summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Veillard <veillard@redhat.com>2005-12-02 12:11:06 +0000
committerDaniel Veillard <veillard@redhat.com>2005-12-02 12:11:06 +0000
commit37ecc6244368aac51c0b21d7af7238dcf28404f1 (patch)
tree859cb5aaf49286c67980ac45bc4912c32d238a9b /configure.in
parentAdding missing Makefile.am, daniel (diff)
downloadlibvirt-37ecc6244368aac51c0b21d7af7238dcf28404f1.tar.gz
libvirt-37ecc6244368aac51c0b21d7af7238dcf28404f1.tar.bz2
libvirt-37ecc6244368aac51c0b21d7af7238dcf28404f1.zip
* configure.in src/Makefile.am: more warnings from compiler and
link static in work environement Daniel
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 6e049c8c7..bd57d6e0a 100644
--- a/configure.in
+++ b/configure.in
@@ -47,6 +47,19 @@ test "x$U" != "x" && AC_MSG_ERROR(Compiler not ANSI compliant)
AM_PROG_LIBTOOL
+dnl
+dnl specific tests to setup DV devel environments with debug etc ...
+dnl
+if [[ "${LOGNAME}" = "veillard" -a "`pwd`" = "/u/veillard/libxen" ]] ; then
+ if test "${GCC}" = "yes" ; then
+ CFLAGS="-g -O -pedantic -W -Wformat -Wunused -Wimplicit -Wreturn-type -Wswitch -Wcomment -Wtrigraphs -Wformat -Wchar-subscripts -Wuninitialized -Wparentheses -Wshadow -Wpointer-arith -Wcast-align -Wwrite-strings -Waggregate-return -Wstrict-prototypes -Wmissing-prototypes -Wnested-externs -Winline -Wredundant-decls -Wall"
+ fi
+ STATIC_BINARIES="-static"
+else
+ STATIC_BINARIES=
+fi
+AC_SUBST(STATIC_BINARIES)
+
dnl search for the low level Xen library
AC_SEARCH_LIBS(xc_domain_create, [xenctrl], [], [AC_MSG_ERROR([Xen control library not found])])
AC_SEARCH_LIBS(xs_read, [xenstore], [], [AC_MSG_ERROR([Xen store library not found])])