aboutsummaryrefslogtreecommitdiff
path: root/daemon
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@cardoe.com>2012-08-12 23:44:48 -0500
committerDaniel Veillard <veillard@redhat.com>2012-08-15 21:40:38 +0800
commit910041bac8867c807290a40a883af0ac0b7495a3 (patch)
tree42c902ac08592b3e2901d3ccdc9f7c197ac1a881 /daemon
parentFix man page file paths to real paths (diff)
downloadlibvirt-910041bac8867c807290a40a883af0ac0b7495a3.tar.gz
libvirt-910041bac8867c807290a40a883af0ac0b7495a3.tar.bz2
libvirt-910041bac8867c807290a40a883af0ac0b7495a3.zip
Replace unset REMOTE_PID_FILE with proper value
REMOTE_PID_FILE is no longer used in the source or the build process but the man page still used it resulting in no file name being displayed. The same value that the libvirtd daemon code uses is now used in the man page.
Diffstat (limited to 'daemon')
-rw-r--r--daemon/Makefile.am4
-rw-r--r--daemon/libvirtd.pod.in6
2 files changed, 4 insertions, 6 deletions
diff --git a/daemon/Makefile.am b/daemon/Makefile.am
index c15c785c6..b00fc13bc 100644
--- a/daemon/Makefile.am
+++ b/daemon/Makefile.am
@@ -87,7 +87,6 @@ libvirtd.8: $(srcdir)/libvirtd.8.in
sed \
-e 's!SYSCONFDIR!$(sysconfdir)!g' \
-e 's!LOCALSTATEDIR!$(localstatedir)!g' \
- -e 's!REMOTE_PID_FILE!$(REMOTE_PID_FILE)!g' \
< $< > $@-t
mv $@-t $@
@@ -99,8 +98,7 @@ libvirtd_CFLAGS = \
$(XDR_CFLAGS) $(POLKIT_CFLAGS) $(DBUS_CFLAGS) $(LIBNL_CFLAGS) \
$(WARN_CFLAGS) \
$(COVERAGE_CFLAGS) \
- -DQEMUD_PID_FILE="\"$(QEMUD_PID_FILE)\"" \
- -DREMOTE_PID_FILE="\"$(REMOTE_PID_FILE)\""
+ -DQEMUD_PID_FILE="\"$(QEMUD_PID_FILE)\""
libvirtd_LDFLAGS = \
$(WARN_CFLAGS) \
diff --git a/daemon/libvirtd.pod.in b/daemon/libvirtd.pod.in
index 7dc8d83ea..2b68cab0f 100644
--- a/daemon/libvirtd.pod.in
+++ b/daemon/libvirtd.pod.in
@@ -104,7 +104,7 @@ The TLS B<Server> certificate libvirtd will use.
The TLS B<Server> private key libvirtd will use.
-=item F<REMOTE_PID_FILE>
+=item F<LOCALSTATEDIR/run/libvirtd.pid>
The PID file to use, unless overridden by the B<-p>|B<--pid-file> option.
@@ -121,8 +121,8 @@ To retrieve the version of libvirtd:
To start libvirtd, instructing it to daemonize and create a PID file:
# libvirtd -d
- # ls -la REMOTE_PID_FILE
- -rw-r--r-- 1 root root 6 Jul 9 02:40 REMOTE_PID_FILE
+ # ls -la LOCALSTATEDIR/run/libvirtd.pid
+ -rw-r--r-- 1 root root 6 Jul 9 02:40 LOCALSTATEDIR/run/libvirtd.pid
#
=head1 BUGS