aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@cardoe.com>2012-09-17 20:27:06 -0500
committerEric Blake <eblake@redhat.com>2012-09-19 08:27:01 -0600
commitb95ad92e058d3b25b9fc0a9f48cf21c57c29e0b5 (patch)
treef6223ebecf35348d10c3c024325d6c0938643065 /libvirt.spec.in
parentvirsh: Rename QEmu to QEMU to match upstream (diff)
downloadlibvirt-b95ad92e058d3b25b9fc0a9f48cf21c57c29e0b5.tar.gz
libvirt-b95ad92e058d3b25b9fc0a9f48cf21c57c29e0b5.tar.bz2
libvirt-b95ad92e058d3b25b9fc0a9f48cf21c57c29e0b5.zip
build: define WITH_INTERFACE for the driver
Based exclusively on work by Eric Blake in a patch posted with the same subject. However some modifications related to comments and my plans to add another backend. Added WITH_INTERFACE as the only automake variable deciding whether to build the driver and using WITH_NETCF to identify that we're wanting to use the netcf library as the backend. * configure.ac: Added with_interface * src/interface/netcf_driver.c: Renamed.. * src/interface/interface_backend_netcf.c: ..to this to match storage. * src/interface/netcf_driver.h: Renamed.. * src/interface/interface_driver.h: ..to this. * daemon/Makefile.am: Respect WITH_INTERFACE and WITH_NETCF. * libvirt.spec.in: Add RPM support for --with-interface
Diffstat (limited to 'libvirt.spec.in')
-rw-r--r--libvirt.spec.in18
1 files changed, 12 insertions, 6 deletions
diff --git a/libvirt.spec.in b/libvirt.spec.in
index 8c4c08dfc..119273914 100644
--- a/libvirt.spec.in
+++ b/libvirt.spec.in
@@ -70,6 +70,7 @@
%define with_parallels 0%{!?_without_parallels:1}
# Then the secondary host drivers, which run inside libvirtd
+%define with_interface 0%{!?_without_interface:%{server_drivers}}
%define with_network 0%{!?_without_network:%{server_drivers}}
%define with_storage_fs 0%{!?_without_storage_fs:%{server_drivers}}
%define with_storage_lvm 0%{!?_without_storage_lvm:%{server_drivers}}
@@ -207,6 +208,11 @@
%define with_hal 0%{!?_without_hal:%{server_drivers}}
%endif
+# interface requires netcf
+%if ! 0%{?with_netcf}
+%define with_interface 0
+%endif
+
# Enable yajl library for JSON mode with QEMU
%if 0%{?fedora} >= 13 || 0%{?rhel} >= 6
%define with_yajl 0%{!?_without_yajl:%{server_drivers}}
@@ -226,6 +232,7 @@
# Disable some drivers when building without libvirt daemon.
# The logic is the same as in configure.ac
%if ! %{with_libvirtd}
+%define with_interface 0
%define with_network 0
%define with_qemu 0
%define with_lxc 0
@@ -281,12 +288,6 @@
%define with_nodedev 0
%endif
-%if %{with_netcf}
-%define with_interface 1
-%else
-%define with_interface 0
-%endif
-
%if %{with_storage_fs} || %{with_storage_mpath} || %{with_storage_iscsi} || %{with_storage_lvm} || %{with_storage_disk}
%define with_storage 1
%else
@@ -1113,6 +1114,10 @@ of recent versions of Linux (and other OSes).
%define _with_rhel5_api --with-rhel5-api
%endif
+%if ! %{with_interface}
+%define _without_interface --without-interface
+%endif
+
%if ! %{with_network}
%define _without_network --without-network
%endif
@@ -1249,6 +1254,7 @@ autoreconf -if
%{?_without_hyperv} \
%{?_without_vmware} \
%{?_without_parallels} \
+ %{?_without_interface} \
%{?_without_network} \
%{?_with_rhel5_api} \
%{?_without_storage_fs} \