aboutsummaryrefslogtreecommitdiff
path: root/tools
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@cardoe.com>2012-09-17 20:27:06 -0500
committerEric Blake <eblake@redhat.com>2012-09-19 08:27:01 -0600
commitb95ad92e058d3b25b9fc0a9f48cf21c57c29e0b5 (patch)
treef6223ebecf35348d10c3c024325d6c0938643065 /tools
parentvirsh: Rename QEmu to QEMU to match upstream (diff)
downloadlibvirt-b95ad92e058d3b25b9fc0a9f48cf21c57c29e0b5.tar.gz
libvirt-b95ad92e058d3b25b9fc0a9f48cf21c57c29e0b5.tar.bz2
libvirt-b95ad92e058d3b25b9fc0a9f48cf21c57c29e0b5.zip
build: define WITH_INTERFACE for the driver
Based exclusively on work by Eric Blake in a patch posted with the same subject. However some modifications related to comments and my plans to add another backend. Added WITH_INTERFACE as the only automake variable deciding whether to build the driver and using WITH_NETCF to identify that we're wanting to use the netcf library as the backend. * configure.ac: Added with_interface * src/interface/netcf_driver.c: Renamed.. * src/interface/interface_backend_netcf.c: ..to this to match storage. * src/interface/netcf_driver.h: Renamed.. * src/interface/interface_driver.h: ..to this. * daemon/Makefile.am: Respect WITH_INTERFACE and WITH_NETCF. * libvirt.spec.in: Add RPM support for --with-interface
Diffstat (limited to 'tools')
-rw-r--r--tools/virsh.c5
1 files changed, 4 insertions, 1 deletions
diff --git a/tools/virsh.c b/tools/virsh.c
index 6a72412ba..5447376be 100644
--- a/tools/virsh.c
+++ b/tools/virsh.c
@@ -2707,8 +2707,11 @@ vshShowVersion(vshControl *ctl ATTRIBUTE_UNUSED)
#ifdef WITH_BRIDGE
vshPrint(ctl, " Bridging");
#endif
-#ifdef WITH_NETCF
+#if defined(WITH_INTERFACE)
vshPrint(ctl, " Interface");
+# if defined(WITH_NETCF)
+ vshPrint(ctl, " netcf");
+# endif
#endif
#ifdef WITH_NWFILTER
vshPrint(ctl, " Nwfilter");