aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnulib/tests/Makefile.am')
-rw-r--r--gnulib/tests/Makefile.am401
1 files changed, 0 insertions, 401 deletions
diff --git a/gnulib/tests/Makefile.am b/gnulib/tests/Makefile.am
deleted file mode 100644
index b1da7680a..000000000
--- a/gnulib/tests/Makefile.am
+++ /dev/null
@@ -1,401 +0,0 @@
-## DO NOT EDIT! GENERATED AUTOMATICALLY!
-## Process this file with automake to produce Makefile.in.
-# Copyright (C) 2002-2009 Free Software Foundation, Inc.
-#
-# This file is free software, distributed under the terms of the GNU
-# General Public License. As a special exception to the GNU General
-# Public License, this file may be distributed as part of a program
-# that contains a configuration script generated by Autoconf, under
-# the same distribution terms as the rest of that program.
-#
-# Generated by gnulib-tool.
-
-AUTOMAKE_OPTIONS = 1.5 foreign
-
-SUBDIRS =
-TESTS =
-TESTS_ENVIRONMENT =
-noinst_PROGRAMS =
-check_PROGRAMS =
-noinst_HEADERS =
-noinst_LIBRARIES =
-check_LIBRARIES = libtests.a
-EXTRA_DIST =
-BUILT_SOURCES =
-SUFFIXES =
-MOSTLYCLEANFILES = core *.stackdump
-MOSTLYCLEANDIRS =
-CLEANFILES =
-DISTCLEANFILES =
-MAINTAINERCLEANFILES =
-
-AM_CPPFLAGS = \
- -I. -I$(srcdir) \
- -I../.. -I$(srcdir)/../.. \
- -I../../gnulib/lib -I$(srcdir)/../../gnulib/lib
-
-LDADD = libtests.a ../../gnulib/lib/libgnu.la libtests.a $(LIBTESTS_LIBDEPS)
-
-libtests_a_SOURCES =
-libtests_a_LIBADD = $(gltests_LIBOBJS)
-libtests_a_DEPENDENCIES = $(gltests_LIBOBJS)
-EXTRA_libtests_a_SOURCES =
-AM_LIBTOOLFLAGS = --preserve-dup-deps
-
-## begin gnulib module accept
-
-
-EXTRA_DIST += accept.c w32sock.h
-
-EXTRA_libtests_a_SOURCES += accept.c
-
-## end gnulib module accept
-
-## begin gnulib module alloca-opt-tests
-
-TESTS += test-alloca-opt
-check_PROGRAMS += test-alloca-opt
-
-EXTRA_DIST += test-alloca-opt.c
-
-## end gnulib module alloca-opt-tests
-
-## begin gnulib module arpa_inet-tests
-
-TESTS += test-arpa_inet
-check_PROGRAMS += test-arpa_inet
-
-EXTRA_DIST += test-arpa_inet.c
-
-## end gnulib module arpa_inet-tests
-
-## begin gnulib module bind
-
-
-EXTRA_DIST += bind.c w32sock.h
-
-EXTRA_libtests_a_SOURCES += bind.c
-
-## end gnulib module bind
-
-## begin gnulib module c-ctype-tests
-
-TESTS += test-c-ctype
-check_PROGRAMS += test-c-ctype
-
-EXTRA_DIST += test-c-ctype.c
-
-## end gnulib module c-ctype-tests
-
-## begin gnulib module errno-tests
-
-TESTS += test-errno
-check_PROGRAMS += test-errno
-
-EXTRA_DIST += test-errno.c
-
-## end gnulib module errno-tests
-
-## begin gnulib module fseeko-tests
-
-TESTS += test-fseeko.sh
-TESTS_ENVIRONMENT += EXEEXT='@EXEEXT@' srcdir='$(srcdir)'
-check_PROGRAMS += test-fseeko
-EXTRA_DIST += test-fseeko.c test-fseeko.sh
-
-## end gnulib module fseeko-tests
-
-## begin gnulib module getaddrinfo-tests
-
-TESTS += test-getaddrinfo
-check_PROGRAMS += test-getaddrinfo
-test_getaddrinfo_LDADD = $(LDADD) @GETADDRINFO_LIB@ @LIBINTL@
-
-EXTRA_DIST += test-getaddrinfo.c
-
-## end gnulib module getaddrinfo-tests
-
-## begin gnulib module getdelim-tests
-
-TESTS += test-getdelim
-check_PROGRAMS += test-getdelim
-MOSTLYCLEANFILES += test-getdelim.txt
-EXTRA_DIST += test-getdelim.c
-
-## end gnulib module getdelim-tests
-
-## begin gnulib module gethostname-tests
-
-TESTS += test-gethostname
-check_PROGRAMS += test-gethostname
-EXTRA_DIST += test-gethostname.c
-
-## end gnulib module gethostname-tests
-
-## begin gnulib module getline-tests
-
-TESTS += test-getline
-check_PROGRAMS += test-getline
-MOSTLYCLEANFILES += test-getline.txt
-EXTRA_DIST += test-getline.c
-
-## end gnulib module getline-tests
-
-## begin gnulib module gettimeofday-tests
-
-TESTS += test-gettimeofday
-check_PROGRAMS += test-gettimeofday
-
-EXTRA_DIST += test-gettimeofday.c
-
-## end gnulib module gettimeofday-tests
-
-## begin gnulib module listen
-
-
-EXTRA_DIST += listen.c w32sock.h
-
-EXTRA_libtests_a_SOURCES += listen.c
-
-## end gnulib module listen
-
-## begin gnulib module lseek-tests
-
-TESTS += test-lseek.sh
-TESTS_ENVIRONMENT += EXEEXT='@EXEEXT@' srcdir='$(srcdir)'
-check_PROGRAMS += test-lseek
-EXTRA_DIST += test-lseek.c test-lseek.sh
-
-## end gnulib module lseek-tests
-
-## begin gnulib module lstat-tests
-
-TESTS += test-lstat
-check_PROGRAMS += test-lstat
-EXTRA_DIST += test-lstat.c
-
-## end gnulib module lstat-tests
-
-## begin gnulib module netdb-tests
-
-TESTS += test-netdb
-check_PROGRAMS += test-netdb
-
-EXTRA_DIST += test-netdb.c
-
-## end gnulib module netdb-tests
-
-## begin gnulib module netinet_in-tests
-
-TESTS += test-netinet_in
-check_PROGRAMS += test-netinet_in
-
-EXTRA_DIST += test-netinet_in.c
-
-## end gnulib module netinet_in-tests
-
-## begin gnulib module perror-tests
-
-TESTS += test-perror.sh
-TESTS_ENVIRONMENT += EXEEXT='@EXEEXT@' srcdir='$(srcdir)'
-check_PROGRAMS += test-perror
-EXTRA_DIST += test-perror.c test-perror.sh
-
-## end gnulib module perror-tests
-
-## begin gnulib module poll-tests
-
-TESTS += test-poll
-check_PROGRAMS += test-poll
-test_poll_LDADD = $(LDADD) @LIBSOCKET@
-EXTRA_DIST += test-poll.c
-
-## end gnulib module poll-tests
-
-## begin gnulib module random_r-tests
-
-TESTS += test-random_r
-check_PROGRAMS += test-random_r
-
-EXTRA_DIST += test-random_r.c
-
-## end gnulib module random_r-tests
-
-## begin gnulib module snprintf-tests
-
-TESTS += test-snprintf
-check_PROGRAMS += test-snprintf
-
-EXTRA_DIST += test-snprintf.c
-
-## end gnulib module snprintf-tests
-
-## begin gnulib module sockets
-
-libtests_a_SOURCES += sockets.h sockets.c
-
-## end gnulib module sockets
-
-## begin gnulib module sockets-tests
-
-TESTS += test-sockets
-check_PROGRAMS += test-sockets
-test_sockets_LDADD = $(LDADD) @LIBSOCKET@
-EXTRA_DIST += test-sockets.c
-
-## end gnulib module sockets-tests
-
-## begin gnulib module stdbool-tests
-
-TESTS += test-stdbool
-check_PROGRAMS += test-stdbool
-
-EXTRA_DIST += test-stdbool.c
-
-## end gnulib module stdbool-tests
-
-## begin gnulib module stdint-tests
-
-TESTS += test-stdint
-check_PROGRAMS += test-stdint
-
-EXTRA_DIST += test-stdint.c
-
-## end gnulib module stdint-tests
-
-## begin gnulib module stdio-tests
-
-TESTS += test-stdio
-check_PROGRAMS += test-stdio
-
-EXTRA_DIST += test-stdio.c
-
-## end gnulib module stdio-tests
-
-## begin gnulib module stdlib-tests
-
-TESTS += test-stdlib
-check_PROGRAMS += test-stdlib
-
-EXTRA_DIST += test-stdlib.c
-
-## end gnulib module stdlib-tests
-
-## begin gnulib module strerror-tests
-
-TESTS += test-strerror
-check_PROGRAMS += test-strerror
-EXTRA_DIST += test-strerror.c
-
-## end gnulib module strerror-tests
-
-## begin gnulib module string-tests
-
-TESTS += test-string
-check_PROGRAMS += test-string
-
-EXTRA_DIST += test-string.c
-
-## end gnulib module string-tests
-
-## begin gnulib module sys_select-tests
-
-TESTS += test-sys_select
-check_PROGRAMS += test-sys_select
-
-EXTRA_DIST += test-sys_select.c
-
-## end gnulib module sys_select-tests
-
-## begin gnulib module sys_socket-tests
-
-TESTS += test-sys_socket
-check_PROGRAMS += test-sys_socket
-
-EXTRA_DIST += test-sys_socket.c
-
-## end gnulib module sys_socket-tests
-
-## begin gnulib module sys_stat-tests
-
-TESTS += test-sys_stat
-check_PROGRAMS += test-sys_stat
-
-EXTRA_DIST += test-sys_stat.c
-
-## end gnulib module sys_stat-tests
-
-## begin gnulib module sys_time-tests
-
-TESTS += test-sys_time
-check_PROGRAMS += test-sys_time
-
-EXTRA_DIST += test-sys_time.c
-
-## end gnulib module sys_time-tests
-
-## begin gnulib module time-tests
-
-TESTS += test-time
-check_PROGRAMS += test-time
-
-EXTRA_DIST += test-time.c
-
-## end gnulib module time-tests
-
-## begin gnulib module unistd-tests
-
-TESTS += test-unistd
-check_PROGRAMS += test-unistd
-
-EXTRA_DIST += test-unistd.c
-
-## end gnulib module unistd-tests
-
-## begin gnulib module vasnprintf-tests
-
-TESTS += test-vasnprintf
-check_PROGRAMS += test-vasnprintf
-
-EXTRA_DIST += test-vasnprintf.c
-
-## end gnulib module vasnprintf-tests
-
-## begin gnulib module vasprintf-tests
-
-TESTS += test-vasprintf
-check_PROGRAMS += test-vasprintf
-
-EXTRA_DIST += test-vasprintf.c
-
-## end gnulib module vasprintf-tests
-
-## begin gnulib module vc-list-files-tests
-
-TESTS += test-vc-list-files-git.sh
-TESTS += test-vc-list-files-cvs.sh
-TESTS_ENVIRONMENT += PATH='$(abs_aux_dir)':"$$PATH"
-EXTRA_DIST += test-vc-list-files-git.sh test-vc-list-files-cvs.sh
-
-## end gnulib module vc-list-files-tests
-
-## begin gnulib module wchar-tests
-
-TESTS += test-wchar
-check_PROGRAMS += test-wchar
-
-EXTRA_DIST += test-wchar.c
-
-## end gnulib module wchar-tests
-
-# Clean up after Solaris cc.
-clean-local:
- rm -rf SunWS_cache
-
-mostlyclean-local: mostlyclean-generic
- @for dir in '' $(MOSTLYCLEANDIRS); do \
- if test -n "$$dir" && test -d $$dir; then \
- echo "rmdir $$dir"; rmdir $$dir; \
- fi; \
- done; \
- :