summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2023-09-21 07:29:30 -0400
committerMike Pagano <mpagano@gentoo.org>2023-09-21 07:29:30 -0400
commit6788828261a8548c2a47c35ba7ccb7bc2fb1c2a6 (patch)
treec8cafc0b70fb52251352bedd94c35e6e240dc891
parentLinux patch 5.10.195 (diff)
downloadlinux-patches-6788828261a8548c2a47c35ba7ccb7bc2fb1c2a6.tar.gz
linux-patches-6788828261a8548c2a47c35ba7ccb7bc2fb1c2a6.tar.bz2
linux-patches-6788828261a8548c2a47c35ba7ccb7bc2fb1c2a6.zip
Linux patch 5.10.1965.10-206
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
-rw-r--r--0000_README4
-rw-r--r--1195_linux-5.10.196.patch33
2 files changed, 37 insertions, 0 deletions
diff --git a/0000_README b/0000_README
index 08e7549f..f7687328 100644
--- a/0000_README
+++ b/0000_README
@@ -823,6 +823,10 @@ Patch: 1194_linux-5.10.195.patch
From: https://www.kernel.org
Desc: Linux 5.10.195
+Patch: 1195_linux-5.10.196.patch
+From: https://www.kernel.org
+Desc: Linux 5.10.196
+
Patch: 1500_XATTR_USER_PREFIX.patch
From: https://bugs.gentoo.org/show_bug.cgi?id=470644
Desc: Support for namespace user.pax.* on tmpfs.
diff --git a/1195_linux-5.10.196.patch b/1195_linux-5.10.196.patch
new file mode 100644
index 00000000..1c2b574a
--- /dev/null
+++ b/1195_linux-5.10.196.patch
@@ -0,0 +1,33 @@
+diff --git a/Makefile b/Makefile
+index 006700fbb6525..7021aa85afd1e 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,7 +1,7 @@
+ # SPDX-License-Identifier: GPL-2.0
+ VERSION = 5
+ PATCHLEVEL = 10
+-SUBLEVEL = 195
++SUBLEVEL = 196
+ EXTRAVERSION =
+ NAME = Dare mighty things
+
+diff --git a/fs/configfs/dir.c b/fs/configfs/dir.c
+index 0b7e9ab517d58..12388ed4faa59 100644
+--- a/fs/configfs/dir.c
++++ b/fs/configfs/dir.c
+@@ -479,7 +479,6 @@ static struct dentry * configfs_lookup(struct inode *dir,
+ if (!configfs_dirent_is_ready(parent_sd))
+ goto out;
+
+- spin_lock(&configfs_dirent_lock);
+ list_for_each_entry(sd, &parent_sd->s_children, s_sibling) {
+ if (sd->s_type & CONFIGFS_NOT_PINNED) {
+ const unsigned char * name = configfs_get_name(sd);
+@@ -492,7 +491,6 @@ static struct dentry * configfs_lookup(struct inode *dir,
+ break;
+ }
+ }
+- spin_unlock(&configfs_dirent_lock);
+
+ if (!found) {
+ /*