summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2021-05-07 07:35:52 -0400
committerMike Pagano <mpagano@gentoo.org>2021-05-07 07:35:52 -0400
commiteb696d683b677541b94ce1efa142516987be5014 (patch)
treeb87eaad457cf091da501c95de807c968d23e14fa
parentUpdate README (diff)
downloadlinux-patches-eb696d683b677541b94ce1efa142516987be5014.tar.gz
linux-patches-eb696d683b677541b94ce1efa142516987be5014.tar.bz2
linux-patches-eb696d683b677541b94ce1efa142516987be5014.zip
Update wireguard to 1.0.20210424
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
-rw-r--r--0000_README2
-rwxr-xr-x2400_wireguard-backport-v1.0.20210424.patch (renamed from 2400_wireguard-backport-v1.0.20210316.patch)19
2 files changed, 16 insertions, 5 deletions
diff --git a/0000_README b/0000_README
index a686ee7d..323a0e3c 100644
--- a/0000_README
+++ b/0000_README
@@ -519,7 +519,7 @@ Patch: 2000_BT-Check-key-sizes-only-if-Secure-Simple-Pairing-enabled.patch
From: https://lore.kernel.org/linux-bluetooth/20190522070540.48895-1-marcel@holtmann.org/raw
Desc: Bluetooth: Check key sizes only when Secure Simple Pairing is enabled. See bug #686758
-Patch: 2400_wireguard-backport-v1.0.20210316.patch
+Patch: 2400_wireguard-backport-v1.0.20210424.patch
From: https://git.zx2c4.com/wireguard-linux/
Desc: Extremely simple yet fast and modern VPN that utilizes state-of-the-art cryptography
diff --git a/2400_wireguard-backport-v1.0.20210316.patch b/2400_wireguard-backport-v1.0.20210424.patch
index ab5ae8ce..34d7aa54 100755
--- a/2400_wireguard-backport-v1.0.20210316.patch
+++ b/2400_wireguard-backport-v1.0.20210424.patch
@@ -371,7 +371,9 @@ exit 0
+ tristate
--- b/lib/crypto/Makefile
+++ b/lib/crypto/Makefile
-@@ -3,11 +3,43 @@
+@@ -1,13 +1,45 @@
+ # SPDX-License-Identifier: GPL-2.0
+
-obj-$(CONFIG_CRYPTO_LIB_AES) += libaes.o
-libaes-y := aes.o
+# chacha is used by the /dev/random driver which is always builtin
@@ -2280,7 +2282,10 @@ exit 0
$(src)/sha256-core.S_shipped: $(src)/sha256-armv4.pl
$(call cmd,perl)
-@@ -70 +78,6 @@
+@@ -67,4 +75,9 @@
+ $(call cmd,perl)
+ endif
+
-clean-files += sha256-core.S sha512-core.S
+clean-files += poly1305-core.S sha256-core.S sha512-core.S
+
@@ -3162,7 +3167,10 @@ exit 0
# suspend and hibernation support
--- b/arch/mips/crypto/Makefile
+++ b/arch/mips/crypto/Makefile
-@@ -6,0 +7,18 @@
+@@ -4,3 +4,21 @@
+ #
+
+ obj-$(CONFIG_CRYPTO_CRC32_MIPS) += crc32-mips.o
+
+obj-$(CONFIG_CRYPTO_CHACHA_MIPS) += chacha-mips.o
+chacha-mips-y := chacha-core.o chacha-glue.o
@@ -13269,7 +13277,10 @@ exit 0
endif
ifeq ($(sha1_ni_supported),yes)
sha1-ssse3-y += sha1_ni_asm.o
-@@ -117,0 +128,5 @@
+@@ -115,3 +125,8 @@
+ endif
+ sha512-ssse3-y := sha512-ssse3-asm.o sha512-avx-asm.o sha512-avx2-asm.o sha512_ssse3_glue.o
+ crct10dif-pclmul-y := crct10dif-pcl-asm_64.o crct10dif-pclmul_glue.o
+
+quiet_cmd_perlasm = PERLASM $@
+ cmd_perlasm = $(PERL) $< > $@