aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOzan Caglayan <ozan@pardus.org.tr>2010-10-01 17:07:03 +0200
committerDaniel Lezcano <dlezcano@fr.ibm.com>2010-10-01 17:07:03 +0200
commita52455f2d5b152aa62dadd46e3d0ea65c30645b9 (patch)
tree6713dbfebf688729841d9013bb48e4ec597a9117
parentinitialize capabilities in checkpoint and restart commands (diff)
downloadlxc-a52455f2d5b152aa62dadd46e3d0ea65c30645b9.tar.gz
lxc-a52455f2d5b152aa62dadd46e3d0ea65c30645b9.tar.bz2
lxc-a52455f2d5b152aa62dadd46e3d0ea65c30645b9.zip
Fix linking problems with libcap
Correctly link to libcap to avoid underlinking and unused direct dependency problems. Signed-off-by: Ozan Caglayan <ozan@pardus.org.tr> Signed-off-by: Daniel Lezcano <dlezcano@fr.ibm.com>
-rw-r--r--src/lxc/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/lxc/Makefile.am b/src/lxc/Makefile.am
index b851e2c..d2ee4d9 100644
--- a/src/lxc/Makefile.am
+++ b/src/lxc/Makefile.am
@@ -59,7 +59,7 @@ liblxc_so_LDFLAGS = \
-shared \
-Wl,-soname,liblxc.so.$(firstword $(subst ., ,$(VERSION)))
-liblxc_so_LDADD = -lutil
+liblxc_so_LDADD = -lutil $(CAP_LIBS)
bin_SCRIPTS = \
lxc-ps \