aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Lezcano <dlezcano@fr.ibm.com>2009-04-26 11:49:53 +0200
committerDaniel Lezcano <dlezcano@fr.ibm.com>2009-04-26 11:49:53 +0200
commit6b9f39176cc9d898d339f8344291b922bfde19a8 (patch)
treedd2dce3d8954e04c0aa261b798e09da04f628dd9
parentrename configure.in to configure.ac (diff)
downloadlxc-6b9f39176cc9d898d339f8344291b922bfde19a8.tar.gz
lxc-6b9f39176cc9d898d339f8344291b922bfde19a8.tar.bz2
lxc-6b9f39176cc9d898d339f8344291b922bfde19a8.zip
Revert "make the log fd thread safe"lxc_0_6_2
This reverts commit 2c9bd0073f29573181dc16a840c674dacc8a33fd. Pointless and useless right now and certainly wrong as several threads in the library may want to log to the same, to be defined later.
-rw-r--r--src/lxc/log.c7
1 files changed, 5 insertions, 2 deletions
diff --git a/src/lxc/log.c b/src/lxc/log.c
index 452b973..496805c 100644
--- a/src/lxc/log.c
+++ b/src/lxc/log.c
@@ -35,8 +35,11 @@
#include <lxc/log.h>
-static __thread int lxc_log_fd = 2;
-static __thread char log_prefix[LXC_LOG_PREFIX_SIZE] = "lxc";
+#define LXC_LOG_PREFIX_SIZE 32
+#define LXC_LOG_BUFFER_SIZE 512
+
+int lxc_log_fd = 2;
+static char log_prefix[LXC_LOG_PREFIX_SIZE] = "lxc";
lxc_log_define(lxc_log, lxc);