aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichel Normand <normand@fr.ibm.com>2009-11-04 15:14:30 +0100
committerDaniel Lezcano <dlezcano@fr.ibm.com>2009-11-04 15:14:30 +0100
commitd5cf438682963ac84c3617941032ba623d4ac9b2 (patch)
tree87246f2c017729535b5b993dd1ccf1df3efb9e56
parentconfigure.ac - allow user to switch off/on documentation generation (diff)
downloadlxc-d5cf438682963ac84c3617941032ba623d4ac9b2.tar.gz
lxc-d5cf438682963ac84c3617941032ba623d4ac9b2.tar.bz2
lxc-d5cf438682963ac84c3617941032ba623d4ac9b2.zip
lxc: lxc version to reflect string in AC_INIT (V2)
I changed the code to have lxc version to reflect the string set in AC_INIT of configure.ac rather than to report only the 3 first digits update: use PACKAGE_VERSION in place of VERSION Signed-off-by: Michel Normand <normand@fr.ibm.com> Signed-off-by: Daniel Lezcano <dlezcano@fr.ibm.com>
-rw-r--r--configure.ac8
-rw-r--r--doc/lxc.sgml.in2
-rw-r--r--lxc.pc.in2
-rw-r--r--src/lxc/lxc-version.in2
4 files changed, 3 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index e44d40a..a9ca211 100644
--- a/configure.ac
+++ b/configure.ac
@@ -62,14 +62,6 @@ if test "x$GCC" = "xyes"; then
CFLAGS="$CFLAGS -Wall"
fi
-LXC_MAJOR_VERSION=$(echo $PACKAGE_VERSION | cut -d. -f1)
-LXC_MINOR_VERSION=$(echo $PACKAGE_VERSION | cut -d. -f2)
-LXC_MICRO_VERSION=$(echo $PACKAGE_VERSION | cut -d. -f3)
-
-AC_SUBST(LXC_MAJOR_VERSION)
-AC_SUBST(LXC_MINOR_VERSION)
-AC_SUBST(LXC_MICRO_VERSION)
-
AC_CONFIG_FILES([
Makefile
lxc.pc
diff --git a/doc/lxc.sgml.in b/doc/lxc.sgml.in
index 961a967..af2efab 100644
--- a/doc/lxc.sgml.in
+++ b/doc/lxc.sgml.in
@@ -39,7 +39,7 @@ Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
<refentrytitle>lxc</refentrytitle>
<manvolnum>7</manvolnum>
<refmiscinfo>
- Version @LXC_MAJOR_VERSION@.@LXC_MINOR_VERSION@.@LXC_MICRO_VERSION@
+ Version @PACKAGE_VERSION@
</refmiscinfo>
</refmeta>
diff --git a/lxc.pc.in b/lxc.pc.in
index 188cbe5..cd513c0 100644
--- a/lxc.pc.in
+++ b/lxc.pc.in
@@ -5,7 +5,7 @@ includedir=@INCLUDEDIR@
Name: lxc
Description: linux container tools
-Version: @LXC_MAJOR_VERSION@.@LXC_MINOR_VERSION@.@LXC_MICRO_VERSION@
+Version: @PACKAGE_VERSION@
URL: http://lxc.sourceforge.net
Libs: -L${libdir} -llxc -lutil
Cflags: -I${includedir}
diff --git a/src/lxc/lxc-version.in b/src/lxc/lxc-version.in
index dcc88b2..1bd055a 100644
--- a/src/lxc/lxc-version.in
+++ b/src/lxc/lxc-version.in
@@ -1,3 +1,3 @@
#!/bin/bash
-echo "lxc version: @LXC_MAJOR_VERSION@.@LXC_MINOR_VERSION@.@LXC_MICRO_VERSION@"
+echo "lxc version: @PACKAGE_VERSION@"