aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--configure.ac16
-rw-r--r--doc/lxc-execute.sgml.in11
-rw-r--r--doc/lxc-start.sgml.in21
-rw-r--r--doc/lxc.conf.sgml.in17
-rw-r--r--doc/lxc.sgml.in2
5 files changed, 44 insertions, 23 deletions
diff --git a/configure.ac b/configure.ac
index 4be78a3..c0a8693 100644
--- a/configure.ac
+++ b/configure.ac
@@ -39,6 +39,7 @@ AS_AC_EXPAND(LIBEXECDIR, $libexecdir)
AS_AC_EXPAND(SYSCONFDIR, $sysconfdir)
AS_AC_EXPAND(DATADIR, $datadir)
AS_AC_EXPAND(LOCALSTATEDIR, $localstatedir)
+AS_AC_EXPAND(DOCDIR, $docdir)
AC_ARG_WITH([config-path],
[AC_HELP_STRING(
@@ -99,6 +100,14 @@ AC_CONFIG_FILES([
doc/common_options.sgml
doc/see_also.sgml
+ doc/examples/Makefile
+ doc/examples/lxc-macvlan.conf
+ doc/examples/lxc-no-netns.conf
+ doc/examples/lxc-empty-netns.conf
+ doc/examples/lxc-phys.conf
+ doc/examples/lxc-veth.conf
+ doc/examples/lxc-complex-config
+
scripts/Makefile
scripts/lxc-debian
scripts/lxc-fedora
@@ -115,13 +124,6 @@ AC_CONFIG_FILES([
src/lxc/lxc-create
src/lxc/lxc-destroy
- doc/examples/Makefile
- doc/examples/lxc-macvlan.conf
- doc/examples/lxc-no-netns.conf
- doc/examples/lxc-empty-netns.conf
- doc/examples/lxc-phys.conf
- doc/examples/lxc-veth.conf
- doc/examples/lxc-complex-config
])
AC_CONFIG_COMMANDS([default],[[]],[[]])
AC_OUTPUT
diff --git a/doc/lxc-execute.sgml.in b/doc/lxc-execute.sgml.in
index 6d5bcd4..ddd3a13 100644
--- a/doc/lxc-execute.sgml.in
+++ b/doc/lxc-execute.sgml.in
@@ -66,17 +66,6 @@ Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
</para>
<para>
- If the container does not exist, it is automatically created and
- destroyed at the end. The command can use the configuration file
- to create itself the container
- like <command>lxc-create</command> would do and will destroy the
- container when the application exits. If the container was
- previously created with the lxc-create command, when the
- application exits, the container is not destroyed and it can be
- reused later.
- </para>
-
- <para>
This command is mainly used when you want to quickly launch an
application in an isolated environment. It will create an
intermediate process allowing you application to daemonize in
diff --git a/doc/lxc-start.sgml.in b/doc/lxc-start.sgml.in
index 7a92519..fdf64c5 100644
--- a/doc/lxc-start.sgml.in
+++ b/doc/lxc-start.sgml.in
@@ -60,10 +60,11 @@ Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
<para>
<command>lxc-start</command> runs the specified command inside
the container specified by name. It will setup the container
- according with the configuration defined previously with the
- lxc-create command and execute the command inside the
- container. The orphan process group and daemon are not supported
- by this command.
+ according the configuration previously defined with the
+ lxc-create command or with the configuration file parameter and
+ execute the command inside the container. If no configuration is
+ defined, the default isolation is used. The orphan process
+ group and daemon are not supported by this command.
If no command is specified, <command>lxc-start</command> will
use the default
@@ -93,6 +94,18 @@ Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
</listitem>
</varlistentry>
+ <varlistentry>
+ <term>
+ <option>-f <replaceable>config_file</replaceable></option>
+ </term>
+ <listitem>
+ <para>
+ Specify the configuration file to configure the virtualization
+ and isolation functionalities for the container.
+ </para>
+ </listitem>
+ </varlistentry>
+
</variablelist>
</refsect1>
diff --git a/doc/lxc.conf.sgml.in b/doc/lxc.conf.sgml.in
index aed8f1f..c128333 100644
--- a/doc/lxc.conf.sgml.in
+++ b/doc/lxc.conf.sgml.in
@@ -318,6 +318,19 @@ Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
</para>
</listitem>
</varlistentry>
+
+ <varlistentry>
+ <term>
+ <option>lxc.mount.entry</option>
+ </term>
+ <listitem>
+ <para>
+ specify a mount point corresponding to a line in the
+ fstab format.
+ </para>
+ </listitem>
+ </varlistentry>
+
</variablelist>
</refsect2>
@@ -579,6 +592,10 @@ Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
<listitem><para></para></listitem>
</varlistentry>
<varlistentry>
+ <term>lxc.mount.entry = /lib /root/myrootfs/lib none ro,bind 0 0</term>
+ <listitem><para></para></listitem>
+ </varlistentry>
+ <varlistentry>
<term>lxc.rootfs = /mnt/rootfs.complex</term>
<listitem><para></para></listitem>
</varlistentry>
diff --git a/doc/lxc.sgml.in b/doc/lxc.sgml.in
index af2efab..8f08ef7 100644
--- a/doc/lxc.sgml.in
+++ b/doc/lxc.sgml.in
@@ -59,7 +59,7 @@ Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
a container with a predefined configuration template, it may
work.
<command>
- @BINDIR@/lxc-execute -n foo -f @SYSCONFDIR@/lxc/lxc-macvlan.conf /bin/bash
+ @BINDIR@/lxc-execute -n foo -f @DOCDIR@/examples/lxc-macvlan.conf /bin/bash
</command>
</para>
</refsect1>