aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorcallmetango <callmetango@users.noreply.github.com>2018-11-06 15:21:50 +0100
committerAnthony G. Basile <blueness@gentoo.org>2018-12-04 10:54:55 -0500
commitc5d38fa48fe5cc72fe10113a9529951060f90144 (patch)
treeb6bc10715c27dcbe178e6964860a2eac116a0c51
parentdev-java/icedtea: fix Manifest (diff)
downloadmusl-c5d38fa48fe5cc72fe10113a9529951060f90144.tar.gz
musl-c5d38fa48fe5cc72fe10113a9529951060f90144.tar.bz2
musl-c5d38fa48fe5cc72fe10113a9529951060f90144.zip
x11-libs/vte: version bump to 0.54.2
Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
-rw-r--r--x11-libs/vte/Manifest4
-rw-r--r--x11-libs/vte/files/vte-0.54.2-musl-remove-W_EXITCODE.patch23
-rw-r--r--x11-libs/vte/metadata.xml3
-rw-r--r--x11-libs/vte/vte-0.54.2.ebuild91
4 files changed, 120 insertions, 1 deletions
diff --git a/x11-libs/vte/Manifest b/x11-libs/vte/Manifest
index 2562feda..546a2dae 100644
--- a/x11-libs/vte/Manifest
+++ b/x11-libs/vte/Manifest
@@ -1 +1,3 @@
-DIST vte-0.28.2.tar.xz 962340 SHA256 86cf0b81aa023fa93ed415653d51c96767f20b2d7334c893caba71e42654b0ae SHA512 d6a50481aaa8946cca3779e0b328fef551be534d70366a75385d1f8ead3fcddec57bed85c7d4bc2d9f34546532129e63083aafa33cbb0efcbc7dc9d66e7c45f6 WHIRLPOOL cf491b80cdfbdda6163ec7562f922f1c449e6e927845de28ad8e0b06b47bbbf092f735fc4b72f6131797d17c02c6172888d4db37a520973118d2bfbacd374c2c
+DIST vte-0.28.2.tar.xz 962340 BLAKE2B 1e4b5977962265be77917ccfc9118ed93232c03d7a16b6c08a27e721fe71f8c1dd1783a439530d7b3d915111cb8cc78281f1e9e351d6a83edd31f224309ca1e9 SHA512 d6a50481aaa8946cca3779e0b328fef551be534d70366a75385d1f8ead3fcddec57bed85c7d4bc2d9f34546532129e63083aafa33cbb0efcbc7dc9d66e7c45f6
+DIST vte-0.54.1-command-notify.patch.xz 3428 BLAKE2B 75b0c22720276300be2e49e8444aa68fed77fb7a6cc6b0e93a5c2d41257626bd60ff1084d68579769cb3d85e7ec567927591746de48e860b138d0c1f24f64cc7 SHA512 a53da569f8168c8e9e21e186dcfc00bf9fdb78a0c767ba35033c1c1e4f836406b4d9bf70ee3e071f6c749fd6f72101a6960d201617bd0bc23021e1eeaac6fd0c
+DIST vte-0.54.2.tar.xz 1087628 BLAKE2B 9e613ff514beef395f88677ebb25d278df3107b90af07f5d7cbebc44f93d5a6784d65b56cca2c3c020bbf20b0f406a933b97678004bbb586e1485f4aeda08aa9 SHA512 214ec69110d6ad6caa9bc41fb741874bfcf27f20f34d3ae745b13903c574f9c854f7e0dadbae3dbc8ce04c5a6eb818a433c50569c1ef802501a9a078385f23fc
diff --git a/x11-libs/vte/files/vte-0.54.2-musl-remove-W_EXITCODE.patch b/x11-libs/vte/files/vte-0.54.2-musl-remove-W_EXITCODE.patch
new file mode 100644
index 00000000..dfbc3668
--- /dev/null
+++ b/x11-libs/vte/files/vte-0.54.2-musl-remove-W_EXITCODE.patch
@@ -0,0 +1,23 @@
+Expanded non-standard W_EXITCODE macro for Musl compatibility
+
+diff -Naur vte-0.54.2.orig/src/widget.cc vte-0.54.2/src/widget.cc
+--- vte-0.54.2.orig/src/widget.cc 2018-09-28 10:06:12.000000000 +0200
++++ vte-0.54.2/src/widget.cc 2018-11-06 15:04:30.275949689 +0100
+@@ -20,8 +20,6 @@
+
+ #include "widget.hh"
+
+-#include <sys/wait.h> // for W_EXITCODE
+-
+ #include <new>
+ #include <string>
+
+@@ -126,7 +124,7 @@
+ Widget::dispose() noexcept
+ {
+ if (m_terminal->terminate_child()) {
+- int status = W_EXITCODE(0, SIGKILL);
++ int status = (0) << 8 | (SIGKILL); // W_EXITCODE(ret, sig)
+ emit_child_exited(status);
+ }
+ }
diff --git a/x11-libs/vte/metadata.xml b/x11-libs/vte/metadata.xml
index 996e7cac..9889b0b1 100644
--- a/x11-libs/vte/metadata.xml
+++ b/x11-libs/vte/metadata.xml
@@ -5,4 +5,7 @@
<email>gnome@gentoo.org</email>
<name>Gentoo GNOME Desktop</name>
</maintainer>
+ <use>
+ <flag name="glade">Installs catalog files for <pkg>dev-util/glade</pkg></flag>
+ </use>
</pkgmetadata>
diff --git a/x11-libs/vte/vte-0.54.2.ebuild b/x11-libs/vte/vte-0.54.2.ebuild
new file mode 100644
index 00000000..5a85452b
--- /dev/null
+++ b/x11-libs/vte/vte-0.54.2.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+VALA_USE_DEPEND="vapigen"
+VALA_MIN_API_VERSION="0.32"
+
+inherit autotools gnome2 vala
+
+DESCRIPTION="Library providing a virtual terminal emulator widget"
+HOMEPAGE="https://wiki.gnome.org/action/show/Apps/Terminal/VTE"
+
+LICENSE="LGPL-2+"
+SLOT="2.91"
+IUSE="+crypt debug glade +introspection vala vanilla"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+REQUIRED_USE="vala? ( introspection )"
+
+SRC_URI="${SRC_URI} !vanilla? ( https://dev.gentoo.org/~leio/distfiles/${PN}-0.54.1-command-notify.patch.xz )"
+
+RDEPEND="
+ >=dev-libs/glib-2.40:2
+ >=dev-libs/libpcre2-10.21
+ >=x11-libs/gtk+-3.16:3[introspection?]
+ >=x11-libs/pango-1.22.0
+
+ sys-libs/ncurses:0=
+ sys-libs/zlib
+
+ crypt? ( >=net-libs/gnutls-3.2.7:0= )
+ glade? ( >=dev-util/glade-3.9:3.10 )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.0:= )
+"
+DEPEND="${RDEPEND}
+ dev-libs/libxml2:2
+ dev-util/glib-utils
+ >=dev-util/gtk-doc-am-1.13
+ >=dev-util/intltool-0.35
+ sys-devel/gettext
+ virtual/pkgconfig
+
+ vala? ( $(vala_depend) )
+"
+RDEPEND="${RDEPEND}
+ !x11-libs/vte:2.90[glade]
+"
+
+src_prepare() {
+ if ! use vanilla; then
+ # First half of http://pkgs.fedoraproject.org/cgit/rpms/vte291.git/tree/vte291-command-notify-scroll-speed.patch
+ # Adds OSC 777 support for desktop notifications in gnome-terminal or elsewhere
+ eapply "${WORKDIR}"/${PN}-0.54.1-command-notify.patch
+ fi
+
+ eapply "${FILESDIR}/${P}-musl-remove-W_EXITCODE.patch"
+ eautoreconf
+
+ use vala && vala_src_prepare
+
+ # build fails because of -Werror with gcc-5.x
+ sed -e 's#-Werror=format=2#-Wformat=2#' -i configure || die "sed failed"
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ local myconf=""
+
+ if [[ ${CHOST} == *-interix* ]]; then
+ myconf="${myconf} --disable-Bsymbolic"
+
+ # interix stropts.h is empty...
+ export ac_cv_header_stropts_h=no
+ fi
+
+ gnome2_src_configure \
+ --disable-static \
+ --with-gtk=3.0 \
+ --with-iconv \
+ $(use_enable debug) \
+ $(use_enable glade glade-catalogue) \
+ $(use_with crypt gnutls) \
+ $(use_enable introspection) \
+ $(use_enable vala) \
+ ${myconf}
+}
+
+src_install() {
+ gnome2_src_install
+ mv "${ED}"/etc/profile.d/vte{,-${SLOT}}.sh || die
+}