summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--20018_all_mysql-5.7.23-add-missing-gcc-8-fix.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/20018_all_mysql-5.7.23-add-missing-gcc-8-fix.patch b/20018_all_mysql-5.7.23-add-missing-gcc-8-fix.patch
new file mode 100644
index 0000000..0463813
--- /dev/null
+++ b/20018_all_mysql-5.7.23-add-missing-gcc-8-fix.patch
@@ -0,0 +1,13 @@
+https://bugs.gentoo.org/662816
+
+--- a/regex/CMakeLists.txt
++++ b/regex/CMakeLists.txt
+@@ -15,6 +15,8 @@
+
+ INCLUDE_DIRECTORIES(${CMAKE_SOURCE_DIR}/include)
+
++INCLUDE(${MYSQL_CMAKE_SCRIPT_DIR}/compile_flags.cmake)
++
+ MY_CHECK_C_COMPILER_FLAG("-Wstringop-truncation" HAVE_STRINGOP_TRUNCATION)
+ IF(HAVE_STRINGOP_TRUNCATION)
+ ADD_COMPILE_FLAGS(