aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gmail.com>2015-02-18 19:19:57 -0500
committerTim Harder <radhermit@gmail.com>2015-02-18 19:20:12 -0500
commit2472ca4ca444e8aae28c82d9ad96f1d8e61c66b4 (patch)
treedc190ef2e04caea8395f647e7e684c004cdcedcc
parentuse symlinks for EAPI 1 and 3 bash libs since they're just dupes (diff)
downloadpkgcore-2472ca4ca444e8aae28c82d9ad96f1d8e61c66b4.tar.gz
pkgcore-2472ca4ca444e8aae28c82d9ad96f1d8e61c66b4.tar.bz2
pkgcore-2472ca4ca444e8aae28c82d9ad96f1d8e61c66b4.zip
fix data file installs for py3
map() returns a map object in py3
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 571bf7e75..afeee305d 100644
--- a/setup.py
+++ b/setup.py
@@ -207,7 +207,7 @@ def _get_files(path):
def _get_data_mapping(host_path, path):
for x in os.walk(path):
yield (os.path.join(host_path, x[0].partition(path)[2].lstrip('/')),
- map(lambda y: os.path.join(x[0], y), x[2]))
+ list(map(lambda y: os.path.join(x[0], y), x[2])))
class pkgcore_install_docs(core.Command):