aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gmail.com>2015-02-17 15:42:08 -0500
committerTim Harder <radhermit@gmail.com>2015-02-18 17:03:39 -0500
commit446efe83191c71fd7b69cd83015637983d679506 (patch)
treef4e596bf4a3fab9074aed9c4e58494fa66391f7e
parenttests: check empty iuse cases for ebuilds (diff)
downloadpkgcore-446efe83191c71fd7b69cd83015637983d679506.tar.gz
pkgcore-446efe83191c71fd7b69cd83015637983d679506.tar.bz2
pkgcore-446efe83191c71fd7b69cd83015637983d679506.zip
setup: return a generator instead of a list for _get_files()
-rw-r--r--setup.py6
1 files changed, 2 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 4213a13e9..4b9b53879 100644
--- a/setup.py
+++ b/setup.py
@@ -200,11 +200,9 @@ class pkgcore_install_scripts(core.Command):
def _get_files(path):
- l = []
for root, dirs, files in os.walk(path):
- l.extend(os.path.join(root, fn)[len(path):].lstrip('/')
- for fn in files)
- return l
+ for f in files:
+ yield os.path.join(root, f)[len(path):].lstrip('/')
class pkgcore_install_docs(core.Command):