aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gmail.com>2017-12-28 12:52:24 -0500
committerTim Harder <radhermit@gmail.com>2018-03-06 23:43:31 -0500
commitb76e791a16116bc2c6ea46710831edbe0d20fc62 (patch)
tree05505b5570ab7c1fcf99c2d91c04cacae10775c7
parentebuild.domain: don't overlap JIT stored attr with initial repos attr (diff)
downloadpkgcore-b76e791a16116bc2c6ea46710831edbe0d20fc62.tar.gz
pkgcore-b76e791a16116bc2c6ea46710831edbe0d20fc62.tar.bz2
pkgcore-b76e791a16116bc2c6ea46710831edbe0d20fc62.zip
ebuild.ebd: move src_install pre/post messages from bash to python
-rw-r--r--ebd/ebuild-default-functions.lib10
-rw-r--r--src/pkgcore/ebuild/ebd.py10
2 files changed, 10 insertions, 10 deletions
diff --git a/ebd/ebuild-default-functions.lib b/ebd/ebuild-default-functions.lib
index 07e72eaca..6f2248b4b 100644
--- a/ebd/ebuild-default-functions.lib
+++ b/ebd/ebuild-default-functions.lib
@@ -20,13 +20,6 @@ addpredict() {
}
__dyn_src_install() {
- local f
- echo
- if ${PKGCORE_PREFIX_SUPPORT}; then
- echo ">>> Install ${PF} into ${ED} category ${CATEGORY}"
- else
- echo ">>> Install ${PF} into ${D} category ${CATEGORY}"
- fi
if __is_function src_install; then
__qa_invoke src_install
else
@@ -42,7 +35,7 @@ __dyn_src_install() {
# Don't want paths that point to the tree where the package was built
# (older, broken libtools would do this). Also check for null paths
# because the loader will search $PWD when it finds null paths.
- f=$(scanelf -qyRF '%r %p' "${ED}" | grep -E "(${WORKDIR}|${ED}|: |::|^ )")
+ local f=$(scanelf -qyRF '%r %p' "${ED}" | grep -E "(${WORKDIR}|${ED}|: |::|^ )")
if [[ -n ${f} ]]; then
echo -ne '\a\n'
echo "QA Notice: the following files contain insecure RUNPATH's"
@@ -113,7 +106,6 @@ __dyn_src_install() {
done }
fi
- echo ">>> Completed installing ${PF} into ${ED}"
unset -v dir
}
diff --git a/src/pkgcore/ebuild/ebd.py b/src/pkgcore/ebuild/ebd.py
index 27773c6f7..fffdc8166 100644
--- a/src/pkgcore/ebuild/ebd.py
+++ b/src/pkgcore/ebuild/ebd.py
@@ -8,6 +8,8 @@ Wraps :obj:`pkgcore.ebuild.processor` functionality into a higher level
api, for example per phase methods.
"""
+from __future__ import print_function
+
__all__ = (
"ebd", "setup_mixin", "install_op", "uninstall_op", "replace_op",
"buildable", "binpkg_localize")
@@ -791,7 +793,13 @@ class buildable(ebd, setup_mixin, format.build):
@observer.decorate_build_method("install")
def install(self):
"""run the install phase (maps to src_install)"""
- return self._generic_phase("install", False, True)
+ # TODO: replace print() usage with observer
+ print(">>> Install {} into {} category {}".format(
+ self.env['PF'], self.env.get('ED', self.env['D']), self.env['CATEGORY']))
+ ret = self._generic_phase("install", False, True)
+ print(">>> Completed installing {} into {}".format(
+ self.env['PF'], self.env.get('ED', self.env['D'])))
+ return ret
@observer.decorate_build_method("test")
def test(self):