summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2014-12-14 11:50:20 -0500
committerMike Gilbert <floppym@gentoo.org>2014-12-14 11:50:20 -0500
commit018fe053f41591d47134a69793473ec34e8b1fde (patch)
treede6ea7a573d1639ab02dd3b589dfb725739f4fc2
parentUpdates from Arfrever's 2.7-20140921 patchset. (diff)
downloadpython-gentoo-patches-018fe053f41591d47134a69793473ec34e8b1fde.tar.gz
python-gentoo-patches-018fe053f41591d47134a69793473ec34e8b1fde.tar.bz2
python-gentoo-patches-018fe053f41591d47134a69793473ec34e8b1fde.zip
Updates for 2.7.9 by Arfrever2.7.9-0
-rw-r--r--patches/01_all_static_library_location.patch14
-rw-r--r--patches/02_all_disable_modules_and_ssl.patch10
-rw-r--r--patches/03_all_libdir.patch12
-rw-r--r--patches/04_all_non-zero_exit_status_on_failure.patch10
-rw-r--r--patches/05_all_loadable_sqlite_extensions.patch4
-rw-r--r--patches/06_all_regenerate_platform-specific_modules.patch12
-rw-r--r--patches/21_all_distutils_c++.patch4
-rw-r--r--patches/23_all_arm_OABI.patch2
-rw-r--r--patches/24_all_tests_environment.patch4
-rw-r--r--patches/61_all_process_data.patch6
10 files changed, 40 insertions, 38 deletions
diff --git a/patches/01_all_static_library_location.patch b/patches/01_all_static_library_location.patch
index 378c6dd..4af8e46 100644
--- a/patches/01_all_static_library_location.patch
+++ b/patches/01_all_static_library_location.patch
@@ -1,10 +1,10 @@
Install libpythonX.Y.a in /usr/lib instead of /usr/lib/pythonX.Y/config.
https://bugs.gentoo.org/show_bug.cgi?id=252372
-http://bugs.python.org/issue6103
+https://bugs.python.org/issue6103
--- Makefile.pre.in
+++ Makefile.pre.in
-@@ -902,6 +902,19 @@
+@@ -924,6 +924,19 @@
fi; \
else true; \
fi
@@ -24,7 +24,7 @@ http://bugs.python.org/issue6103
# Install the versioned manual page
altmaninstall:
-@@ -1098,18 +1111,6 @@
+@@ -1121,18 +1134,6 @@
else true; \
fi; \
done
@@ -45,10 +45,10 @@ http://bugs.python.org/issue6103
$(INSTALL_DATA) $(srcdir)/Modules/config.c.in $(DESTDIR)$(LIBPL)/config.c.in
--- Misc/python-config.in
+++ Misc/python-config.in
-@@ -46,11 +46,7 @@
- elif opt in ('--libs', '--ldflags'):
- libs = getvar('LIBS').split() + getvar('SYSLIBS').split()
- libs.append('-lpython'+pyver)
+@@ -47,11 +47,7 @@
+ libs = ['-lpython' + pyver]
+ libs += getvar('LIBS').split()
+ libs += getvar('SYSLIBS').split()
- # add the prefix/lib/pythonX.Y/config dir, but only if there is no
- # shared library in prefix/lib/.
if opt == '--ldflags':
diff --git a/patches/02_all_disable_modules_and_ssl.patch b/patches/02_all_disable_modules_and_ssl.patch
index c8b0ac8..1e76063 100644
--- a/patches/02_all_disable_modules_and_ssl.patch
+++ b/patches/02_all_disable_modules_and_ssl.patch
@@ -20,7 +20,7 @@
def add_dir_to_list(dirlist, dir):
"""Add the directory 'dir' to the list 'dirlist' (at the front) if
-@@ -436,6 +447,7 @@
+@@ -438,6 +449,7 @@
os.unlink(tmpfile)
def detect_modules(self):
@@ -28,7 +28,7 @@
# Ensure that /usr/local is always used
if not cross_compiling:
add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib')
-@@ -793,7 +805,7 @@
+@@ -795,7 +807,7 @@
ssl_incs = find_file('openssl/ssl.h', inc_dirs,
search_for_ssl_incs_in
)
@@ -37,7 +37,7 @@
krb5_h = find_file('krb5.h', inc_dirs,
['/usr/kerberos/include'])
if krb5_h:
-@@ -804,7 +816,8 @@
+@@ -806,7 +818,8 @@
] )
if (ssl_incs is not None and
@@ -47,7 +47,7 @@
exts.append( Extension('_ssl', ['_ssl.c'],
include_dirs = ssl_incs,
library_dirs = ssl_libs,
-@@ -836,7 +849,7 @@
+@@ -838,7 +851,7 @@
pass
min_openssl_ver = 0x00907000
@@ -56,7 +56,7 @@
have_usable_openssl = (have_any_openssl and
openssl_ver >= min_openssl_ver)
-@@ -852,21 +865,20 @@
+@@ -854,21 +867,20 @@
print ("warning: openssl 0x%08x is too old for _hashlib" %
openssl_ver)
missing.append('_hashlib')
diff --git a/patches/03_all_libdir.patch b/patches/03_all_libdir.patch
index 86bd419..da3f90c 100644
--- a/patches/03_all_libdir.patch
+++ b/patches/03_all_libdir.patch
@@ -137,7 +137,7 @@
#
--- setup.py
+++ setup.py
-@@ -450,7 +450,7 @@
+@@ -452,7 +452,7 @@
global disable_ssl
# Ensure that /usr/local is always used
if not cross_compiling:
@@ -146,7 +146,7 @@
add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
if cross_compiling:
self.add_gcc_paths()
-@@ -517,8 +517,7 @@
+@@ -519,8 +519,7 @@
):
add_dir_to_list(inc_dirs, d)
for d in (
@@ -156,7 +156,7 @@
):
add_dir_to_list(lib_dirs, d)
exts = []
-@@ -772,11 +771,11 @@
+@@ -774,11 +773,11 @@
elif curses_library:
readline_libs.append(curses_library)
elif self.compiler.find_library_file(lib_dirs +
@@ -170,7 +170,7 @@
extra_link_args=readline_extra_link_args,
libraries=readline_libs) )
else:
-@@ -1042,8 +1041,7 @@
+@@ -1044,8 +1043,7 @@
# check lib directories parallel to the location of the header
db_dirs_to_check = [
@@ -180,7 +180,7 @@
]
if host_platform != 'darwin':
-@@ -1156,10 +1154,8 @@
+@@ -1158,10 +1156,8 @@
if sqlite_incdir:
sqlite_dirs_to_check = [
@@ -193,7 +193,7 @@
]
sqlite_libfile = self.compiler.find_library_file(
sqlite_dirs_to_check + lib_dirs, 'sqlite3')
-@@ -1931,15 +1927,14 @@
+@@ -1933,15 +1929,14 @@
added_lib_dirs.append('/usr/openwin/lib')
elif os.path.exists('/usr/X11R6/include'):
include_dirs.append('/usr/X11R6/include')
diff --git a/patches/04_all_non-zero_exit_status_on_failure.patch b/patches/04_all_non-zero_exit_status_on_failure.patch
index 88e0f2f..738701e 100644
--- a/patches/04_all_non-zero_exit_status_on_failure.patch
+++ b/patches/04_all_non-zero_exit_status_on_failure.patch
@@ -1,5 +1,5 @@
https://bugs.gentoo.org/show_bug.cgi?id=281968
-http://bugs.python.org/issue6731
+https://bugs.python.org/issue6731
--- setup.py
+++ setup.py
@@ -12,16 +12,18 @@ http://bugs.python.org/issue6731
def add_dir_to_list(dirlist, dir):
"""Add the directory 'dir' to the list 'dirlist' (at the front) if
1) 'dir' is not already in 'dirlist'
-@@ -284,6 +286,8 @@
+@@ -285,7 +287,10 @@
+ " detect_modules() for the module's name.")
print
++ global exit_status
++
if self.failed:
-+ global exit_status
+ exit_status = 1
failed = self.failed[:]
print
print "Failed to build these modules:"
-@@ -2239,6 +2243,7 @@
+@@ -2241,6 +2246,7 @@
'Tools/scripts/2to3',
'Lib/smtpd.py']
)
diff --git a/patches/05_all_loadable_sqlite_extensions.patch b/patches/05_all_loadable_sqlite_extensions.patch
index b5f0f2b..f7ecefc 100644
--- a/patches/05_all_loadable_sqlite_extensions.patch
+++ b/patches/05_all_loadable_sqlite_extensions.patch
@@ -1,5 +1,5 @@
https://bugs.gentoo.org/show_bug.cgi?id=335505
-http://bugs.python.org/issue10268
+https://bugs.python.org/issue10268
--- configure.ac
+++ configure.ac
@@ -21,7 +21,7 @@ http://bugs.python.org/issue10268
AC_ARG_WITH(dbmliborder,
--- setup.py
+++ setup.py
-@@ -1183,8 +1183,10 @@
+@@ -1186,8 +1186,10 @@
else:
sqlite_defines.append(('MODULE_NAME', '\\"sqlite3\\"'))
diff --git a/patches/06_all_regenerate_platform-specific_modules.patch b/patches/06_all_regenerate_platform-specific_modules.patch
index 82a5346..51b4913 100644
--- a/patches/06_all_regenerate_platform-specific_modules.patch
+++ b/patches/06_all_regenerate_platform-specific_modules.patch
@@ -1,4 +1,4 @@
-http://bugs.python.org/issue12619
+https://bugs.python.org/issue12619
--- Lib/plat-aix4/regen
+++ Lib/plat-aix4/regen
@@ -37,7 +37,7 @@ http://bugs.python.org/issue12619
+python$EXE ../../Tools/scripts/h2py.py /usr/include/sys/stropts.h
--- Makefile.pre.in
+++ Makefile.pre.in
-@@ -405,7 +405,7 @@
+@@ -408,7 +408,7 @@
# Default target
all: build_all
@@ -46,7 +46,7 @@ http://bugs.python.org/issue12619
# Compile a binary with gcc profile guided optimization.
profile-opt:
-@@ -473,6 +473,32 @@
+@@ -476,6 +476,32 @@
_TCLTK_INCLUDES='$(TCLTK_INCLUDES)' _TCLTK_LIBS='$(TCLTK_LIBS)' \
$(PYTHON_FOR_BUILD) $(srcdir)/setup.py $$quiet build
@@ -79,7 +79,7 @@ http://bugs.python.org/issue12619
# Build static library
# avoid long command lines, same as LIBRARY_OBJS
$(LIBRARY): $(LIBRARY_OBJS)
-@@ -972,7 +998,7 @@
+@@ -995,7 +1021,7 @@
unittest unittest/test \
lib-old \
curses pydoc_data $(MACHDEPS)
@@ -88,7 +88,7 @@ http://bugs.python.org/issue12619
@for i in $(SCRIPTDIR) $(LIBDEST); \
do \
if test ! -d $(DESTDIR)$$i; then \
-@@ -1055,23 +1081,6 @@
+@@ -1078,23 +1104,6 @@
-PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
$(PYTHON_FOR_BUILD) -m lib2to3.pgen2.driver $(DESTDIR)$(LIBDEST)/lib2to3/PatternGrammar.txt
@@ -112,7 +112,7 @@ http://bugs.python.org/issue12619
python-config: $(srcdir)/Misc/python-config.in
# Substitution happens here, as the completely-expanded BINDIR
# is not available in configure
-@@ -1365,7 +1374,7 @@
+@@ -1388,7 +1397,7 @@
Python/thread.o: @THREADHEADERS@
# Declare targets that aren't real files
diff --git a/patches/21_all_distutils_c++.patch b/patches/21_all_distutils_c++.patch
index 5496a5d..eb5552e 100644
--- a/patches/21_all_distutils_c++.patch
+++ b/patches/21_all_distutils_c++.patch
@@ -1,4 +1,4 @@
-http://bugs.python.org/issue1222585
+https://bugs.python.org/issue1222585
--- Lib/distutils/cygwinccompiler.py
+++ Lib/distutils/cygwinccompiler.py
@@ -262,7 +262,7 @@ http://bugs.python.org/issue1222585
_INITPRE = '_OSX_SUPPORT_INITIAL_'
--- Makefile.pre.in
+++ Makefile.pre.in
-@@ -469,7 +469,7 @@
+@@ -472,7 +472,7 @@
*\ -s*|s*) quiet="-q";; \
*) quiet="";; \
esac; \
diff --git a/patches/23_all_arm_OABI.patch b/patches/23_all_arm_OABI.patch
index 1f94f78..45193a8 100644
--- a/patches/23_all_arm_OABI.patch
+++ b/patches/23_all_arm_OABI.patch
@@ -1,5 +1,5 @@
https://bugs.gentoo.org/show_bug.cgi?id=266703
-http://bugs.python.org/issue1762561
+https://bugs.python.org/issue1762561
--- Objects/floatobject.c
+++ Objects/floatobject.c
diff --git a/patches/24_all_tests_environment.patch b/patches/24_all_tests_environment.patch
index 63c420e..15dbfdd 100644
--- a/patches/24_all_tests_environment.patch
+++ b/patches/24_all_tests_environment.patch
@@ -1,4 +1,4 @@
-http://bugs.python.org/issue1674555
+https://bugs.python.org/issue1674555
--- Lib/site.py
+++ Lib/site.py
@@ -158,7 +158,7 @@ http://bugs.python.org/issue1674555
--- Makefile.pre.in
+++ Makefile.pre.in
-@@ -804,7 +804,7 @@
+@@ -807,7 +807,7 @@
TESTOPTS= -l $(EXTRATESTOPTS)
TESTPROG= $(srcdir)/Lib/test/regrtest.py
diff --git a/patches/61_all_process_data.patch b/patches/61_all_process_data.patch
index 11b697c..b0eda4b 100644
--- a/patches/61_all_process_data.patch
+++ b/patches/61_all_process_data.patch
@@ -85,7 +85,7 @@ python_generate_wrapper_scripts() to check if Python supports GENTOO_PYTHON_TARG
}
--- Python/sysmodule.c
+++ Python/sysmodule.c
-@@ -1573,6 +1573,10 @@
+@@ -1578,6 +1578,10 @@
makeargvobject(int argc, char **argv)
{
PyObject *av;
@@ -96,7 +96,7 @@ python_generate_wrapper_scripts() to check if Python supports GENTOO_PYTHON_TARG
if (argc <= 0 || argv == NULL) {
/* Ensure at least one (empty) argument is seen */
static char *empty_argv[1] = {""};
-@@ -1597,7 +1601,11 @@
+@@ -1602,7 +1606,11 @@
} else
v = PyString_FromString(argv[i]);
#else
@@ -109,7 +109,7 @@ python_generate_wrapper_scripts() to check if Python supports GENTOO_PYTHON_TARG
#endif
if (v == NULL) {
Py_DECREF(av);
-@@ -1625,7 +1633,15 @@
+@@ -1630,7 +1638,15 @@
if (PySys_SetObject("argv", av) != 0)
Py_FatalError("can't assign sys.argv");
if (updatepath && path != NULL) {