summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <hans@degraaff.org>2014-11-09 09:09:54 +0100
committerHans de Graaff <hans@degraaff.org>2014-11-09 09:09:54 +0100
commit6673a51c0ee5e3512d1e6c7179ca3cac737eac8a (patch)
tree3e30cafc3ea24f89c867417062c92e9ef2e7efc2 /patchsets
parentCreate a bit larger plot by default since the SVG can be scaled down easily. (diff)
downloadruby-scripts-6673a51c0ee5e3512d1e6c7179ca3cac737eac8a.tar.gz
ruby-scripts-6673a51c0ee5e3512d1e6c7179ca3cac737eac8a.tar.bz2
ruby-scripts-6673a51c0ee5e3512d1e6c7179ca3cac737eac8a.zip
Add unchanged patchsets for new patch releases to be complete.
Diffstat (limited to 'patchsets')
-rw-r--r--patchsets/patches-1.9.3_p550/004_gfbsd7.patch37
-rw-r--r--patchsets/patches-1.9.3_p550/005_no-undefined-ext.patch11
-rw-r--r--patchsets/patches-1.9.3_p550/009_no-gems.patch55
-rw-r--r--patchsets/patches-1.9.3_p550/010_mkmf-parallel-install.patch15
-rw-r--r--patchsets/patches-2.0.0_p594/004_gfbsd7.patch37
-rw-r--r--patchsets/patches-2.0.0_p594/005_no-undefined-ext.patch11
-rw-r--r--patchsets/patches-2.0.0_p594/009_no-gems.patch63
-rw-r--r--patchsets/patches-2.0.0_p594/010_uclibc.patch45
-rw-r--r--patchsets/patches-2.1.4/004_gfbsd7.patch37
-rw-r--r--patchsets/patches-2.1.4/005_no-undefined-ext.patch11
-rw-r--r--patchsets/patches-2.1.4/009_no-gems.patch62
-rw-r--r--patchsets/patches-2.1.4/012_no_forced_sse2.patch28
12 files changed, 412 insertions, 0 deletions
diff --git a/patchsets/patches-1.9.3_p550/004_gfbsd7.patch b/patchsets/patches-1.9.3_p550/004_gfbsd7.patch
new file mode 100644
index 0000000..7a80142
--- /dev/null
+++ b/patchsets/patches-1.9.3_p550/004_gfbsd7.patch
@@ -0,0 +1,37 @@
+--- ruby-1.9.3-preview1.orig/configure.in
++++ ruby-1.9.3-preview1/configure.in
+@@ -1946,7 +1946,7 @@ if test "$rb_cv_binary_elf" = yes; then
+ fi
+
+ AS_CASE(["$target_os"],
+-[linux* | gnu* | k*bsd*-gnu | bsdi* | kopensolaris*-gnu], [
++[linux* | gnu* | k*bsd*-gnu | bsdi* | kopensolaris*-gnu | freebsd* | dragonfly*], [
+ if test "$rb_cv_binary_elf" = no; then
+ with_dln_a_out=yes
+ else
+@@ -2035,7 +2035,7 @@ if test "$with_dln_a_out" != yes; then
+ [bsdi3*], [ AS_CASE(["$CC"],
+ [*shlicc*], [ : ${LDSHARED='$(CC) -r'}
+ rb_cv_dlopen=yes])],
+- [linux* | gnu* | k*bsd*-gnu | netbsd* | bsdi* | kopensolaris*-gnu], [
++ [linux* | gnu* | k*bsd*-gnu | netbsd* | bsdi* | kopensolaris*-gnu | freebsd7*], [
+ : ${LDSHARED='$(CC) -shared'}
+ if test "$rb_cv_binary_elf" = yes; then
+ LDFLAGS="$LDFLAGS -Wl,-export-dynamic"
+@@ -2048,7 +2048,6 @@ if test "$with_dln_a_out" != yes; then
+ [freebsd*|dragonfly*], [
+ : ${LDSHARED='$(CC) -shared'}
+ if test "$rb_cv_binary_elf" = yes; then
+- LDFLAGS="$LDFLAGS -rdynamic"
+ DLDFLAGS="$DLDFLAGS "'-Wl,-soname,$(.TARGET)'
+ else
+ test "$GCC" = yes && test "$rb_cv_prog_gnu_ld" = yes || LDSHARED="ld -Bshareable"
+@@ -2336,7 +2335,7 @@ AS_CASE("$enable_shared", [yes], [
+ [sunos4*], [
+ LIBRUBY_ALIASES='lib$(RUBY_SO_NAME).so.$(MAJOR).$(MINOR) lib$(RUBY_SO_NAME).so'
+ ],
+- [linux* | gnu* | k*bsd*-gnu | atheos* | kopensolaris*-gnu], [
++ [linux* | gnu* | k*bsd*-gnu | atheos* | kopensolaris*-gnu | freebsd7*], [
+ LIBRUBY_DLDFLAGS='-Wl,-soname,lib$(RUBY_SO_NAME).so.$(MAJOR).$(MINOR)'
+ LIBRUBY_ALIASES='lib$(RUBY_SO_NAME).so.$(MAJOR).$(MINOR) lib$(RUBY_SO_NAME).so'
+ if test "$load_relative" = yes; then
diff --git a/patchsets/patches-1.9.3_p550/005_no-undefined-ext.patch b/patchsets/patches-1.9.3_p550/005_no-undefined-ext.patch
new file mode 100644
index 0000000..f279932
--- /dev/null
+++ b/patchsets/patches-1.9.3_p550/005_no-undefined-ext.patch
@@ -0,0 +1,11 @@
+--- ruby-1.9.3-preview1.orig/configure.in
++++ ruby-1.9.3-preview1/configure.in
+@@ -2038,7 +2038,7 @@ if test "$with_dln_a_out" != yes; then
+ [linux* | gnu* | k*bsd*-gnu | netbsd* | bsdi* | kopensolaris*-gnu], [
+ : ${LDSHARED='$(CC) -shared'}
+ if test "$rb_cv_binary_elf" = yes; then
+- LDFLAGS="$LDFLAGS -Wl,-export-dynamic"
++ LDFLAGS="$LDFLAGS -Wl,-export-dynamic -Wl,--no-undefined"
+ fi
+ rb_cv_dlopen=yes],
+ [interix*], [ : ${LDSHARED='$(CC) -shared'}
diff --git a/patchsets/patches-1.9.3_p550/009_no-gems.patch b/patchsets/patches-1.9.3_p550/009_no-gems.patch
new file mode 100644
index 0000000..0c60885
--- /dev/null
+++ b/patchsets/patches-1.9.3_p550/009_no-gems.patch
@@ -0,0 +1,55 @@
+--- ruby-1.9.3-preview1.orig/tool/rbinstall.rb
++++ ruby-1.9.3-preview1/tool/rbinstall.rb
+@@ -532,51 +532,7 @@ install?(:local, :comm, :man) do
+ end
+
+ install?(:ext, :comm, :gem) do
+- $:.unshift(File.join(srcdir, "lib"))
+- require("rubygems.rb")
+- gem_dir = Gem.default_dir
+- directories = Gem.ensure_gem_subdirectories(gem_dir)
+- prepare "default gems", gem_dir, directories
+-
+- spec_dir = File.join(gem_dir, directories.grep(/^spec/)[0])
+- File.foreach(File.join(srcdir, "defs/default_gems")) do |line|
+- line.chomp!
+- line.sub!(/\s*#.*/, '')
+- next if line.empty?
+- words = []
+- line.scan(/\G\s*([^\[\]\s]+|\[([^\[\]]*)\])/) do
+- words << ($2 ? $2.split : $1)
+- end
+- name, src, execs = *words
+- next unless name and src
+- execs ||= []
+- src = File.join(srcdir, src)
+- version = open(src) {|f| f.find {|s| /^\s*\w*VERSION\s*=(?!=)/ =~ s}} or next
+- version = version.split(%r"=\s*", 2)[1].strip[/\A([\'\"])(.*?)\1/, 2]
+- full_name = "#{name}-#{version}"
+-
+- puts "#{" "*30}#{name} #{version}"
+- open_for_install(File.join(spec_dir, "#{full_name}.gemspec"), $data_mode) do
+- <<-GEMSPEC
+-Gem::Specification.new do |s|
+- s.name = #{name.dump}
+- s.version = #{version.dump}
+- s.summary = "This #{name} is bundled with Ruby"
+- s.executables = #{execs.inspect}
+-end
+- GEMSPEC
+- end
+-
+- unless execs.empty? then
+- bin_dir = File.join(gem_dir, 'gems', full_name, 'bin')
+- makedirs(bin_dir)
+-
+- execs.each do |exec|
+- exec = File.join(srcdir, 'bin', exec)
+- install(exec, bin_dir, :mode => $prog_mode)
+- end
+- end
+- end
++ # gems are unbundled
+ end
+
+ parse_args()
diff --git a/patchsets/patches-1.9.3_p550/010_mkmf-parallel-install.patch b/patchsets/patches-1.9.3_p550/010_mkmf-parallel-install.patch
new file mode 100644
index 0000000..bb80635
--- /dev/null
+++ b/patchsets/patches-1.9.3_p550/010_mkmf-parallel-install.patch
@@ -0,0 +1,15 @@
+Index: ruby-1.9.3-p392/lib/mkmf.rb
+===================================================================
+--- ruby-1.9.3-p392.orig/lib/mkmf.rb
++++ ruby-1.9.3-p392/lib/mkmf.rb
+@@ -2039,8 +2039,8 @@ static: $(STATIC_LIB)#{$extout ? " insta
+ end
+ for f in files
+ dest = "#{dir}/#{File.basename(f)}"
+- mfile.print("install-rb#{sfx}: #{dest} #{dir}\n")
+- mfile.print("#{dest}: #{f}\n")
++ mfile.print("install-rb#{sfx}: #{dest}\n")
++ mfile.print("#{dest}: #{f} #{timestamp_file(dir)}\n")
+ mfile.print("\t$(Q) $(#{$extout ? 'COPY' : 'INSTALL_DATA'}) #{f} $(@D#{sep})\n")
+ if defined?($installed_list) and !$extout
+ mfile.print("\t@echo #{dest}>>$(INSTALLED_LIST)\n")
diff --git a/patchsets/patches-2.0.0_p594/004_gfbsd7.patch b/patchsets/patches-2.0.0_p594/004_gfbsd7.patch
new file mode 100644
index 0000000..450d714
--- /dev/null
+++ b/patchsets/patches-2.0.0_p594/004_gfbsd7.patch
@@ -0,0 +1,37 @@
+--- configure.in.orig 2013-05-05 19:36:02.800254192 +0200
++++ configure.in 2013-05-05 19:37:56.573346196 +0200
+@@ -2156,7 +2156,7 @@
+ fi
+
+ AS_CASE(["$target_os"],
+-[linux* | gnu* | k*bsd*-gnu | bsdi* | kopensolaris*-gnu | nacl], [
++[linux* | gnu* | k*bsd*-gnu | bsdi* | kopensolaris*-gnu | nacl | freebsd* | dragonfly*], [
+ if test "$rb_cv_binary_elf" = no; then
+ with_dln_a_out=yes
+ else
+@@ -2249,7 +2249,7 @@
+ [bsdi3*], [ AS_CASE(["$CC"],
+ [*shlicc*], [ : ${LDSHARED='$(CC) -r'}
+ rb_cv_dlopen=yes])],
+- [linux* | gnu* | k*bsd*-gnu | netbsd* | bsdi* | kopensolaris*-gnu], [
++ [linux* | gnu* | k*bsd*-gnu | netbsd* | bsdi* | kopensolaris*-gnu | freebsd7*], [
+ : ${LDSHARED='$(CC) -shared'}
+ if test "$rb_cv_binary_elf" = yes; then
+ LDFLAGS="$LDFLAGS -Wl,-export-dynamic"
+@@ -2262,7 +2262,6 @@
+ [freebsd*|dragonfly*], [
+ : ${LDSHARED='$(CC) -shared'}
+ if test "$rb_cv_binary_elf" = yes; then
+- LDFLAGS="$LDFLAGS -rdynamic"
+ DLDFLAGS="$DLDFLAGS "'-Wl,-soname,$@'
+ else
+ test "$GCC" = yes && test "$rb_cv_prog_gnu_ld" = yes || LDSHARED='$(LD) -Bshareable'
+@@ -2638,7 +2637,7 @@
+ [sunos4*], [
+ LIBRUBY_ALIASES='lib$(RUBY_SO_NAME).so.$(MAJOR).$(MINOR) lib$(RUBY_SO_NAME).so'
+ ],
+- [linux* | gnu* | k*bsd*-gnu | atheos* | kopensolaris*-gnu], [
++ [linux* | gnu* | k*bsd*-gnu | atheos* | kopensolaris*-gnu | freebsd7*], [
+ LIBRUBY_DLDFLAGS='-Wl,-soname,lib$(RUBY_SO_NAME).so.$(MAJOR).$(MINOR)'" $LDFLAGS_OPTDIR"
+ LIBRUBY_ALIASES='lib$(RUBY_SO_NAME).so.$(MAJOR).$(MINOR) lib$(RUBY_SO_NAME).so'
+ if test "$load_relative" = yes; then
diff --git a/patchsets/patches-2.0.0_p594/005_no-undefined-ext.patch b/patchsets/patches-2.0.0_p594/005_no-undefined-ext.patch
new file mode 100644
index 0000000..f279932
--- /dev/null
+++ b/patchsets/patches-2.0.0_p594/005_no-undefined-ext.patch
@@ -0,0 +1,11 @@
+--- ruby-1.9.3-preview1.orig/configure.in
++++ ruby-1.9.3-preview1/configure.in
+@@ -2038,7 +2038,7 @@ if test "$with_dln_a_out" != yes; then
+ [linux* | gnu* | k*bsd*-gnu | netbsd* | bsdi* | kopensolaris*-gnu], [
+ : ${LDSHARED='$(CC) -shared'}
+ if test "$rb_cv_binary_elf" = yes; then
+- LDFLAGS="$LDFLAGS -Wl,-export-dynamic"
++ LDFLAGS="$LDFLAGS -Wl,-export-dynamic -Wl,--no-undefined"
+ fi
+ rb_cv_dlopen=yes],
+ [interix*], [ : ${LDSHARED='$(CC) -shared'}
diff --git a/patchsets/patches-2.0.0_p594/009_no-gems.patch b/patchsets/patches-2.0.0_p594/009_no-gems.patch
new file mode 100644
index 0000000..a9271af
--- /dev/null
+++ b/patchsets/patches-2.0.0_p594/009_no-gems.patch
@@ -0,0 +1,63 @@
+--- tool/rbinstall.rb.orig 2013-05-05 19:40:15.417797767 +0200
++++ tool/rbinstall.rb 2013-05-05 19:41:08.064452389 +0200
+@@ -685,59 +685,7 @@
+ # :startdoc:
+
+ install?(:ext, :comm, :gem) do
+- $:.unshift(File.join(srcdir, "lib"))
+- require("rubygems.rb")
+- gem_dir = Gem.default_dir
+- # Gem.ensure_gem_subdirectories makes subdirectories group-writable.
+- directories = Gem::REPOSITORY_SUBDIRECTORIES
+- prepare "default gems", gem_dir, directories
+-
+- spec_dir = File.join(gem_dir, directories.grep(/^spec/)[0])
+- default_spec_dir = "#{spec_dir}/default"
+- makedirs(default_spec_dir)
+-
+- gems = {}
+- File.foreach(File.join(srcdir, "defs/default_gems")) do |line|
+- line.chomp!
+- line.sub!(/\s*#.*/, '')
+- next if line.empty?
+- words = []
+- line.scan(/\G\s*([^\[\]\s]+|\[([^\[\]]*)\])/) do
+- words << ($2 ? $2.split : $1)
+- end
+- name, base_dir, src, execs = *words
+- next unless name and base_dir and src
+-
+- src = File.join(srcdir, src)
+- base_dir = File.join(srcdir, base_dir)
+- specgen = RbInstall::Specs::Generator.new(name, base_dir, src, execs || [])
+- gems[name] ||= specgen
+- end
+-
+- Dir.glob(srcdir+"/{lib,ext}/**/*.gemspec").each do |src|
+- specgen = RbInstall::Specs::Reader.new(src)
+- gems[specgen.gemspec.name] ||= specgen
+- end
+-
+- gems.sort.each do |name, specgen|
+- gemspec = specgen.gemspec
+- base_dir = specgen.src.sub(/\A#{Regexp.escape(srcdir)}\//, "")
+- full_name = "#{gemspec.name}-#{gemspec.version}"
+-
+- puts "#{" "*30}#{gemspec.name} #{gemspec.version}"
+- gemspec_path = File.join(default_spec_dir, "#{full_name}.gemspec")
+- open_for_install(gemspec_path, $data_mode) do
+- specgen.spec_source
+- end
+-
+- unless gemspec.executables.empty? then
+- bin_dir = File.join(gem_dir, 'gems', full_name, 'bin')
+- makedirs(bin_dir)
+-
+- execs = gemspec.executables.map {|exec| File.join(srcdir, 'bin', exec)}
+- install(execs, bin_dir, :mode => $prog_mode)
+- end
+- end
++# gems are unbundled
+ end
+
+ parse_args()
diff --git a/patchsets/patches-2.0.0_p594/010_uclibc.patch b/patchsets/patches-2.0.0_p594/010_uclibc.patch
new file mode 100644
index 0000000..c2cf6ee
--- /dev/null
+++ b/patchsets/patches-2.0.0_p594/010_uclibc.patch
@@ -0,0 +1,45 @@
+diff -urp ruby-2.0.0-p353/missing/isinf.c ruby-2.0.0-p353-uclibc/missing/isinf.c
+--- ruby-2.0.0-p353/missing/isinf.c 2011-05-15 07:55:52.000000000 -0400
++++ ruby-2.0.0-p353-uclibc/missing/isinf.c 2014-02-01 09:19:31.000000000 -0500
+@@ -52,6 +52,7 @@ static double zero(void) { return 0.0; }
+ static double one (void) { return 1.0; }
+ static double inf (void) { return one() / zero(); }
+
++#ifndef isinf
+ int
+ isinf(double n)
+ {
+@@ -67,3 +68,4 @@ isinf(double n)
+ }
+ #endif
+ #endif
++#endif
+diff -urp ruby-2.0.0-p353/missing/isnan.c ruby-2.0.0-p353-uclibc/missing/isnan.c
+--- ruby-2.0.0-p353/missing/isnan.c 2010-07-28 04:12:01.000000000 -0400
++++ ruby-2.0.0-p353-uclibc/missing/isnan.c 2014-01-31 22:12:44.000000000 -0500
+@@ -2,6 +2,20 @@
+
+ #include "ruby/missing.h"
+
++/*
++ * isnan() may be a macro, a function or both.
++ * (The C99 standard defines that isnan() is a macro, though.)
++ * http://www.gnu.org/software/automake/manual/autoconf/Function-Portability.html
++ *
++ * macro only: uClibc
++ * both: GNU libc
++ *
++ * This file is compile if no isnan() function is available.
++ * (autoconf AC_REPLACE_FUNCS detects only the function.)
++ * The macro is detected by following #ifndef.
++ */
++
++#ifndef isnan
+ static int double_ne(double n1, double n2);
+
+ int
+@@ -15,3 +29,4 @@ double_ne(double n1, double n2)
+ {
+ return n1 != n2;
+ }
++#endif
diff --git a/patchsets/patches-2.1.4/004_gfbsd7.patch b/patchsets/patches-2.1.4/004_gfbsd7.patch
new file mode 100644
index 0000000..450d714
--- /dev/null
+++ b/patchsets/patches-2.1.4/004_gfbsd7.patch
@@ -0,0 +1,37 @@
+--- configure.in.orig 2013-05-05 19:36:02.800254192 +0200
++++ configure.in 2013-05-05 19:37:56.573346196 +0200
+@@ -2156,7 +2156,7 @@
+ fi
+
+ AS_CASE(["$target_os"],
+-[linux* | gnu* | k*bsd*-gnu | bsdi* | kopensolaris*-gnu | nacl], [
++[linux* | gnu* | k*bsd*-gnu | bsdi* | kopensolaris*-gnu | nacl | freebsd* | dragonfly*], [
+ if test "$rb_cv_binary_elf" = no; then
+ with_dln_a_out=yes
+ else
+@@ -2249,7 +2249,7 @@
+ [bsdi3*], [ AS_CASE(["$CC"],
+ [*shlicc*], [ : ${LDSHARED='$(CC) -r'}
+ rb_cv_dlopen=yes])],
+- [linux* | gnu* | k*bsd*-gnu | netbsd* | bsdi* | kopensolaris*-gnu], [
++ [linux* | gnu* | k*bsd*-gnu | netbsd* | bsdi* | kopensolaris*-gnu | freebsd7*], [
+ : ${LDSHARED='$(CC) -shared'}
+ if test "$rb_cv_binary_elf" = yes; then
+ LDFLAGS="$LDFLAGS -Wl,-export-dynamic"
+@@ -2262,7 +2262,6 @@
+ [freebsd*|dragonfly*], [
+ : ${LDSHARED='$(CC) -shared'}
+ if test "$rb_cv_binary_elf" = yes; then
+- LDFLAGS="$LDFLAGS -rdynamic"
+ DLDFLAGS="$DLDFLAGS "'-Wl,-soname,$@'
+ else
+ test "$GCC" = yes && test "$rb_cv_prog_gnu_ld" = yes || LDSHARED='$(LD) -Bshareable'
+@@ -2638,7 +2637,7 @@
+ [sunos4*], [
+ LIBRUBY_ALIASES='lib$(RUBY_SO_NAME).so.$(MAJOR).$(MINOR) lib$(RUBY_SO_NAME).so'
+ ],
+- [linux* | gnu* | k*bsd*-gnu | atheos* | kopensolaris*-gnu], [
++ [linux* | gnu* | k*bsd*-gnu | atheos* | kopensolaris*-gnu | freebsd7*], [
+ LIBRUBY_DLDFLAGS='-Wl,-soname,lib$(RUBY_SO_NAME).so.$(MAJOR).$(MINOR)'" $LDFLAGS_OPTDIR"
+ LIBRUBY_ALIASES='lib$(RUBY_SO_NAME).so.$(MAJOR).$(MINOR) lib$(RUBY_SO_NAME).so'
+ if test "$load_relative" = yes; then
diff --git a/patchsets/patches-2.1.4/005_no-undefined-ext.patch b/patchsets/patches-2.1.4/005_no-undefined-ext.patch
new file mode 100644
index 0000000..f279932
--- /dev/null
+++ b/patchsets/patches-2.1.4/005_no-undefined-ext.patch
@@ -0,0 +1,11 @@
+--- ruby-1.9.3-preview1.orig/configure.in
++++ ruby-1.9.3-preview1/configure.in
+@@ -2038,7 +2038,7 @@ if test "$with_dln_a_out" != yes; then
+ [linux* | gnu* | k*bsd*-gnu | netbsd* | bsdi* | kopensolaris*-gnu], [
+ : ${LDSHARED='$(CC) -shared'}
+ if test "$rb_cv_binary_elf" = yes; then
+- LDFLAGS="$LDFLAGS -Wl,-export-dynamic"
++ LDFLAGS="$LDFLAGS -Wl,-export-dynamic -Wl,--no-undefined"
+ fi
+ rb_cv_dlopen=yes],
+ [interix*], [ : ${LDSHARED='$(CC) -shared'}
diff --git a/patchsets/patches-2.1.4/009_no-gems.patch b/patchsets/patches-2.1.4/009_no-gems.patch
new file mode 100644
index 0000000..7c61bbd
--- /dev/null
+++ b/patchsets/patches-2.1.4/009_no-gems.patch
@@ -0,0 +1,62 @@
+--- tool/rbinstall.rb.~1~ 2013-11-09 17:37:46.000000000 +0100
++++ tool/rbinstall.rb 2013-12-25 20:10:03.651964649 +0100
+@@ -711,58 +711,7 @@
+ # :startdoc:
+
+ install?(:ext, :comm, :gem) do
+- $:.unshift(File.join(srcdir, "lib"))
+- require("rubygems.rb")
+- gem_dir = Gem.default_dir
+- directories = Gem.ensure_gem_subdirectories(gem_dir, :mode => $dir_mode)
+- prepare "default gems", gem_dir, directories
+-
+- spec_dir = File.join(gem_dir, directories.grep(/^spec/)[0])
+- default_spec_dir = "#{spec_dir}/default"
+- makedirs(default_spec_dir)
+-
+- gems = {}
+- File.foreach(File.join(srcdir, "defs/default_gems")) do |line|
+- line.chomp!
+- line.sub!(/\s*#.*/, '')
+- next if line.empty?
+- words = []
+- line.scan(/\G\s*([^\[\]\s]+|\[([^\[\]]*)\])/) do
+- words << ($2 ? $2.split : $1)
+- end
+- name, base_dir, src, execs = *words
+- next unless name and base_dir and src
+-
+- src = File.join(srcdir, src)
+- base_dir = File.join(srcdir, base_dir)
+- specgen = RbInstall::Specs::Generator.new(name, base_dir, src, execs || [])
+- gems[name] ||= specgen
+- end
+-
+- Dir.glob(srcdir+"/{lib,ext}/**/*.gemspec").each do |src|
+- specgen = RbInstall::Specs::Reader.new(src)
+- gems[specgen.gemspec.name] ||= specgen
+- end
+-
+- gems.sort.each do |name, specgen|
+- gemspec = specgen.gemspec
+- base_dir = specgen.src.sub(/\A#{Regexp.escape(srcdir)}\//, "")
+- full_name = "#{gemspec.name}-#{gemspec.version}"
+-
+- puts "#{" "*30}#{gemspec.name} #{gemspec.version}"
+- gemspec_path = File.join(default_spec_dir, "#{full_name}.gemspec")
+- open_for_install(gemspec_path, $data_mode) do
+- specgen.spec_source
+- end
+-
+- unless gemspec.executables.empty? then
+- bin_dir = File.join(gem_dir, 'gems', full_name, 'bin')
+- makedirs(bin_dir)
+-
+- execs = gemspec.executables.map {|exec| File.join(srcdir, 'bin', exec)}
+- install(execs, bin_dir, :mode => $prog_mode)
+- end
+- end
++ # gems are unbundled in Gentoo.
+ end
+
+ parse_args()
diff --git a/patchsets/patches-2.1.4/012_no_forced_sse2.patch b/patchsets/patches-2.1.4/012_no_forced_sse2.patch
new file mode 100644
index 0000000..97793bc
--- /dev/null
+++ b/patchsets/patches-2.1.4/012_no_forced_sse2.patch
@@ -0,0 +1,28 @@
+https://bugs.gentoo.org/show_bug.cgi?id=503804
+https://bugs.ruby-lang.org/issues/8358
+
+--- configure.in.orig 2014-04-14 00:46:14.000000000 +0400
++++ configure.in 2014-04-14 01:38:54.597889225 +0400
+@@ -856,22 +856,6 @@
+ for oflag in -fno-fast-math; do
+ RUBY_TRY_CFLAGS($oflag, [RUBY_APPEND_OPTION(optflags, $oflag)])
+ done
+- AS_CASE(["$target"],
+- [*-darwin*], [
+- # doesn't seem necessary on Mac OS X
+- ],
+- [[i[4-6]86*|i386*mingw*]], [
+- RUBY_TRY_CFLAGS(-msse2 -mfpmath=sse, [
+- RUBY_APPEND_OPTION(XCFLAGS, -msse2 -mfpmath=sse)
+- ])
+- AS_CASE(["$XCFLAGS"],
+- [[*-msse2*]], [
+- RUBY_TRY_CFLAGS(-mstackrealign, [
+- RUBY_APPEND_OPTION(XCFLAGS, -mstackrealign)
+- ])
+- ])
+- ]
+- )
+ fi
+
+ AC_ARG_WITH(opt-dir,