aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosh Triplett <josh@freedesktop.org>2007-08-31 14:04:02 -0700
committerJosh Triplett <josh@freedesktop.org>2007-08-31 14:06:47 -0700
commita3ba81906dc41f12264df379c9f699de76abacab (patch)
tree02cb0f4dee1a04d84c4ff655715ca836ec21eb19 /Makefile
parentAdd a manpage for sparse (diff)
downloadsparse-a3ba81906dc41f12264df379c9f699de76abacab.tar.gz
sparse-a3ba81906dc41f12264df379c9f699de76abacab.tar.bz2
sparse-a3ba81906dc41f12264df379c9f699de76abacab.zip
Install the Sparse manpage
Signed-off-by: Josh Triplett <josh@freedesktop.org>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index f07290e..cb0d83d 100644
--- a/Makefile
+++ b/Makefile
@@ -19,6 +19,8 @@ DESTDIR=
PREFIX=$(HOME)
BINDIR=$(PREFIX)/bin
LIBDIR=$(PREFIX)/lib
+MANDIR=$(PREFIX)/share/man
+MAN1DIR=$(MANDIR)/man1
INCLUDEDIR=$(PREFIX)/include
PKGCONFIGDIR=$(LIBDIR)/pkgconfig
@@ -27,6 +29,7 @@ PROGRAMS=test-lexing test-parsing obfuscate compile graph sparse test-linearize
INST_PROGRAMS=sparse cgcc
+INST_MAN1=sparse.1
ifeq ($(HAVE_LIBXML),yes)
PROGRAMS+=c2xml
@@ -71,11 +74,15 @@ all: $(PROGRAMS) sparse.pc
install: $(INST_PROGRAMS) $(LIBS) $(LIB_H) sparse.pc
$(Q)install -d $(DESTDIR)$(BINDIR)
$(Q)install -d $(DESTDIR)$(LIBDIR)
+ $(Q)install -d $(DESTDIR)$(MAN1DIR)
$(Q)install -d $(DESTDIR)$(INCLUDEDIR)/sparse
$(Q)install -d $(DESTDIR)$(PKGCONFIGDIR)
$(Q)for f in $(INST_PROGRAMS); do \
$(QUIET_INST_SH)install -v $$f $(DESTDIR)$(BINDIR)/$$f || exit 1; \
done
+ $(Q)for f in $(INST_MAN1); do \
+ $(QUIET_INST_SH)install -v $$f $(DESTDIR)$(MAN1DIR)/$$f || exit 1; \
+ done
$(Q)for f in $(LIBS); do \
$(QUIET_INST_SH)install -m 644 -v $$f $(DESTDIR)$(LIBDIR)/$$f || exit 1; \
done