summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-texlive/texlive-humanities/texlive-humanities-2023_p68465.ebuild')
-rw-r--r--dev-texlive/texlive-humanities/texlive-humanities-2023_p68465.ebuild17
1 files changed, 15 insertions, 2 deletions
diff --git a/dev-texlive/texlive-humanities/texlive-humanities-2023_p68465.ebuild b/dev-texlive/texlive-humanities/texlive-humanities-2023_p68465.ebuild
index 57857b8..34caf32 100644
--- a/dev-texlive/texlive-humanities/texlive-humanities-2023_p68465.ebuild
+++ b/dev-texlive/texlive-humanities/texlive-humanities-2023_p68465.ebuild
@@ -156,7 +156,7 @@ SLOT="0"
KEYWORDS="~amd64 ~arm64 ~ppc ~riscv ~x86"
COMMON_DEPEND="
>=dev-texlive/texlive-latex-2023
- app-text/sword
+ doc? ( app-text/sword )
"
RDEPEND="
${COMMON_DEPEND}
@@ -169,8 +169,21 @@ TEXLIVE_MODULE_BINSCRIPTS="
texmf-dist/scripts/diadia/diadia.lua
"
+src_prepare() {
+ default
+
+ if use doc; then
+ # https://github.com/olsak/OpBible/pull/1
+ eapply "${FILESDIR}"/${PN}-2023-opbible-improve-Makefile-respect-user-flags.patch
+ # Remove the binary, so that it is rebuild.
+ rm texmf-dist/doc/luatex/opbible/txs-gen/mod2tex || die
+ fi
+}
+
src_compile() {
- emake -C texmf-dist/doc/luatex/opbible/txs-gen
+ if use doc; then
+ emake -C texmf-dist/doc/luatex/opbible/txs-gen
+ fi
texlive-module_src_compile
}