summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Heidelberger <david.heidelberger@ixit.cz>2014-10-18 22:04:44 +0200
committerDavid Heidelberger <david.heidelberger@ixit.cz>2014-10-18 22:04:44 +0200
commit484be17fd6b8af4b9cb8e388581bed6765c485b9 (patch)
tree1230ffe98ae17a3affce2f61101c0b791a2ca286
parentx11-drivers/ati-drivers fix linux-3.17 no_hotplug build failure (diff)
downloadx11-484be17fd6b8af4b9cb8e388581bed6765c485b9.tar.gz
x11-484be17fd6b8af4b9cb8e388581bed6765c485b9.tar.bz2
x11-484be17fd6b8af4b9cb8e388581bed6765c485b9.zip
x11-libs/libxcb: drop xevie and xprint
Dropped from X-Server in 2008, oldest available xorg-server in portage is 1.9.5 from 2011. Signed-off-by: David Heidelberger <david.heidelberger@ixit.cz>
-rw-r--r--x11-libs/libxcb/files/libxcb-1.11-xevie-xprint_removal.patch30
-rw-r--r--x11-libs/libxcb/libxcb-1.11.ebuild3
2 files changed, 33 insertions, 0 deletions
diff --git a/x11-libs/libxcb/files/libxcb-1.11-xevie-xprint_removal.patch b/x11-libs/libxcb/files/libxcb-1.11-xevie-xprint_removal.patch
new file mode 100644
index 00000000..e8c24d34
--- /dev/null
+++ b/x11-libs/libxcb/files/libxcb-1.11-xevie-xprint_removal.patch
@@ -0,0 +1,30 @@
+Both extensions have been dropped from the X-Server in 2008:
+ http://cgit.freedesktop.org/xorg/xserver/commit/?id=1c8bd31
+ http://cgit.freedesktop.org/xorg/xserver/commit/?id=f4036f6
+
+Don't build them by default.
+
+Reviewed-by: Julien Cristau <jcristau@debian.org>
+Signed-off-by: Daniel Martin <consume.noise@gmail.com>
+Signed-off-by: Uli Schlachter <psychon@znc.in>
+
+diff --git a/a/configure.ac b/b/configure.ac
+index eb4a971..c9a1e91 100644
+--- a/a/configure.ac
++++ b/b/configure.ac
+@@ -227,13 +227,13 @@ XCB_EXTENSION(Screensaver, "yes")
+ XCB_EXTENSION(Shape, "yes")
+ XCB_EXTENSION(Shm, "yes")
+ XCB_EXTENSION(Sync, "yes")
+-XCB_EXTENSION(Xevie, "yes")
++XCB_EXTENSION(Xevie, "no")
+ XCB_EXTENSION(XFixes, "yes")
+ XCB_EXTENSION(XFree86-DRI, "yes")
+ XCB_EXTENSION(Xinerama, "yes")
+ XCB_EXTENSION(XInput, "no")
+ XCB_EXTENSION(XKB, "yes")
+-XCB_EXTENSION(Xprint, "yes")
++XCB_EXTENSION(Xprint, "no")
+ XCB_EXTENSION(SELinux, "no")
+ XCB_EXTENSION(XTest, "yes")
+ XCB_EXTENSION(Xv, "yes")
diff --git a/x11-libs/libxcb/libxcb-1.11.ebuild b/x11-libs/libxcb/libxcb-1.11.ebuild
index e67a10c5..5d4b500d 100644
--- a/x11-libs/libxcb/libxcb-1.11.ebuild
+++ b/x11-libs/libxcb/libxcb-1.11.ebuild
@@ -9,6 +9,7 @@ PYTHON_REQ_USE=xml
XORG_DOC=doc
XORG_MULTILIB=yes
+XORG_EAUTORECONF=yes
inherit python-any-r1 xorg-2
DESCRIPTION="X C-language Bindings library"
@@ -39,6 +40,8 @@ pkg_setup() {
python-any-r1_pkg_setup
}
+PATCHES=( "${FILESDIR}/${P}-xevie-xprint_removal.patch" )
+
src_configure() {
XORG_CONFIGURE_OPTIONS=(
$(use_enable doc build-docs)