summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-02 16:25:56 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-02 20:30:23 +0100
commitaead74d8ce4c2b134eaa9fbd900b6c95e200db29 (patch)
tree4733086b7d37425efc63f13971cfcfb48942c977
parentdev-python/pulsectl: Enable py3.12 (diff)
downloadgentoo-aead74d8ce4c2b134eaa9fbd900b6c95e200db29.tar.gz
gentoo-aead74d8ce4c2b134eaa9fbd900b6c95e200db29.tar.bz2
gentoo-aead74d8ce4c2b134eaa9fbd900b6c95e200db29.zip
dev-python/pulsectl-asyncio: New package, v1.1.1
New dependency for x11-wm/qtile, thanks to Etn40ff for the initial ebuild. Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pulsectl-asyncio/Manifest1
-rw-r--r--dev-python/pulsectl-asyncio/metadata.xml12
-rw-r--r--dev-python/pulsectl-asyncio/pulsectl-asyncio-1.1.1.ebuild41
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/pulsectl-asyncio/Manifest b/dev-python/pulsectl-asyncio/Manifest
new file mode 100644
index 000000000000..ecfee5f80efd
--- /dev/null
+++ b/dev-python/pulsectl-asyncio/Manifest
@@ -0,0 +1 @@
+DIST pulsectl-asyncio-1.1.1.gh.tar.gz 19425 BLAKE2B c950dc0e003c6795fba0b122ed9b5e3c0bb61adb1a26901f467e508ff3def64bc7c0a25e4250decbbd55aedd66ef5b030ced004e797a94ee0a5988043cd7dedb SHA512 b495295ee13d54e136cd70daaf3675239aa96faa284bd2ad0d21496821ee818f67ebbe83269a4201ea0bee99b5b2b78be3945909e1b2519078bc38c2529734bf
diff --git a/dev-python/pulsectl-asyncio/metadata.xml b/dev-python/pulsectl-asyncio/metadata.xml
new file mode 100644
index 000000000000..798c499d03bf
--- /dev/null
+++ b/dev-python/pulsectl-asyncio/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">mhthies/pulsectl-asyncio</remote-id>
+ <remote-id type="pypi">pulsectl-asyncio</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pulsectl-asyncio/pulsectl-asyncio-1.1.1.ebuild b/dev-python/pulsectl-asyncio/pulsectl-asyncio-1.1.1.ebuild
new file mode 100644
index 000000000000..a0217de9e234
--- /dev/null
+++ b/dev-python/pulsectl-asyncio/pulsectl-asyncio-1.1.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Asyncio frontend for pulsectl, Python bindings of libpulse"
+HOMEPAGE="
+ https://github.com/mhthies/pulsectl-asyncio/
+ https://pypi.org/project/pulsectl-asyncio/
+"
+# sdist is missing examples that are used in tests
+SRC_URI="
+ https://github.com/mhthies/pulsectl-asyncio/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/pulsectl-23.5.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ media-sound/pulseaudio-daemon
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e 's:,<=[0-9.]*::' setup.cfg || die
+ distutils-r1_src_prepare
+}