summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-06-28 17:09:55 +0200
committerDavid Seifert <soap@gentoo.org>2022-06-28 17:09:55 +0200
commitf2909e2c89dc2b9193a84862cdea1e5e1319c387 (patch)
tree0b8543dec4b65efb60daa71925edfcb98d22e45c /app-admin/webalizer
parentwww-apache/mpm_itk: update EAPI 5 -> 7 (diff)
downloadgentoo-f2909e2c89dc2b9193a84862cdea1e5e1319c387.tar.gz
gentoo-f2909e2c89dc2b9193a84862cdea1e5e1319c387.tar.bz2
gentoo-f2909e2c89dc2b9193a84862cdea1e5e1319c387.zip
app-admin/webalizer: update EAPI 5 -> 8
Closes: https://bugs.gentoo.org/835387 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-admin/webalizer')
-rw-r--r--app-admin/webalizer/files/webalizer-2.23.08-broken-disable-static.patch16
-rw-r--r--app-admin/webalizer/webalizer-2.23.08-r1.ebuild (renamed from app-admin/webalizer/webalizer-2.23.08.ebuild)24
2 files changed, 30 insertions, 10 deletions
diff --git a/app-admin/webalizer/files/webalizer-2.23.08-broken-disable-static.patch b/app-admin/webalizer/files/webalizer-2.23.08-broken-disable-static.patch
new file mode 100644
index 000000000000..109740a33ccb
--- /dev/null
+++ b/app-admin/webalizer/files/webalizer-2.23.08-broken-disable-static.patch
@@ -0,0 +1,16 @@
+--- a/configure
++++ b/configure
+@@ -3939,13 +3939,6 @@
+
+
+ if test "$GCC" = "yes"; then
+-
+- # Check whether --enable-static was given.
+-if test "${enable_static+set}" = set; then
+- enableval=$enable_static; LDFLAGS="--static ${LDFLAGS}"
+-fi
+-
+-
+ if test "$IN_CFLAGS" = ""; then
+ CFLAGS="-Wall -O2"
+ fi
diff --git a/app-admin/webalizer/webalizer-2.23.08.ebuild b/app-admin/webalizer/webalizer-2.23.08-r1.ebuild
index 8eb9f1511f93..4599eb628b61 100644
--- a/app-admin/webalizer/webalizer-2.23.08.ebuild
+++ b/app-admin/webalizer/webalizer-2.23.08-r1.ebuild
@@ -4,15 +4,15 @@
# uses webapp.eclass to create directories with right permissions
# probably slight overkill but works well
-EAPI="5"
+EAPI=8
-inherit flag-o-matic versionator epatch webapp db-use
+inherit flag-o-matic webapp db-use
WEBAPP_MANUAL_SLOT="yes"
XTENDED_VER="RB30"
XTENDED_URL="rb30"
-MY_PV="$(get_version_component_range 1-2)-$(get_version_component_range 3)"
+MY_PV="$(ver_cut 1-2)-$(ver_cut 3)"
MY_P="${PN}-${MY_PV}"
GEODB_DATE="20140201"
@@ -21,17 +21,20 @@ GEODB_DIR="/usr/share/webalizer/geodb"
DESCRIPTION="Webserver log file analyzer"
HOMEPAGE="http://www.webalizer.org/"
-SRC_URI="ftp://ftp.mrunix.net/pub/webalizer/${MY_P}-src.tar.bz2
+SRC_URI="
+ ftp://ftp.mrunix.net/pub/webalizer/${MY_P}-src.tar.bz2
xtended? ( http://patrickfrei.ch/webalizer/${XTENDED_URL}/${PN}-${MY_PV}-${XTENDED_VER}-patch.tar.gz )
https://dev.gentoo.org/~blueness/webalizer/webalizer.conf.gz
${GEODB_URL}/webalizer-geodb-${GEODB_DATE}.tgz"
+S="${WORKDIR}/${MY_P}"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="~alpha amd64 ~arm ~hppa ppc ppc64 ~sparc x86"
IUSE="bzip2 xtended geoip nls"
-SLOT="0"
-DEPEND=">=sys-libs/db-4.2:*
+DEPEND="
+ >=sys-libs/db-4.2:*
>=sys-libs/zlib-1.1.4
>=media-libs/libpng-1.2:0=
>=media-libs/gd-1.8.3[png]
@@ -39,8 +42,6 @@ DEPEND=">=sys-libs/db-4.2:*
bzip2? ( app-arch/bzip2 )"
RDEPEND="${DEPEND}"
-S="${WORKDIR}"/${MY_P}
-
pkg_setup() {
webapp_pkg_setup
@@ -53,10 +54,13 @@ pkg_setup() {
}
src_prepare() {
- epatch "${FILESDIR}"/${PN}-2.23.08-gcc-10.patch
+ eapply "${FILESDIR}"/${PN}-2.23.08-broken-disable-static.patch
+ eapply "${FILESDIR}"/${PN}-2.23.08-gcc-10.patch
if use xtended; then
- epatch "${WORKDIR}"/${PN}-${MY_PV}-${XTENDED_VER}-patch
+ eapply "${WORKDIR}"/${PN}-${MY_PV}-${XTENDED_VER}-patch
fi
+
+ eapply_user
}
src_configure() {