summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-29 19:11:24 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-29 19:11:24 +0100
commit12a146807bbc9ea9488826c0fa43cce458163c47 (patch)
treea8a951f03f9bf817529b0b99bada103aa73561bc /app-arch/lzlib
parentgnome-extra/gnome-shell-extension-alphabetical-grid: Drop old (diff)
downloadgentoo-12a146807bbc9ea9488826c0fa43cce458163c47.tar.gz
gentoo-12a146807bbc9ea9488826c0fa43cce458163c47.tar.bz2
gentoo-12a146807bbc9ea9488826c0fa43cce458163c47.zip
app-arch/lzlib: Bump to 1.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-arch/lzlib')
-rw-r--r--app-arch/lzlib/Manifest1
-rw-r--r--app-arch/lzlib/lzlib-1.13.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/app-arch/lzlib/Manifest b/app-arch/lzlib/Manifest
index 7911ded06777..a9d3ec48eb6a 100644
--- a/app-arch/lzlib/Manifest
+++ b/app-arch/lzlib/Manifest
@@ -1,2 +1,3 @@
DIST lzlib-1.11.tar.gz 105873 BLAKE2B 6caadc4c3b78db835bcf4f11e5290342f0f952943006589345898a85211b0a0ae5d775d0a8e7747c549eae00dd0abd2e2afb5c07eb75b4fda712a9361a71bd59 SHA512 5aa3ff084177efe906518724a98a78c32d1c0e02b967800a44388fc6af441de48fcc5899457913fca11fae3beb8bebc260ac447f0a336b1c14f3f13726114567
DIST lzlib-1.12.tar.gz 128996 BLAKE2B 3a86005eaf660a45888ec5af97bc6100368da2a3003c119c2379e881cd77ef318707342b7c930efa9473b671b8c2aff5c5e00dd5b312f647b7cafc39f29a2eea SHA512 b5379422eed4016b0ee124e39902dd22c314ca5cc5f72c1af5ec2ef6a68e1e85c523ab18e30048d453689f73f780d0144dcabaf881337e1c8101e2fe17ee21f8
+DIST lzlib-1.13.tar.gz 130005 BLAKE2B 88721890f111c2bb1901329e9cc39e7f581c220bb58bbc93098c34984b7557a80adff236f5755057099870ba20201f6b692925080b97965b4612d221d21cb33c SHA512 b9c4e5a9aca982984b497d1da2e1f0439b37b19acaf88a02f5af114b0a65a828c5ae235b3bd4f419ce001963de38a4d03445a6a1bd93f37e783e799abd75578d
diff --git a/app-arch/lzlib/lzlib-1.13.ebuild b/app-arch/lzlib/lzlib-1.13.ebuild
new file mode 100644
index 000000000000..070ed59f4850
--- /dev/null
+++ b/app-arch/lzlib/lzlib-1.13.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Library for lzip compression"
+HOMEPAGE="https://www.nongnu.org/lzip/lzlib.html"
+SRC_URI="https://download.savannah.gnu.org/releases/lzip/${PN}/${P}.tar.gz"
+
+LICENSE="libstdc++" # fancy form of GPL-2+ with library exception
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+src_configure() {
+ local myconf=(
+ --enable-shared
+ --disable-static
+ --disable-ldconfig
+ --prefix="${EPREFIX}"/usr
+ --libdir='$(prefix)'/$(get_libdir)
+ CC="$(tc-getCC)"
+ CFLAGS="${CFLAGS}"
+ CPPFLAGS="${CPPFLAGS}"
+ LDFLAGS="${LDFLAGS}"
+ )
+
+ # not autotools-based
+ ./configure "${myconf[@]}" || die
+}