summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2016-11-06 01:43:51 +0800
committerJason Zaman <perfinion@gentoo.org>2016-11-06 19:21:10 +0800
commit823dcad5aac5180bac41b4151582bc1dffb2fed6 (patch)
tree9c2fb104e50938f471edba5ab1a3922c4d2224b2 /app-crypt/simple-tpm-pk11/simple-tpm-pk11-0.06.ebuild
parentsys-boot/tboot: snapshot version from 20161101 (diff)
downloadgentoo-823dcad5aac5180bac41b4151582bc1dffb2fed6.tar.gz
gentoo-823dcad5aac5180bac41b4151582bc1dffb2fed6.tar.bz2
gentoo-823dcad5aac5180bac41b4151582bc1dffb2fed6.zip
app-crypt/simple-tpm-pk11: bump to 0.06
Package-Manager: portage-2.3.0
Diffstat (limited to 'app-crypt/simple-tpm-pk11/simple-tpm-pk11-0.06.ebuild')
-rw-r--r--app-crypt/simple-tpm-pk11/simple-tpm-pk11-0.06.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-crypt/simple-tpm-pk11/simple-tpm-pk11-0.06.ebuild b/app-crypt/simple-tpm-pk11/simple-tpm-pk11-0.06.ebuild
new file mode 100644
index 000000000000..46cada90183f
--- /dev/null
+++ b/app-crypt/simple-tpm-pk11/simple-tpm-pk11-0.06.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Simple PKCS11 provider for TPM chips"
+HOMEPAGE="https://github.com/ThomasHabets/simple-tpm-pk11"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/ThomasHabets/${PN}.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/ThomasHabets/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+IUSE="libressl"
+RESTRICT="test" # needs to communicate with the TPM and gtest is all broken
+
+DEPEND="app-crypt/tpm-tools[pkcs11]
+ dev-libs/opencryptoki[tpm]
+ app-crypt/trousers
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )"
+RDEPEND="${DEPEND}
+ net-misc/openssh[-X509]"
+
+src_prepare() {
+ eapply_user
+ eautoreconf
+}