summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-11-03 23:22:40 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-11-04 01:19:24 +0100
commit5ab54d195492f00eb6aece6bae6feafde2fa3d40 (patch)
treeb4ac8526c3f60c58ca25e9b0e8375a0f415d7e6c /app-emacs
parentapp-emacs/magit: drop old 4.0.0 (diff)
downloadgentoo-5ab54d195492f00eb6aece6bae6feafde2fa3d40.tar.gz
gentoo-5ab54d195492f00eb6aece6bae6feafde2fa3d40.tar.bz2
gentoo-5ab54d195492f00eb6aece6bae6feafde2fa3d40.zip
app-emacs/magit: bump to 4.1.2
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/magit/Manifest1
-rw-r--r--app-emacs/magit/magit-4.1.2.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/app-emacs/magit/Manifest b/app-emacs/magit/Manifest
index 03c665e3accf..7a6bd1b72845 100644
--- a/app-emacs/magit/Manifest
+++ b/app-emacs/magit/Manifest
@@ -1,2 +1,3 @@
DIST magit-4.1.0.tar.gz 673317 BLAKE2B 6457c77f08605e3665b3fadcb4d6bc48d21498e370261d9709305e774de579be4647afb6e598a446a3ddf06e47baef6561a48706609812991a24e3ab2b22d416 SHA512 063c23a7f1a9099d7ec020980be936b30b85756b30bded48264939c5ae7f742820efc3eadc8ba480ad328ca7276a9d35bb168e6b7a42ea8dfa6a2c1e13b8cc90
DIST magit-4.1.1.tar.gz 674147 BLAKE2B 4878061957f342aa1c76e8f356a59d6e13ceba35dad6ed0adf4ba59484a3cb9585855aaeec91a40f6dddd9bfa53c0ed0733b506c19be70a5b056ba70dbb27f4e SHA512 c1ab5b4dadf11a0eafcb69ac46c7c1aa19595a1a76e0cf3b8afa987e64c4b525007753179da1e146dab89504f1b436e9141c76025019bd1077d2172beab8105b
+DIST magit-4.1.2.tar.gz 675015 BLAKE2B 0ae4ac04d5b7a20d0ac444e9b87819ca98bebb5b66b6a193f5f9be0d050b07319ed6262f20a0167ecc2d34e9f00b80f4f0eed04b1e673a87b056c33cd9fe564d SHA512 c41abb1525e46b6121f8b7339c598c2773ff23ec35f1dbc3392d63b35e656499026e64b0905a2c97ddbb21e4f547ea9cab0c8df9b0b5ff996c26995940c27f79
diff --git a/app-emacs/magit/magit-4.1.2.ebuild b/app-emacs/magit/magit-4.1.2.ebuild
new file mode 100644
index 000000000000..fe0cb5bb99dd
--- /dev/null
+++ b/app-emacs/magit/magit-4.1.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="A Git porcelain inside Emacs"
+HOMEPAGE="https://magit.vc/
+ https://github.com/magit/magit/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+fi
+
+S="${WORKDIR}/${P}/lisp"
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( ../README.md ../docs/AUTHORS.md ../docs/RelNotes )
+ELISP_TEXINFO="../docs/*.texi"
+SITEFILE="50${PN}-gentoo.el"
+
+RDEPEND="
+ >=app-emacs/compat-30.0.0.0
+ >=app-emacs/dash-2.19.1
+ >=app-emacs/transient-0.7.7
+ >=app-emacs/with-editor-3.4.2
+"
+BDEPEND="
+ ${RDEPEND}
+ sys-apps/texinfo
+"
+RDEPEND+="
+ >=dev-vcs/git-2.44.2
+"
+
+src_prepare() {
+ default
+
+ echo "(setq ${PN}-version \"${PV}\")" > "./${PN}-version.el" || die
+}