summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2024-11-10 14:30:47 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2024-11-10 14:31:54 +0100
commit9ece0a0d64d4075c6a1dd72c3bf5b13a218110e7 (patch)
tree41008c25d1053c47c23b0b3fda2be8b92a306ed4 /app-office
parentmedia-libs/libsdl: drop 1.2.15_p20221201, 1.2.64, 1.2.64_p20230726 (diff)
downloadgentoo-9ece0a0d64d4075c6a1dd72c3bf5b13a218110e7.tar.gz
gentoo-9ece0a0d64d4075c6a1dd72c3bf5b13a218110e7.tar.bz2
gentoo-9ece0a0d64d4075c6a1dd72c3bf5b13a218110e7.zip
app-office/sc-im: add upstream patch for missing include
Closes: https://bugs.gentoo.org/933356 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/sc-im/files/sc-im-0.8.3-malloc.patch21
-rw-r--r--app-office/sc-im/sc-im-0.8.3-r1.ebuild4
2 files changed, 25 insertions, 0 deletions
diff --git a/app-office/sc-im/files/sc-im-0.8.3-malloc.patch b/app-office/sc-im/files/sc-im-0.8.3-malloc.patch
new file mode 100644
index 000000000000..a4aae6458e9d
--- /dev/null
+++ b/app-office/sc-im/files/sc-im-0.8.3-malloc.patch
@@ -0,0 +1,21 @@
+From b6fcd0658d566dac0fa0b7e83235c8721877d7a0 Mon Sep 17 00:00:00 2001
+From: Ryan Jaskulski <ryan.jaskulski@gmail.com>
+Date: Fri, 17 May 2024 20:57:46 -0400
+Subject: [PATCH] fixed compiler error related to missing include
+
+---
+ formats/ods.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/formats/ods.c b/formats/ods.c
+index a2e701a5..f7d7372d 100644
+--- a/formats/ods.c
++++ b/formats/ods.c
+@@ -50,6 +50,7 @@
+ #include <errno.h>
+ #include <zip.h>
+ #include <libxml/parser.h>
++#include <stdlib.h>
+
+ #include "../tui.h"
+ #include "../cmds/cmds.h"
diff --git a/app-office/sc-im/sc-im-0.8.3-r1.ebuild b/app-office/sc-im/sc-im-0.8.3-r1.ebuild
index bf62fb3ad657..044188f182b4 100644
--- a/app-office/sc-im/sc-im-0.8.3-r1.ebuild
+++ b/app-office/sc-im/sc-im-0.8.3-r1.ebuild
@@ -44,6 +44,10 @@ RDEPEND="${DEPEND}"
BDEPEND="app-alternatives/yacc
virtual/pkgconfig"
+PATCHES=(
+ "${FILESDIR}/${P}-malloc.patch"
+)
+
pkg_setup() {
CONFLICTING=$(usex tmux "tmux " "")$(usex wayland "wayland " "")$(usex X "X" "")
if ( use tmux && ( use wayland || use X ) ) ; then