summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2017-12-16 13:09:04 +0700
committerAndrey Grozin <grozin@gentoo.org>2017-12-16 13:11:49 +0700
commitedf8dc3fa3ab3017761b41bf81ffc18b42581300 (patch)
tree8e0b73276aec05a95151018a3020e5cefcbc7bba /app-text
parentmedia-radio/xwxapt: Version bump (diff)
downloadgentoo-edf8dc3fa3ab3017761b41bf81ffc18b42581300.tar.gz
gentoo-edf8dc3fa3ab3017761b41bf81ffc18b42581300.tar.bz2
gentoo-edf8dc3fa3ab3017761b41bf81ffc18b42581300.zip
app-text/doconce: bump to 1.4.4, USE flag doc added
Package-Manager: Portage-2.3.18, Repoman-2.3.6
Diffstat (limited to 'app-text')
-rw-r--r--app-text/doconce/Manifest1
-rw-r--r--app-text/doconce/doconce-1.4.4.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/app-text/doconce/Manifest b/app-text/doconce/Manifest
index f7ce7d6358e2..832e9d90e37b 100644
--- a/app-text/doconce/Manifest
+++ b/app-text/doconce/Manifest
@@ -1 +1,2 @@
DIST doconce-1.3.tar.bz2 112034753 BLAKE2B 4ac826b09ca2dce93d8725868f6fa00a07b61835336a56b72f4d846cb81282cc6982ca25c7fc27d9e66aed5a22d3ef30badbc137748f7c6c3a2e078554b6715e SHA512 b59568e801f4cc5b7f01f3c3d344702ec80c65b5a065e2ece3b3ed8cb5f669739c9adf3caf96cd0b43c646ccae0f11325d5ca64ee1a325ac404ec6e5feb6148d
+DIST doconce-1.4.4.tar.bz2 112713371 BLAKE2B 65acba4d02095d616c5ca6a070bb4a80ae57b4f201d9810f7b88e212e1ea86bd211440213194c4d61a2eefd19dfa9de9f81376d3e535f032747a8102bfdc2160 SHA512 9b5caae789a395bcdbb4daeea57182f2ea21a2c3c4da0abae2c097351fece601da6901de8d89ab60a187c1bc0ba5f913bbee14a847c1f85020dc16e0cdffdf31
diff --git a/app-text/doconce/doconce-1.4.4.ebuild b/app-text/doconce/doconce-1.4.4.ebuild
new file mode 100644
index 000000000000..5028993da166
--- /dev/null
+++ b/app-text/doconce/doconce-1.4.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+inherit distutils-r1
+
+DESCRIPTION="A markdown-like langauge to generate docs in html, LaTeX, and many other formats"
+HOMEPAGE="https://github.com/hplgit/doconce/ https://pypi.python.org/pypi/Doconce/"
+SRC_URI="https://dev.gentoo.org/~grozin/${P}.tar.bz2"
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc"
+KEYWORDS="~amd64 ~x86"
+RDEPEND="dev-python/future[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+src_install() {
+ default
+ if use doc; then
+ sed -e "s|http://hplgit.github.io/doconce/doc|file:///usr/share/doc/${PF}|g" -i doc/web/index.html
+ docompress -x /usr/share/doc
+ dodoc -r doc/web doc/pub
+ fi
+}