summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2019-07-28 19:37:41 +0200
committerUlrich Müller <ulm@gentoo.org>2019-07-28 19:38:47 +0200
commita71a6e96c71cd0fef286d6395decace719d7d612 (patch)
treede07cf0f283148a46408200ab3741da4fad727bf /app-xemacs
parentapp-emacs/ebuild-mode: Bump to version 1.47. (diff)
downloadgentoo-a71a6e96c71cd0fef286d6395decace719d7d612.tar.gz
gentoo-a71a6e96c71cd0fef286d6395decace719d7d612.tar.bz2
gentoo-a71a6e96c71cd0fef286d6395decace719d7d612.zip
app-xemacs/ebuild-mode: Bump to version 1.47.
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-xemacs')
-rw-r--r--app-xemacs/ebuild-mode/Manifest1
-rw-r--r--app-xemacs/ebuild-mode/ebuild-mode-1.47.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/app-xemacs/ebuild-mode/Manifest b/app-xemacs/ebuild-mode/Manifest
index 607da136ec38..4bb9466f5749 100644
--- a/app-xemacs/ebuild-mode/Manifest
+++ b/app-xemacs/ebuild-mode/Manifest
@@ -1 +1,2 @@
DIST ebuild-mode-1.46.tar.xz 34928 BLAKE2B ee2686f3862fc7aa5f820311a6e45d62b153426134422c56a2a6222795163f454291da5510e86c52edee1b22b7bec641ceb132147b29243ee647774a8e91342b SHA512 e7a81c9a3692db1c6db41e138b382e3027094529d4ad3244ecde5a245340f911f8a63ce8ce8bbd7910116c704bcf8fcce90142b8863ecc1b543760ef1411833e
+DIST ebuild-mode-1.47.tar.xz 34812 BLAKE2B abbc3be110239f9e1765d4f1293856a7fc616d497ac5256a28b7d78fc57c8d725abccbf7b9e5908cb85f9a684dc1be26ab88152d836c2ec3a481802091729717 SHA512 13ee756ef914a314f6705df78735a3926a50d156f4abeff917bed68298aec81f072d53a60f7b985d9bb2caddcdbf65fd26f6c9189e6c5c1822674d9142b7db17
diff --git a/app-xemacs/ebuild-mode/ebuild-mode-1.47.ebuild b/app-xemacs/ebuild-mode/ebuild-mode-1.47.ebuild
new file mode 100644
index 000000000000..ad5a9ccad6d0
--- /dev/null
+++ b/app-xemacs/ebuild-mode/ebuild-mode-1.47.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xemacs-elisp
+
+DESCRIPTION="Emacs modes for editing ebuilds and other Gentoo specific files"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Emacs"
+SRC_URI="https://dev.gentoo.org/~ulm/emacs/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+
+RDEPEND=">=app-editors/xemacs-21.4.20-r5
+ app-xemacs/sh-script"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ ${XEMACS_BATCH_CLEAN} -eval "(add-to-list 'load-path \".\")" \
+ -f batch-byte-compile ebuild-mode.el gentoo-newsitem-mode.el || die
+ xemacs-elisp-make-autoload-file \
+ ebuild-mode.el gentoo-newsitem-mode.el || die
+}