summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-11-05 23:04:03 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2016-11-05 23:23:04 +0000
commit6f394690eb3d55820d47150739675a340cab709d (patch)
treef801643821f4d61b018574b562c5899c3a36ed46 /dev-haskell
parentdev-haskell/bytestring-show: allow ghc-8 (diff)
downloadgentoo-6f394690eb3d55820d47150739675a340cab709d.tar.gz
gentoo-6f394690eb3d55820d47150739675a340cab709d.tar.bz2
gentoo-6f394690eb3d55820d47150739675a340cab709d.zip
dev-haskell/chell-quickcheck: allow QuickCheck-2.9
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/chell-quickcheck/chell-quickcheck-0.2.5-r1.ebuild37
-rw-r--r--dev-haskell/chell-quickcheck/files/chell-quickcheck-0.2.5-QC-2.9.patch11
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-haskell/chell-quickcheck/chell-quickcheck-0.2.5-r1.ebuild b/dev-haskell/chell-quickcheck/chell-quickcheck-0.2.5-r1.ebuild
new file mode 100644
index 000000000000..0dd4ce335908
--- /dev/null
+++ b/dev-haskell/chell-quickcheck/chell-quickcheck-0.2.5-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="QuickCheck support for the Chell testing library"
+HOMEPAGE="https://john-millikin.com/software/chell/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/chell-0.3:=[profile?] <dev-haskell/chell-0.5:=[profile?]
+ >=dev-haskell/quickcheck-2.3:2=[profile?]
+ dev-haskell/random:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+PATCHES=("${FILESDIR}"/${P}-QC-2.9.patch)
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'QuickCheck >= 2.3 && < 2.9' 'QuickCheck >= 2.3'
+}
diff --git a/dev-haskell/chell-quickcheck/files/chell-quickcheck-0.2.5-QC-2.9.patch b/dev-haskell/chell-quickcheck/files/chell-quickcheck-0.2.5-QC-2.9.patch
new file mode 100644
index 000000000000..50a2d07f3caa
--- /dev/null
+++ b/dev-haskell/chell-quickcheck/files/chell-quickcheck-0.2.5-QC-2.9.patch
@@ -0,0 +1,11 @@
+diff --git a/lib/Test/Chell/QuickCheck.hs b/lib/Test/Chell/QuickCheck.hs
+index 56cbd04..c630320 100644
+--- a/lib/Test/Chell/QuickCheck.hs
++++ b/lib/Test/Chell/QuickCheck.hs
+@@ -103,5 +103,3 @@ maxDiscardedTests :: QuickCheck.Testable prop => QuickCheck.Args -> prop -> Int
+ #if MIN_VERSION_QuickCheck(2,5,0)
+-maxDiscardedTests args p = if QuickCheck.exhaustive p
+- then QuickCheck.maxDiscardRatio args
+- else QuickCheck.maxDiscardRatio args * QuickCheck.maxSuccess args
++maxDiscardedTests args _ = QuickCheck.maxDiscardRatio args * QuickCheck.maxSuccess args
+ #else