summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2022-08-15 09:54:37 +0200
committerJohn Helmert III <ajak@gentoo.org>2022-08-15 12:20:39 -0500
commit27528c9faba395f5de105f08576283bd9867c2ba (patch)
treefba5f2feab5153ff97b6f158f19e0a30c6447244 /dev-java/jdbc-postgresql
parentsys-devel/gcc: fix build for 9.5.0 w/ glibc-2.36 (diff)
downloadgentoo-27528c9faba395f5de105f08576283bd9867c2ba.tar.gz
gentoo-27528c9faba395f5de105f08576283bd9867c2ba.tar.bz2
gentoo-27528c9faba395f5de105f08576283bd9867c2ba.zip
dev-java/jdbc-postgresql: drop 42.4.0
Bug: https://bugs.gentoo.org/863506 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/26868 Signed-off-by: John Helmert III <ajak@gentoo.org>
Diffstat (limited to 'dev-java/jdbc-postgresql')
-rw-r--r--dev-java/jdbc-postgresql/Manifest1
-rw-r--r--dev-java/jdbc-postgresql/jdbc-postgresql-42.4.0.ebuild59
2 files changed, 0 insertions, 60 deletions
diff --git a/dev-java/jdbc-postgresql/Manifest b/dev-java/jdbc-postgresql/Manifest
index 7fe34114a6a3..4a263b6d3027 100644
--- a/dev-java/jdbc-postgresql/Manifest
+++ b/dev-java/jdbc-postgresql/Manifest
@@ -1,2 +1 @@
-DIST postgresql-jdbc-42.4.0.src.tar.gz 966868 BLAKE2B 0a8bffcfbba4ddedcbd77717b6bca2f4e7cd9fe4597c6edb5a2ac8fbea788c692377ae713723aa7342895f857aff7eca0825eedd36cff69f3760b11cbb7b666c SHA512 816967923f54d5c2ad856e3ae2612987fa52234acc6b487f492d56614ac241d9542abd40a1f868ad6d895a45de28f7a0d586f8486dc719600238bcc3ef40819a
DIST postgresql-jdbc-42.4.1.src.tar.gz 969554 BLAKE2B 76035b2362c304d6263b9549b2ecbedc6e1cfedeba9c2c35f07d29dada39e5bce93e939abb8cb2232a428b0341c5cd5e6ae22de6106292c4d28243e3e0e6fc00 SHA512 a49c5b68a26ba6fd1b150c45da2ec58ea4435b7c36b8aa9bf6c3d33b6a265dabe7da51705e9d7234a640c8f6ccb5c3abb639db2d7bc38e6f4e26550b05b4a844
diff --git a/dev-java/jdbc-postgresql/jdbc-postgresql-42.4.0.ebuild b/dev-java/jdbc-postgresql/jdbc-postgresql-42.4.0.ebuild
deleted file mode 100644
index 37557d8f291b..000000000000
--- a/dev-java/jdbc-postgresql/jdbc-postgresql-42.4.0.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# Skeleton command:
-# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri https://jdbc.postgresql.org/download/postgresql-jdbc-42.4.0.src.tar.gz --slot 0 --keywords "~amd64 ~ppc64 ~x86" --ebuild jdbc-postgresql-42.4.0.ebuild
-
-EAPI=8
-
-JAVA_PKG_IUSE="doc source"
-MAVEN_ID="org.postgresql:postgresql:42.4.0"
-# We don't have junit-vintage and junit-jupiter.
-# JAVA_TESTING_FRAMEWORKS="junit-vintage junit-jupiter junit-4"
-
-inherit java-pkg-2 java-pkg-simple
-
-DESCRIPTION="Java JDBC 4.2 (JRE 8+) driver for PostgreSQL database"
-HOMEPAGE="https://github.com/pgjdbc/pgjdbc"
-SRC_URI="https://jdbc.postgresql.org/download/postgresql-jdbc-${PV}.src.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="amd64 ppc64 x86"
-
-# Common dependencies
-# POM: pom.xml
-# com.ongres.scram:client:2.1 -> !!!groupId-not-found!!!
-# uk.org.webcompere:system-stubs-jupiter:1.2.0 -> !!!groupId-not-found!!!
-
-CP_DEPEND="dev-java/scram:0"
-
-# Compile dependencies
-# POM: pom.xml
-# test? junit:junit:4.13 -> >=dev-java/junit-4.13.2:4
-# test? org.junit.jupiter:junit-jupiter-api:5.6.0 -> !!!groupId-not-found!!!
-# test? org.junit.jupiter:junit-jupiter-engine:5.6.0 -> !!!groupId-not-found!!!
-# test? org.junit.jupiter:junit-jupiter-params:5.6.0 -> !!!groupId-not-found!!!
-# test? org.junit.vintage:junit-vintage-engine:5.6.0 -> !!!groupId-not-found!!!
-# test? se.jiderhamn:classloader-leak-test-framework:1.1.1 -> !!!groupId-not-found!!!
-
-DEPEND="
- >=virtual/jdk-1.8:*
- ${CP_DEPEND}"
-# test? (
-# !!!groupId-not-found!!!
-# )
-# "
-
-RDEPEND="
- >=virtual/jre-1.8:*
- ${CP_DEPEND}"
-
-S="${WORKDIR}/postgresql-${PV}-jdbc-src"
-
-JAVA_SRC_DIR="src/main/java"
-JAVA_RESOURCE_DIRS="src/main/resources"
-
-# JAVA_TEST_GENTOO_CLASSPATH="junit-4,!!!groupId-not-found!!!,!!!groupId-not-found!!!,!!!groupId-not-found!!!,!!!groupId-not-found!!!,!!!groupId-not-found!!!"
-# JAVA_TEST_SRC_DIR="src/test/java"
-# JAVA_TEST_RESOURCE_DIRS="src/test/resources"