summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/squareness-jlf
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/squareness-jlf')
-rw-r--r--dev-java/squareness-jlf/Manifest1
-rw-r--r--dev-java/squareness-jlf/files/build.xml17
-rw-r--r--dev-java/squareness-jlf/metadata.xml11
-rw-r--r--dev-java/squareness-jlf/squareness-jlf-2.3.0-r1.ebuild40
4 files changed, 69 insertions, 0 deletions
diff --git a/dev-java/squareness-jlf/Manifest b/dev-java/squareness-jlf/Manifest
new file mode 100644
index 000000000000..7891fd1e85cc
--- /dev/null
+++ b/dev-java/squareness-jlf/Manifest
@@ -0,0 +1 @@
+DIST squareness_jlf_src-2.3.0.zip 67307 SHA256 a7439f1343f5f13ff3a6709728f2d2ae112097f5da6b858e7b2a4417fd530c57 SHA512 9c3d1de6f682968b2e2db37afdaa571f53857897415df04489ecac1c545ddc0a8342df94c658797979a6024e6e69bbc9a8828029ec428248848c933c9f901a71 WHIRLPOOL 883d3cb71dbd24b22ed2ad2d1b0e9bce468dd8f7ddadc5593590bf69e8680821ef2824d8775577f2c03bd86fa46a9a43cb4ff50d5402d80977737dc7471877f2
diff --git a/dev-java/squareness-jlf/files/build.xml b/dev-java/squareness-jlf/files/build.xml
new file mode 100644
index 000000000000..d4d7fdc7cf1a
--- /dev/null
+++ b/dev-java/squareness-jlf/files/build.xml
@@ -0,0 +1,17 @@
+<project name="squareness-jlf" default="jar">
+ <target name="compile">
+ <mkdir dir="build"/>
+ <javac srcdir="." destdir="build" classpath="${gentoo.classpath}">
+ </javac>
+ </target>
+
+ <target name="jar" depends="compile">
+ <jar destfile="squareness-jlf.jar" basedir="build"/>
+ </target>
+
+ <target name="javadoc" depends="compile">
+ <mkdir dir="docs"/>
+ <javadoc sourcepath="." destdir="docs" classpath="${gentoo.classpath}"/>
+ </target>
+
+</project>
diff --git a/dev-java/squareness-jlf/metadata.xml b/dev-java/squareness-jlf/metadata.xml
new file mode 100644
index 000000000000..4fb9ade43357
--- /dev/null
+++ b/dev-java/squareness-jlf/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <maintainer>
+ <email>java@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">squareness</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-java/squareness-jlf/squareness-jlf-2.3.0-r1.ebuild b/dev-java/squareness-jlf/squareness-jlf-2.3.0-r1.ebuild
new file mode 100644
index 000000000000..cbdcd625624d
--- /dev/null
+++ b/dev-java/squareness-jlf/squareness-jlf-2.3.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Squareness Java Look and Feel"
+HOMEPAGE="http://squareness.beeger.net/"
+SRC_URI="mirror://sourceforge/squareness/${PN/-/_}_src-${PV}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="${JAVA_PKG_IUSE}"
+
+S="${WORKDIR}"
+
+RDEPEND=">=virtual/jre-1.4
+ dev-java/laf-plugin:0"
+
+DEPEND=">=virtual/jdk-1.4
+ dev-java/laf-plugin:0"
+
+EANT_GENTOO_CLASSPATH="laf-plugin"
+
+java_prepare() {
+ cp "${FILESDIR}"/build.xml build.xml || die
+}
+
+src_install() {
+ java-pkg_dojar ${PN}.jar
+
+ use doc && java-pkg_dojavadoc docs
+ use source && java-pkg_dosrc net
+}