summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-04-04 23:15:07 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2019-04-04 23:15:07 +0100
commit9d02125285f4f32e90ae614bb756fd65230c4d82 (patch)
treeb0cacc84f518dc218b72633f9ef14fb5b10c953f /dev-libs/cloog
parentsys-devel/smatch: switch to https:// schema, bug #682508 (diff)
downloadgentoo-9d02125285f4f32e90ae614bb756fd65230c4d82.tar.gz
gentoo-9d02125285f4f32e90ae614bb756fd65230c4d82.tar.bz2
gentoo-9d02125285f4f32e90ae614bb756fd65230c4d82.zip
dev-libs/cloog: switch to https:// schema, bug #682502
Reported-by: Jeroen Roovers Closes: https://bugs.gentoo.org/682502 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-libs/cloog')
-rw-r--r--dev-libs/cloog/cloog-9999.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/dev-libs/cloog/cloog-9999.ebuild b/dev-libs/cloog/cloog-9999.ebuild
index 85781b4d72c3..44fb3bc55495 100644
--- a/dev-libs/cloog/cloog-9999.ebuild
+++ b/dev-libs/cloog/cloog-9999.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI="7"
inherit eutils multilib-minimal
if [[ ${PV} == *9999 ]] ; then
- EGIT_REPO_URI="git://repo.or.cz/cloog.git"
inherit autotools git-r3
+ EGIT_REPO_URI="https://repo.or.cz/cloog.git"
else
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
SRC_URI="http://www.bastoul.net/cloog/pages/download/${P}.tar.gz"
@@ -29,6 +29,8 @@ DEPEND="${DEPEND}
DOCS=( README )
src_prepare() {
+ default
+
if [[ ${PV} == "9999" ]] ; then
./get_submodules.sh
eautoreconf -i
@@ -58,5 +60,5 @@ multilib_src_test () {
multilib_src_install_all() {
einstalldocs
- prune_libtool_files
+ find "${ED}" -type f -name '*.la' -delete
}