summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdrian Schollmeyer <nex+b-g-o@nexadn.de>2022-04-22 14:31:10 +0200
committerJoonas Niilola <juippis@gentoo.org>2022-04-24 10:24:05 +0300
commit6071394425dbb0327b53e6188747249daa2f4786 (patch)
treeeb29986fa6beac47e1967ccb6002eb90f016954d /dev-libs/libstrophe
parentdev-libs/libstrophe: Move doxygen to BDEPEND (diff)
downloadgentoo-6071394425dbb0327b53e6188747249daa2f4786.tar.gz
gentoo-6071394425dbb0327b53e6188747249daa2f4786.tar.bz2
gentoo-6071394425dbb0327b53e6188747249daa2f4786.zip
dev-libs/libstrophe: Fix deletion of *.la files
The previous find call didn't delete *.la files, although they were specified in the find call. This commit fixes this by inserting parentheses. To further make the call robust, this commit also inserts the -type f argument. Signed-off-by: Adrian Schollmeyer <nex+b-g-o@nexadn.de> Closes: https://github.com/gentoo/gentoo/pull/25156 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs/libstrophe')
-rw-r--r--dev-libs/libstrophe/libstrophe-0.10.0.ebuild2
-rw-r--r--dev-libs/libstrophe/libstrophe-0.11.0.ebuild2
2 files changed, 2 insertions, 2 deletions
diff --git a/dev-libs/libstrophe/libstrophe-0.10.0.ebuild b/dev-libs/libstrophe/libstrophe-0.10.0.ebuild
index 65e5bcfda6b4..d3f341dcdf59 100644
--- a/dev-libs/libstrophe/libstrophe-0.10.0.ebuild
+++ b/dev-libs/libstrophe/libstrophe-0.10.0.ebuild
@@ -41,7 +41,7 @@ src_compile() {
src_install() {
default
use doc && dodoc -r examples
- find "${D}" -name '*.la' -o -name '*.a' -delete || die
+ find "${D}" -type f \( -name '*.la' -o -name '*.a' \) -delete || die
}
# Explicit src_test is there to document that the test suite is integrated and
diff --git a/dev-libs/libstrophe/libstrophe-0.11.0.ebuild b/dev-libs/libstrophe/libstrophe-0.11.0.ebuild
index ad3d05309f8b..12a6e1084f43 100644
--- a/dev-libs/libstrophe/libstrophe-0.11.0.ebuild
+++ b/dev-libs/libstrophe/libstrophe-0.11.0.ebuild
@@ -44,7 +44,7 @@ src_compile() {
src_install() {
default
use doc && dodoc -r examples
- find "${D}" -name '*.la' -o -name '*.a' -delete || die
+ find "${D}" -type f \( -name '*.la' -o -name '*.a' \) -delete || die
}
# Explicit src_test is there to document that the test suite is integrated and