summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-03-22 10:23:02 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-03-22 11:06:53 +0100
commit50a6bb2c66ce80aa2843581921639f3ec4248101 (patch)
tree93531691a4a6422f81b3ce6567b49cd79853b19f /dev-ml/ppx_fail/ppx_fail-113.33.00.ebuild
parentdev-ml/ppx_fields_conv: bump to 113.33.00 (diff)
downloadgentoo-50a6bb2c66ce80aa2843581921639f3ec4248101.tar.gz
gentoo-50a6bb2c66ce80aa2843581921639f3ec4248101.tar.bz2
gentoo-50a6bb2c66ce80aa2843581921639f3ec4248101.zip
dev-ml/ppx_fail: bump to 113.33.00
Package-Manager: portage-2.2.28 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml/ppx_fail/ppx_fail-113.33.00.ebuild')
-rw-r--r--dev-ml/ppx_fail/ppx_fail-113.33.00.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-ml/ppx_fail/ppx_fail-113.33.00.ebuild b/dev-ml/ppx_fail/ppx_fail-113.33.00.ebuild
new file mode 100644
index 000000000000..e835771ca617
--- /dev/null
+++ b/dev-ml/ppx_fail/ppx_fail-113.33.00.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit oasis
+
+DESCRIPTION="Add location to calls to failwiths"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-ml/ppx_tools:=
+ dev-ml/ppx_core:=
+ dev-ml/ppx_driver:=
+ dev-ml/ppx_here:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND} dev-ml/opam"
+
+src_configure() {
+ emake setup.exe
+ OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+ dodoc CHANGES.md
+}