summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-06-01 04:29:43 +0100
committerSam James <sam@gentoo.org>2024-06-01 04:29:43 +0100
commit94fd76c7363b8ee27b338ba0b0b2839477dde8a3 (patch)
tree6c68da46df70f40d4a1638facade3db718b7c503 /dev-perl/GD
parentdev-perl/HTTP-Message: add 6.460.0 (diff)
downloadgentoo-94fd76c7363b8ee27b338ba0b0b2839477dde8a3.tar.gz
gentoo-94fd76c7363b8ee27b338ba0b0b2839477dde8a3.tar.bz2
gentoo-94fd76c7363b8ee27b338ba0b0b2839477dde8a3.zip
dev-perl/GD: add 2.820.0
Note that when I rebased respect-libdir.patch, I deliberately added the .pc back in the string as it doesn't configure otherwise. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-perl/GD')
-rw-r--r--dev-perl/GD/GD-2.820.0.ebuild81
-rw-r--r--dev-perl/GD/Manifest1
-rw-r--r--dev-perl/GD/files/GD-2.820.0-respect-libdir.patch37
3 files changed, 119 insertions, 0 deletions
diff --git a/dev-perl/GD/GD-2.820.0.ebuild b/dev-perl/GD/GD-2.820.0.ebuild
new file mode 100644
index 000000000000..bcfda34b9fca
--- /dev/null
+++ b/dev-perl/GD/GD-2.820.0.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=RURBAN
+DIST_VERSION=2.82
+DIST_EXAMPLES=("demos/*")
+inherit perl-module
+
+DESCRIPTION="Interface to Thomas Boutell's gd library"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="animgif fcgi test truetype xpm"
+
+RDEPEND="
+ >=media-libs/gd-2.2.3[png,jpeg]
+ media-libs/giflib
+ media-libs/libjpeg-turbo
+ media-libs/libpng
+ sys-libs/zlib
+ truetype? (
+ media-libs/gd[truetype]
+ media-libs/freetype:2
+ )
+ xpm? (
+ media-libs/gd[xpm]
+ x11-libs/libXpm
+ )
+ fcgi? (
+ dev-libs/fcgi
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${RDEPEND}
+ >=virtual/perl-ExtUtils-Constant-0.230.0
+ dev-perl/ExtUtils-PkgConfig
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=dev-perl/Test-Fork-0.20.0
+ >=virtual/perl-Test-Simple-0.880.0
+ >=dev-perl/Test-NoWarnings-1.0.0
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.820.0-respect-libdir.patch
+)
+
+src_configure() {
+ local myconfargs=(
+ VERSION_33
+ GD_UNCLOSEDPOLY
+ GD_FTCIRCLE
+
+ WINDOWS_BMP
+ JPEG
+ PNG
+ GIF
+ )
+
+ # The following flags do not work properly. This is why we force-enable
+ # at least some of them. See bug 787404 as tracker.
+ use animgif && myconfargs+=( ANIMGIF )
+ use truetype && myconfargs+=( FT )
+ use xpm && myconfargs+=( XPM )
+
+ # Per line 284 of Makefile.PL
+ local myconf="--lib_gd_path ${ESYSROOT}/usr/$(get_libdir) -options '$(printf '%s,' ${myconfargs[@]})'"
+ use fcgi && myconf+=" --fcgi"
+
+ perl-module_src_configure
+}
+
+src_test() {
+ # The 'GD' format itself is long-obsolete and gone in >=media-libs/gd-2.3.3
+ perl_rm_files t/z_*.t t/GD.t
+ perl-module_src_test
+}
diff --git a/dev-perl/GD/Manifest b/dev-perl/GD/Manifest
index 2c17b73f483e..00333a35a2bc 100644
--- a/dev-perl/GD/Manifest
+++ b/dev-perl/GD/Manifest
@@ -1,3 +1,4 @@
DIST GD-2.78.tar.gz 265773 BLAKE2B a05f9e26c2ea7d9a638cdb8fb6675382f5274e295f530587e1e83990ad5238882300052a4eb270f8881f02df30739783c64af8d2d93680e0e0a12570c6d45a61 SHA512 ef3df42c003f105fd1c313ea9e8b8b1e75912b4fdb274e73f2e4f5664a0adb8479a2e62fae5a493e37c36865f9dc37207d2d31e96316eb18a3c5384e07858591
DIST GD-2.79.tar.gz 269331 BLAKE2B 6d640ba19841a7401f3306fde0a71fed8b9e1e6382641a9f902f84b65a96cf3ce297f06f1465a5ee1ed553bfc9213c6871a618109fb48a2f9ab68b9e49769e8d SHA512 c2c1b298b469aa357aaab94a48bbff916e33a36d4d028ad5cb0c9dab8b59f304b261d08121f06512e221598d647d6c09a5360a17bd4378d06cfd3ee53c5fe03b
DIST GD-2.80.tar.gz 285685 BLAKE2B b3b130de1ba9ae14796339d6ed4033abba17db280b0b5ae02cd55d27bf62515999993d519ca32789e9cbc142e67256efef110139a79d472095b1d137c2d57941 SHA512 d973464d97b7472bb1e22cd03d644b8c5d0d83ac3076c9b10890666942e469e1dfc62ee6a01ff0cd49b13e7df9ad6ed2a16bbba36c1acacf94b3363194824177
+DIST GD-2.82.tar.gz 283831 BLAKE2B 9314a17d949f6b98f370c754fb7ae2346589b8aa2413513b6697dcb0ba7bc13465ba18d40604a129da502c189df4b7651e6d974545b05a943c7e3689c0e36986 SHA512 4aca1de74855e79d35cdffa167bba7f50cfc017ee855953bcda1d896d1e9da5976eae8fe3ab6ac2c682597b4a8424f100afc4a67aee2cdc6f88a19ff261551e8
diff --git a/dev-perl/GD/files/GD-2.820.0-respect-libdir.patch b/dev-perl/GD/files/GD-2.820.0-respect-libdir.patch
new file mode 100644
index 000000000000..25070e9edb9c
--- /dev/null
+++ b/dev-perl/GD/files/GD-2.820.0-respect-libdir.patch
@@ -0,0 +1,37 @@
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -66,12 +66,6 @@ END
+
+ @LIBS = qw(-lgd) unless @LIBS;
+
+-# support for AMD64 libraries
+-if (-d '/usr/lib64') {
+- my @libs64 = map {my $a = $_; $a=~ s/lib$/lib64/; $a} @LIBPATH;
+- @LIBPATH = (@LIBPATH,@libs64);
+-}
+-
+ #############################################################################################
+ # Build options passed in to script to support reproducible builds via Makefiles
+ #############################################################################################
+@@ -229,12 +223,6 @@ if( ! defined($lib_gd_path) )
+ $PREFIX = prompt('Where is libgd installed?',$default_lib_gd_path);
+ }
+
+-unless ($AUTOCONFIG || $PREFIX eq $default_lib_gd_path) {
+- $PREFIX =~ s!/lib$!!;
+- unshift @INC,"-I$PREFIX/include";
+- unshift @LIBPATH,"-L$PREFIX/lib";
+-}
+-
+ # FEATURE FLAGS
+
+ ##################################################################################################################
+@@ -564,7 +552,7 @@ sub try_to_autoconfigure {
+ unless ($config) {
+ my %config;
+ require ExtUtils::PkgConfig;
+- %config = ExtUtils::PkgConfig->find ("$prefix/lib/pkgconfig/gdlib") if $prefix;
++ %config = ExtUtils::PkgConfig->find ("$lib_gd_path/pkgconfig/gdlib.pc") if $prefix;
+ %config = ExtUtils::PkgConfig->find ("gdlib") unless %config;
+ return unless %config;
+ $version = $config{modversion};