summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-06-13 16:34:07 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-06-13 16:50:02 +0200
commitaa29d3f0e9c83920c2775ff4f572002f827e746e (patch)
treefed285d1b0f8f0293dc0bab42131abd06404e791 /dev-perl/HTML-Mason
parentsys-apps/hwids: add 20210613 (diff)
downloadgentoo-aa29d3f0e9c83920c2775ff4f572002f827e746e.tar.gz
gentoo-aa29d3f0e9c83920c2775ff4f572002f827e746e.tar.bz2
gentoo-aa29d3f0e9c83920c2775ff4f572002f827e746e.zip
dev-perl/HTML-Mason: Version bump 1.59
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/HTML-Mason')
-rw-r--r--dev-perl/HTML-Mason/HTML-Mason-1.590.0.ebuild65
-rw-r--r--dev-perl/HTML-Mason/Manifest1
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-perl/HTML-Mason/HTML-Mason-1.590.0.ebuild b/dev-perl/HTML-Mason/HTML-Mason-1.590.0.ebuild
new file mode 100644
index 000000000000..ffd6451eccea
--- /dev/null
+++ b/dev-perl/HTML-Mason/HTML-Mason-1.590.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=DROLSKY
+DIST_VERSION=1.59
+inherit depend.apache perl-module
+
+DESCRIPTION="A HTML development and delivery Perl Module"
+HOMEPAGE="http://www.masonhq.com/ https://metacpan.org/release/HTML-Mason"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="modperl test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ !modperl? ( >=dev-perl/CGI-2.460.0 )
+ modperl? (
+ www-apache/libapreq2
+ >=www-apache/mod_perl-2
+ )
+ >=dev-perl/Cache-Cache-1
+ >=dev-perl/Class-Container-0.70.0
+ >=dev-perl/Exception-Class-1.150.0
+ virtual/perl-File-Spec
+ dev-perl/HTML-Parser
+ >=dev-perl/Log-Any-0.80.0
+ >=dev-perl/Params-Validate-0.70.0
+ virtual/perl-Scalar-List-Utils
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=virtual/perl-Test-Simple-0.880.0
+ dev-perl/Test-Deep
+ )
+"
+
+want_apache2 modperl
+
+mydoc="CREDITS UPGRADE"
+myconf="--noprompts"
+
+pkg_setup() {
+ depend.apache_pkg_setup modperl
+ perl_set_version
+}
+
+src_prepare() {
+ # Note about new modperl use flag
+ if use !modperl ; then
+ ewarn "HTML-Mason will only install with modperl support"
+ ewarn "if the use flag modperl is enabled."
+ fi
+ # rendhalver - needed to set an env var for the build script so it finds our apache.
+ export APACHE="${APACHE_BIN}"
+ perl-module_src_prepare
+}
+
+src_install() {
+ perl-module_src_install
+ mv "${ED}"/usr/bin/convert* "${ED}"/usr/share/doc/${PF} || die
+}
diff --git a/dev-perl/HTML-Mason/Manifest b/dev-perl/HTML-Mason/Manifest
index 4c3faf777d05..b8b8314a0a93 100644
--- a/dev-perl/HTML-Mason/Manifest
+++ b/dev-perl/HTML-Mason/Manifest
@@ -1 +1,2 @@
DIST HTML-Mason-1.56.tar.gz 314167 BLAKE2B 7e449bc566f406f2f6c93459f573327be933bbf50eeb1c712e9d109133448cdf568cfbefbdd28fa403d9ed340334afb5c9d1dd5a1800c624b23634cd54949520 SHA512 3492a37b8289209a2215b42be71db242ca150f4364d8422e46ca4762f2cdbddf96a56f44a3462d1f1eb23ef3bbe1cb36b8322106f4050404b988c6d90a05911c
+DIST HTML-Mason-1.59.tar.gz 323661 BLAKE2B e9061cf4349874572c912faa04e849cdba15b7219f33488af3555f58ee0d9b77e851cf20ecddfcb55ebb6ec1e3525dea986fdd444b6445a8f39b8508cd261b68 SHA512 3a8053d976345c7bd1d04aab659e3b4dd541264ece806e6d3bda605b6ecb16887ecce9a310bf27890aab40a129c81ba2dbad60c2edd80681a53d159becb3eda1