summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-10 18:44:01 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-10 19:01:03 +0200
commitbb501f3a25a84c87ea0ba0f2d18c18648a1d304a (patch)
tree2cfc81f210028b324f7af3384183d72311af6e45 /dev-python/aiohttp-oauthlib
parentdev-python/oauthlib: Enable py3.13 (diff)
downloadgentoo-bb501f3a25a84c87ea0ba0f2d18c18648a1d304a.tar.gz
gentoo-bb501f3a25a84c87ea0ba0f2d18c18648a1d304a.tar.bz2
gentoo-bb501f3a25a84c87ea0ba0f2d18c18648a1d304a.zip
dev-python/aiohttp-oauthlib: Enable py3.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/aiohttp-oauthlib')
-rw-r--r--dev-python/aiohttp-oauthlib/aiohttp-oauthlib-0.1.0.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/dev-python/aiohttp-oauthlib/aiohttp-oauthlib-0.1.0.ebuild b/dev-python/aiohttp-oauthlib/aiohttp-oauthlib-0.1.0.ebuild
index 5b22550be9b5..e8bfd1e7f9b5 100644
--- a/dev-python/aiohttp-oauthlib/aiohttp-oauthlib-0.1.0.ebuild
+++ b/dev-python/aiohttp-oauthlib/aiohttp-oauthlib-0.1.0.ebuild
@@ -1,17 +1,17 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+PYTHON_COMPAT=( python3_{10..13} )
inherit distutils-r1
DESCRIPTION="This project provides first-class OAuth library support for aiohttp"
HOMEPAGE="https://git.sr.ht/~whynothugo/aiohttp-oauthlib"
SRC_URI="https://git.sr.ht/~whynothugo/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-v${PV}"
SLOT="0"
LICENSE="ISC"
@@ -21,6 +21,8 @@ RDEPEND="
dev-python/aiohttp[${PYTHON_USEDEP}]
>=dev-python/oauthlib-3.0.0[${PYTHON_USEDEP}]"
-BDEPEND="dev-python/setuptools-scm[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
-S="${WORKDIR}/${PN}-v${PV}"
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}