summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-25 07:39:49 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-25 09:12:32 +0200
commitc1b980acc12f3de2ecbf83ca7be23befe5ab8a60 (patch)
treeb26a8843de7b500c181fa32cb80f31e3756c3a93 /dev-python/asteval
parentdev-python/pytest-httpx: Bump to 0.21.0 (diff)
downloadgentoo-c1b980acc12f3de2ecbf83ca7be23befe5ab8a60.tar.gz
gentoo-c1b980acc12f3de2ecbf83ca7be23befe5ab8a60.tar.bz2
gentoo-c1b980acc12f3de2ecbf83ca7be23befe5ab8a60.zip
dev-python/asteval: Bump to 0.9.27
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/asteval')
-rw-r--r--dev-python/asteval/Manifest1
-rw-r--r--dev-python/asteval/asteval-0.9.27.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/asteval/Manifest b/dev-python/asteval/Manifest
index d42f979739cf..42771819f75f 100644
--- a/dev-python/asteval/Manifest
+++ b/dev-python/asteval/Manifest
@@ -1 +1,2 @@
DIST asteval-0.9.26.tar.gz 40113 BLAKE2B 9d63b78c500e521ea2740a3068087c42fdb00913c1e110d71fba3dbc9187bd02169a095d08db16c6b2b10d7e066a0e0578ff81d220d0cadcf994bb75790ff450 SHA512 8d568edb018416ff40d09d9dd123ccf595426d84e1f1554a22a19dae045703494fabacf1e15a2778c3ed042b1ad2f3b318fd37a20a15c50301e651d657902e57
+DIST asteval-0.9.27.tar.gz 41789 BLAKE2B 6db628dfc90479b605370e6cd4c3eb27a6fdabd2422016aab200ddb217fc5459df77ae99397145511600ae4a79e259c9e7c75c3be50bf5201e08915a76ca5571 SHA512 b56fb81f1055ab66868084edb89775ec87f40ee45563531bf4661ee65656e777b388856e691740af60b4a3891e872683768ac590a78fda2fed9173e613aa7263
diff --git a/dev-python/asteval/asteval-0.9.27.ebuild b/dev-python/asteval/asteval-0.9.27.ebuild
new file mode 100644
index 000000000000..d0a6c8b9f423
--- /dev/null
+++ b/dev-python/asteval/asteval-0.9.27.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Evaluator of Python expression using ast module"
+HOMEPAGE="
+ https://newville.github.io/asteval/
+ https://github.com/newville/asteval/
+ https://pypi.org/project/asteval/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -o addopts=
+}