summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-08 08:07:42 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-08 09:30:01 +0200
commit3b4e76fc0bdac69242acc47ff2676d440677fafc (patch)
tree76da5101636df7a949038b7ade372b291dd5a876 /dev-python/async-lru
parentdev-perl/DateTime-HiRes: Keyword 0.40.0 ppc64, #909852 (diff)
downloadgentoo-3b4e76fc0bdac69242acc47ff2676d440677fafc.tar.gz
gentoo-3b4e76fc0bdac69242acc47ff2676d440677fafc.tar.bz2
gentoo-3b4e76fc0bdac69242acc47ff2676d440677fafc.zip
dev-python/async-lru: Bump to 2.0.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/async-lru')
-rw-r--r--dev-python/async-lru/Manifest1
-rw-r--r--dev-python/async-lru/async-lru-2.0.3.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/async-lru/Manifest b/dev-python/async-lru/Manifest
index 3c984ce3739c..644ed242d9eb 100644
--- a/dev-python/async-lru/Manifest
+++ b/dev-python/async-lru/Manifest
@@ -1 +1,2 @@
DIST async-lru-2.0.2.gh.tar.gz 11040 BLAKE2B dc1dfb12189cdcf8283b77d2b451031e691b1fd833e34df450ce87fd496b57d5a04a7f6ca183bb07d7e820f68cafade44237e626e3694d732df40dbf38f22baf SHA512 ce1f9f241200dd05d44196f06e688c2852fbe1bb2356f5611dbc9ac8109e1313ecdcccbba70944e936aa6bc59864d9cc339daaa58416ec0850f3b2afd17123d3
+DIST async-lru-2.0.3.gh.tar.gz 12592 BLAKE2B 3b434ebcb5f4db754ca93dae3e597490b07ce6d84d573529343a540b77fc9116f329f641fb97639dce6903384e52433dc48aabb7927266e8bcc18ce9fbaa85ac SHA512 8a3685bccb09ae268a713b3796f1f945bc9f9beff14530eb997722c6a0546bb39860492eadc1a46fca6ed549352e20cd9983396127ee9edfbd50657b5e5dd58f
diff --git a/dev-python/async-lru/async-lru-2.0.3.ebuild b/dev-python/async-lru/async-lru-2.0.3.ebuild
new file mode 100644
index 000000000000..ad3398fd3cb0
--- /dev/null
+++ b/dev-python/async-lru/async-lru-2.0.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple lru_cache for asyncio"
+HOMEPAGE="
+ https://github.com/aio-libs/async-lru/
+ https://pypi.org/project/async-lru/
+"
+SRC_URI="
+ https://github.com/aio-libs/async-lru/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-4.0.0[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e 's:--cache-clear::' \
+ -e 's:--no-cov-on-fail --cov=async_lru --cov-report=term --cov-report=html::' \
+ -i setup.cfg || die
+
+ distutils-r1_src_prepare
+}