summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-16 08:42:58 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-16 08:53:05 +0200
commit42c1fed722cdf14caa242d907c967254eea580a6 (patch)
tree4ad89ca41c21119b1f1db61e2e1ac458fab44b01 /dev-python/autoprop
parentdev-python/signature_dispatch: Bump to 1.0.0 (diff)
downloadgentoo-42c1fed722cdf14caa242d907c967254eea580a6.tar.gz
gentoo-42c1fed722cdf14caa242d907c967254eea580a6.tar.bz2
gentoo-42c1fed722cdf14caa242d907c967254eea580a6.zip
dev-python/autoprop: Bump to 4.0.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/autoprop')
-rw-r--r--dev-python/autoprop/Manifest1
-rw-r--r--dev-python/autoprop/autoprop-4.0.2.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/autoprop/Manifest b/dev-python/autoprop/Manifest
index 722879edebe9..a44822ff5205 100644
--- a/dev-python/autoprop/Manifest
+++ b/dev-python/autoprop/Manifest
@@ -1,2 +1,3 @@
DIST autoprop-3.0.0.tar.gz 14082 BLAKE2B 9881dd924b8d66e83dccb3e7ca1d753bec924e8f348d96d0522a76e857c85311ef7ada37b0080c1b3a0e719bf84e807d12c7e4dff4bbfc111273b340f92244a5 SHA512 4730155130b98fc02bea991837ee6d875f19ffa14ae542909314264950d20a34cdbff9e21b31431136624de0dac5eb2a50a9cf677da01862b38cae9c10bec92f
DIST autoprop-4.0.1.tar.gz 19998 BLAKE2B aefff2e8f1d583c45e77a2b0530a07e03be9229977f9f1229cfd832f609d2f31d4cd05ad741189ceb7a01d846e286c85158439952e587dd007526794c6b9a993 SHA512 d77caec360f59f247cd23a1636771808bdcbaa6ba96241cafeabc144e88975b607b604800d2d374c5b6f80b68bf631ab74278c19fe1544112a6c6813190c744f
+DIST autoprop-4.0.2.tar.gz 20050 BLAKE2B 06165a02dfee0755ccf375041487f015e632b56b24766ac3d4bd484caaf1c99a0506994f16ace753f5890b782690b640196ee0cd6fcce0078ef51f8addcfcfe6 SHA512 27c8578e8f023715b07ebe21f4f46e98e606c863d3257bb1c8c31d9f59551d2494ef99e24eed856b308c8c77e1a3276f9e370434aa3e61ebb0b32a9b44fceee7
diff --git a/dev-python/autoprop/autoprop-4.0.2.ebuild b/dev-python/autoprop/autoprop-4.0.2.ebuild
new file mode 100644
index 000000000000..9d5ce4a8be8a
--- /dev/null
+++ b/dev-python/autoprop/autoprop-4.0.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Infer properties from accessor methods"
+HOMEPAGE="
+ https://github.com/kalekundert/autoprop/
+ https://pypi.org/project/autoprop/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/signature_dispatch-1.0.0[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest