summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-08-09 10:12:23 +0200
committerMichał Górny <mgorny@gentoo.org>2022-08-09 10:14:03 +0200
commita9fa4d1183353673adbdf0135364e8122b7b84cf (patch)
treec9d7519f83502720b63dac438c1ff320f8b837f6 /dev-python/dask
parentdev-python/flit_scm: Remove old (diff)
downloadgentoo-a9fa4d1183353673adbdf0135364e8122b7b84cf.tar.gz
gentoo-a9fa4d1183353673adbdf0135364e8122b7b84cf.tar.bz2
gentoo-a9fa4d1183353673adbdf0135364e8122b7b84cf.zip
dev-python/dask: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/dask')
-rw-r--r--dev-python/dask/Manifest1
-rw-r--r--dev-python/dask/dask-2022.6.1.ebuild58
2 files changed, 0 insertions, 59 deletions
diff --git a/dev-python/dask/Manifest b/dev-python/dask/Manifest
index b791f71a0a25..8534fa40e1a6 100644
--- a/dev-python/dask/Manifest
+++ b/dev-python/dask/Manifest
@@ -1,4 +1,3 @@
-DIST dask-2022.6.1.gh.tar.gz 8729249 BLAKE2B 211beeb3960569aa1cb68a4fd9b261a417297de5dc406d50bc54342239227ea01e2158b618bd889862a7eff8bb01bb43d098937bb3911f088250957caa672d04 SHA512 6e06b63dd5c7f1d7c6c7dce867ffa42b956023b313b25245a339f698b06bea17a03cc4ead9bd5aef8ddf081750cad4df4b6b2972038315c89585221382c9e95c
DIST dask-2022.7.0.gh.tar.gz 8748843 BLAKE2B ae0e63c883e6542aefd29a619168b1e86e9b20d43e7966ecb8a92a90b72952acd7e08ce53fdbc146b47bcb7f65190f2d0cbe19966c52f94b0d52eb63e53778d9 SHA512 11fe292134dac14e30068b98d88e622af2941b7fffa2c667b39b87e4d28ac6388001e18a8628bd22bbd48a2a10ee707dc25618a960a401e40cb73b2231fd2dfc
DIST dask-2022.7.1.gh.tar.gz 8749841 BLAKE2B 9c4db1adbfd9ea796db10855f98b972104415e66d5d01800e139d9475ceaedb850867a47d8af8e538856bcf21f805d6f24146a8407968e96c0084f81ce5e323d SHA512 459c20cdb8da523020483212cc48fdf0830915ce6cbd48511ccb02e3a1a5c4c8e1ce9bafb09e1288ec7f89d9dc8da36cd7fe75da1441cb3e5b31521720fd0708
DIST dask-2022.8.0.gh.tar.gz 8751904 BLAKE2B 057cbb0f50684413b6eaaf9b25b1be5556d62ccb81258427c8504c861d156b49ec83957199758d6794406c06b1bc6d7724163ca975e5970ddd05505789392738 SHA512 dc455596500cfdcd38a71e256606cea4d41f96dd947b8fcf652cc0f8fff51145bfdd19eae8697472b6f5bb050c0525e422de53bf9e8c549310b1f26931491052
diff --git a/dev-python/dask/dask-2022.6.1.ebuild b/dev-python/dask/dask-2022.6.1.ebuild
deleted file mode 100644
index 710040987184..000000000000
--- a/dev-python/dask/dask-2022.6.1.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Task scheduling and blocked algorithms for parallel processing"
-HOMEPAGE="
- https://www.dask.org/
- https://github.com/dask/dask/
- https://pypi.org/project/dask/
-"
-SRC_URI="
- https://github.com/dask/dask/archive/${PV}.tar.gz -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- >=dev-python/cloudpickle-0.2.2[${PYTHON_USEDEP}]
- >=dev-python/fsspec-0.6.0[${PYTHON_USEDEP}]
- >=dev-python/numpy-1.15.1[${PYTHON_USEDEP}]
- >=dev-python/pandas-0.25.0[${PYTHON_USEDEP}]
- >=dev-python/packaging-20.0[${PYTHON_USEDEP}]
- >=dev-python/partd-0.3.10[${PYTHON_USEDEP}]
- dev-python/psutil[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP}]
- >=dev-python/toolz-0.8.2[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/toolz[${PYTHON_USEDEP}]
- test? (
- dev-python/moto[${PYTHON_USEDEP}]
- dev-python/numexpr[${PYTHON_USEDEP}]
- dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # another test relying on -Werror
- "dask/array/tests/test_overlap.py::test_map_overlap_no_depth[None]"
- # TODO
- dask/array/tests/test_reductions.py::test_mean_func_does_not_warn
- dask/tests/test_config.py::test__get_paths
-)
-
-python_test() {
- epytest -p no:flaky -m "not network"
-}