summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-16 12:11:25 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-16 12:11:25 +0200
commitd92463b47554acf0dfdda8e75cccd0c9ce450c89 (patch)
treee2ce803a1ce0069e3a8f5eee94689083d9503650 /dev-python/debugpy
parentdev-python/botocore: Remove old (diff)
downloadgentoo-d92463b47554acf0dfdda8e75cccd0c9ce450c89.tar.gz
gentoo-d92463b47554acf0dfdda8e75cccd0c9ce450c89.tar.bz2
gentoo-d92463b47554acf0dfdda8e75cccd0c9ce450c89.zip
dev-python/debugpy: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/debugpy')
-rw-r--r--dev-python/debugpy/Manifest2
-rw-r--r--dev-python/debugpy/debugpy-1.5.1.ebuild42
-rw-r--r--dev-python/debugpy/debugpy-1.6.1.ebuild43
-rw-r--r--dev-python/debugpy/files/debugpy-1.4.2-unbundle-pydevd.patch78
4 files changed, 0 insertions, 165 deletions
diff --git a/dev-python/debugpy/Manifest b/dev-python/debugpy/Manifest
index 87a753125cef..6cbfc4561c41 100644
--- a/dev-python/debugpy/Manifest
+++ b/dev-python/debugpy/Manifest
@@ -1,4 +1,2 @@
-DIST debugpy-1.5.1.gh.tar.gz 6675322 BLAKE2B a8e3a07d5dbd1b5ca39301e703b279514653606f98743a396693738c9a89403c73a6b6942e5dc368dd89eb8b74277e1808f9247573f330e3a94596c26af7e5be SHA512 93ee526ca7cb3d44b85106a33d8f930f4f2b307eb26ede3ab6b5653de986a101b10f545f5de12cd8ee6ff9e9a12c5e4b57c4c40b1b3003c2f555676bd34482ce
DIST debugpy-1.6.0.gh.tar.gz 6366079 BLAKE2B 134d2adcae6ec926dcdb7161f0874b830a1d0e3c55abb991f4861fa5a58045437ee4f4cb4c9572b902e3e33634bc3f9970ae055985b983d89d0ef1d99561bda8 SHA512 fe245d4ff751a6c2ef0e75a5249f99661b78075ac62c931c20e3ccbc9389d39a08dc2fda44a33eb23a0a76e5ee339edae439b0004d130cdfe421048f3cc83962
-DIST debugpy-1.6.1.gh.tar.gz 6684941 BLAKE2B 113ad9670cb9c80a28670be22265e110e5857d7093438db6ea531719de012a66c53ed9914c859c17f3bb5e03b88b11317173d261c9327e5434b5105396fac057 SHA512 28619e8e07265a8d983eccde28cc693b96ca5b94674ab0d512775a9c261f54baaa72e7bb8632b49b3715c2eb3626997cb967b5edb1b53672c6777493f0a46e50
DIST debugpy-1.6.2.gh.tar.gz 6684477 BLAKE2B ab1bdf394d3447ba347db149e5c4c36820df6df24c5d0984fe862419a490cea21b240322d76644bc9ebadbdf9a6d6c8709ae28452828d42b45d65edd2d2e58cb SHA512 64ecd9f8290588358abcff538f2c68025f14efc38ac5b406f32cd40a580aab90e0b2f145de90ca81943872c70969d6294ac51b3151bc4e03f18370ddfbb9ac6c
diff --git a/dev-python/debugpy/debugpy-1.5.1.ebuild b/dev-python/debugpy/debugpy-1.5.1.ebuild
deleted file mode 100644
index ab764a291aae..000000000000
--- a/dev-python/debugpy/debugpy-1.5.1.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..11} )
-inherit distutils-r1
-
-DESCRIPTION="An implementation of the Debug Adapter Protocol for Python"
-HOMEPAGE="https://github.com/microsoft/debugpy/ https://pypi.org/project/debugpy/"
-SRC_URI="
- https://github.com/microsoft/${PN}/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ppc ppc64 ~riscv ~s390 sparc x86"
-
-# There is not enough time in the universe for this test suite
-RESTRICT="test"
-
-RDEPEND="dev-python/pydevd[${PYTHON_USEDEP}]"
-BDEPEND="test? ( dev-python/pytest-timeout[${PYTHON_USEDEP}] )"
-
-PATCHES=(
- "${FILESDIR}/${PN}-1.4.2-unbundle-pydevd.patch"
-)
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # Drop unnecessary and unrecognized option
- # __main__.py: error: unrecognized arguments: -n8
- # Do not timeout
- sed -e '/addopts/d' -e '/timeout/d' -i pytest.ini || die
-
- # Unbundle dev-python/pydevd
- rm -r src/debugpy/_vendored || die
-
- distutils-r1_python_prepare_all
-}
diff --git a/dev-python/debugpy/debugpy-1.6.1.ebuild b/dev-python/debugpy/debugpy-1.6.1.ebuild
deleted file mode 100644
index 87982f97e4bb..000000000000
--- a/dev-python/debugpy/debugpy-1.6.1.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..11} )
-DISTUTILS_USE_PEP517=setuptools
-inherit distutils-r1
-
-DESCRIPTION="An implementation of the Debug Adapter Protocol for Python"
-HOMEPAGE="https://github.com/microsoft/debugpy/ https://pypi.org/project/debugpy/"
-SRC_URI="
- https://github.com/microsoft/${PN}/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-
-# This is completely broken
-RESTRICT="test"
-
-RDEPEND="dev-python/pydevd[${PYTHON_USEDEP}]"
-BDEPEND="test? ( dev-python/pytest-timeout[${PYTHON_USEDEP}] )"
-
-PATCHES=(
- "${FILESDIR}/${PN}-1.6.1-unbundle-pydevd.patch"
-)
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # Drop unnecessary and unrecognized option
- # __main__.py: error: unrecognized arguments: -n8
- # Do not timeout
- sed -e '/addopts/d' -e '/timeout/d' -i pytest.ini || die
-
- # Unbundle dev-python/pydevd
- rm -r src/debugpy/_vendored tests/tests/test_vendoring.py || die
-
- distutils-r1_python_prepare_all
-}
diff --git a/dev-python/debugpy/files/debugpy-1.4.2-unbundle-pydevd.patch b/dev-python/debugpy/files/debugpy-1.4.2-unbundle-pydevd.patch
deleted file mode 100644
index 3d60bcd18cbc..000000000000
--- a/dev-python/debugpy/files/debugpy-1.4.2-unbundle-pydevd.patch
+++ /dev/null
@@ -1,78 +0,0 @@
-diff --git a/setup.py b/setup.py
-index ee5bbba..f69dc95 100644
---- a/setup.py
-+++ b/setup.py
-@@ -21,12 +21,10 @@ del sys.path[0]
-
- sys.path.insert(0, os.path.join(os.path.dirname(os.path.abspath(__file__)), "src"))
- import debugpy
--import debugpy._vendored
-
- del sys.path[0]
-
-
--PYDEVD_ROOT = debugpy._vendored.project_root("pydevd")
- DEBUGBY_ROOT = os.path.dirname(os.path.abspath(debugpy.__file__))
-
-
-@@ -36,27 +34,6 @@ def get_buildplatform():
- return None
-
-
--def cython_build():
-- print("Compiling extension modules (set SKIP_CYTHON_BUILD=1 to omit)")
-- subprocess.call(
-- [
-- sys.executable,
-- os.path.join(PYDEVD_ROOT, "setup_cython.py"),
-- "build_ext",
-- "-i",
-- ]
-- )
--
--
--def iter_vendored_files():
-- # Add pydevd files as data files for this package. They are not
-- # treated as a package of their own, because we don't actually
-- # want to provide pydevd - just use our own copy internally.
-- for project in debugpy._vendored.list_all():
-- for filename in debugpy._vendored.iter_packaging_files(project):
-- yield filename
--
--
- # bdist_wheel determines whether the package is pure or not based on ext_modules.
- # However, all pydevd native modules are prebuilt and packaged as data, so they
- # should not be in the list.
-@@ -121,8 +98,6 @@ with open("DESCRIPTION.md", "r") as fh:
-
-
- if __name__ == "__main__":
-- if not os.getenv("SKIP_CYTHON_BUILD"):
-- cython_build()
-
- extras = {}
- platforms = get_buildplatform()
-@@ -165,11 +140,9 @@ if __name__ == "__main__":
- "debugpy.common",
- "debugpy.launcher",
- "debugpy.server",
-- "debugpy._vendored",
- ],
- package_data={
- "debugpy": ["ThirdPartyNotices.txt"],
-- "debugpy._vendored": list(iter_vendored_files()),
- },
- ext_modules=ExtModules(),
- has_ext_modules=lambda: True,
-diff --git a/src/debugpy/server/__init__.py b/src/debugpy/server/__init__.py
-index e6a1ad6..a79a86b 100644
---- a/src/debugpy/server/__init__.py
-+++ b/src/debugpy/server/__init__.py
-@@ -3,7 +3,3 @@
- # for license information.
-
- from __future__ import absolute_import, division, print_function, unicode_literals
--
--# "force_pydevd" must be imported first to ensure (via side effects)
--# that the debugpy-vendored copy of pydevd gets used.
--import debugpy._vendored.force_pydevd # noqa