summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-09 09:57:30 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-09 11:20:42 +0100
commit131298d98e3f171f361db3472450bfc4e5ababa8 (patch)
treefa104e036d8880081b6b0c49ec7dcb596d8aa66f /dev-python/django-configurations
parentdev-python/colorlog: Bump to 6.6.0 (diff)
downloadgentoo-131298d98e3f171f361db3472450bfc4e5ababa8.tar.gz
gentoo-131298d98e3f171f361db3472450bfc4e5ababa8.tar.bz2
gentoo-131298d98e3f171f361db3472450bfc4e5ababa8.zip
dev-python/django-configurations: Bump to 2.3.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django-configurations')
-rw-r--r--dev-python/django-configurations/Manifest1
-rw-r--r--dev-python/django-configurations/django-configurations-2.3.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/django-configurations/Manifest b/dev-python/django-configurations/Manifest
index e9b3be6f1642..5d7934e86610 100644
--- a/dev-python/django-configurations/Manifest
+++ b/dev-python/django-configurations/Manifest
@@ -1 +1,2 @@
DIST django-configurations-2.2.gh.tar.gz 41909 BLAKE2B 4107e37a694d4c9670f855886d870c7aea30e9b95788a6c09f6fb3c913d3ffc4d17ed250264ce9ff0408856787b4768cda67eecf26c135ccb338ffda7530fd41 SHA512 9c53811016c20ae4dedbb9e1951b45440b656fad2fb9544e94bbbabb65a5883846ee063647f107ac57c08e54db71206b89903ee1d02cbfc0c8d3dafe7520e5a2
+DIST django-configurations-2.3.1.gh.tar.gz 38288 BLAKE2B f9d4322ad3e1fe839c6cc9d3e8eee31d0f3bbd48859f8e49b5fa72a3984517b77248278c42b4a709f1a5965cff3af336c5fea7323004b41fcc15a4ee40175524 SHA512 0d3df709fe306fba1e85d03e5ce16c954a796327d857717e3e802fc717d94f7aa5255a8422e27991faaade31c29bc90e3e05923609e68893784996ca87ca93ed
diff --git a/dev-python/django-configurations/django-configurations-2.3.1.ebuild b/dev-python/django-configurations/django-configurations-2.3.1.ebuild
new file mode 100644
index 000000000000..7363d23fc599
--- /dev/null
+++ b/dev-python/django-configurations/django-configurations-2.3.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A helper for organizing Django settings"
+HOMEPAGE="
+ https://pypi.org/project/django-configurations/
+ https://github.com/jazzband/django-configurations/
+ https://django-configurations.readthedocs.io/"
+SRC_URI="
+ https://github.com/jazzband/django-configurations/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/django[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/django-cache-url[${PYTHON_USEDEP}]
+ dev-python/dj-database-url[${PYTHON_USEDEP}]
+ dev-python/dj-email-url[${PYTHON_USEDEP}]
+ dev-python/dj-search-url[${PYTHON_USEDEP}]
+ )"
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ local -x DJANGO_SETTINGS_MODULE=tests.settings.main
+ local -x DJANGO_CONFIGURATION=Test
+ distutils_install_for_testing
+ django-cadmin test -v2 || die "Tests failed with ${EPYTHON}"
+}