summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-26 07:42:19 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-26 08:33:04 +0100
commit5694a10268299f3dc8650765bb18e41cd33ff89e (patch)
tree15364f1ffee13a05d0c2eecf105084da5a1d04e1 /dev-python/django-configurations
parentdev-python/reportlab: Bump to 3.6.6 (diff)
downloadgentoo-5694a10268299f3dc8650765bb18e41cd33ff89e.tar.gz
gentoo-5694a10268299f3dc8650765bb18e41cd33ff89e.tar.bz2
gentoo-5694a10268299f3dc8650765bb18e41cd33ff89e.zip
dev-python/django-configurations: Bump to 2.3.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django-configurations')
-rw-r--r--dev-python/django-configurations/Manifest1
-rw-r--r--dev-python/django-configurations/django-configurations-2.3.2.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/django-configurations/Manifest b/dev-python/django-configurations/Manifest
index 4e275e7399c6..215dbd35ab05 100644
--- a/dev-python/django-configurations/Manifest
+++ b/dev-python/django-configurations/Manifest
@@ -1 +1,2 @@
DIST django-configurations-2.3.1.gh.tar.gz 38288 BLAKE2B f9d4322ad3e1fe839c6cc9d3e8eee31d0f3bbd48859f8e49b5fa72a3984517b77248278c42b4a709f1a5965cff3af336c5fea7323004b41fcc15a4ee40175524 SHA512 0d3df709fe306fba1e85d03e5ce16c954a796327d857717e3e802fc717d94f7aa5255a8422e27991faaade31c29bc90e3e05923609e68893784996ca87ca93ed
+DIST django-configurations-2.3.2.gh.tar.gz 38475 BLAKE2B 2b3c583e665a08a46bc0ca0c52ae4326fbdfb794d102deecbd13f953e8b6f3fd39b3b747c591fc9717c6a0792258cdb9041de53e71db2034de1a31ddf5bfc0ea SHA512 4cb5a7b284a0025ba93b32e158fb65b57e66230938181b921a1b1264848113b697eb45ac6ad2fc4f26f3bc29ea5f77acbfd5307b20ef2d385e29c2c1746295b3
diff --git a/dev-python/django-configurations/django-configurations-2.3.2.ebuild b/dev-python/django-configurations/django-configurations-2.3.2.ebuild
new file mode 100644
index 000000000000..f79518670b82
--- /dev/null
+++ b/dev-python/django-configurations/django-configurations-2.3.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A helper for organizing Django settings"
+HOMEPAGE="
+ https://pypi.org/project/django-configurations/
+ https://github.com/jazzband/django-configurations/
+ https://django-configurations.readthedocs.io/"
+SRC_URI="
+ https://github.com/jazzband/django-configurations/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/django[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/django-cache-url[${PYTHON_USEDEP}]
+ dev-python/dj-database-url[${PYTHON_USEDEP}]
+ dev-python/dj-email-url[${PYTHON_USEDEP}]
+ dev-python/dj-search-url[${PYTHON_USEDEP}]
+ )"
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ local -x DJANGO_SETTINGS_MODULE=tests.settings.main
+ local -x DJANGO_CONFIGURATION=Test
+ PYTHONPATH=. django-cadmin test -v2 || die "Tests failed with ${EPYTHON}"
+}