summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-20 06:12:35 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-20 06:22:31 +0200
commit34c97badfc22848bd420c0c317c7be15f9df01c8 (patch)
tree203561affcb2a0f86bb79182d0fd95c624ecedeb /dev-python/fasteners
parentdev-python/absl-py: Bump to 2.0.0 (diff)
downloadgentoo-34c97badfc22848bd420c0c317c7be15f9df01c8.tar.gz
gentoo-34c97badfc22848bd420c0c317c7be15f9df01c8.tar.bz2
gentoo-34c97badfc22848bd420c0c317c7be15f9df01c8.zip
dev-python/fasteners: Bump to 0.19
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fasteners')
-rw-r--r--dev-python/fasteners/Manifest1
-rw-r--r--dev-python/fasteners/fasteners-0.19.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/fasteners/Manifest b/dev-python/fasteners/Manifest
index fe2726585f7b..f00f6de966c0 100644
--- a/dev-python/fasteners/Manifest
+++ b/dev-python/fasteners/Manifest
@@ -1 +1,2 @@
DIST fasteners-0.18.gh.tar.gz 42343 BLAKE2B 702ca6a68733ed202ae0f8a2d9d430012c5786ef8d779903186815f9250ed7b2ccf781694aa57ef230009a470ef7c6bd0e83cc7bc9fcb809d2335542e799e3d6 SHA512 40928e93fa94ca9e67335d15acede73b70906885f8cc34262b00e2dfba9dfed8647f11490ab0df4c8fcfd94778362cfdc4bd0053063660b962202524dd5bda18
+DIST fasteners-0.19.gh.tar.gz 43188 BLAKE2B c30f4dc3da6605aa2552f58ae1071b51efefe2aea59ca8815fd50eebdbe7e826756cd9923485d6fb99dcc39196def485f4c1346a234bc7af09e2426c84b6a0d3 SHA512 47db216ff5bad5c669ca2d9be0ee09feba4a3d55ed0eac8d3623bd3d112b0b87fb9019f8785d035ec32ad9fa9e4ae7d1c92a576c97eec29acc82711d7e71a465
diff --git a/dev-python/fasteners/fasteners-0.19.ebuild b/dev-python/fasteners/fasteners-0.19.ebuild
new file mode 100644
index 000000000000..d3b2343df0d3
--- /dev/null
+++ b/dev-python/fasteners/fasteners-0.19.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python package that provides useful locks"
+HOMEPAGE="
+ https://github.com/harlowja/fasteners/
+ https://pypi.org/project/fasteners/
+"
+SRC_URI="
+ https://github.com/harlowja/fasteners/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+BDEPEND="
+ test? (
+ dev-python/diskcache[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ tests/test_eventlet.py
+)