summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-07-11 18:42:25 -0700
committerPatrick McLean <chutzpah@gentoo.org>2019-07-11 18:42:25 -0700
commit25c4cfe3155a2a6799f503653930f794bd6f4d56 (patch)
treecc276d092a46e81b396366047b2b416439b42430 /dev-python/google-auth-httplib2
parentdev-python/django-debug-toolbar: 2.0 bump (diff)
downloadgentoo-25c4cfe3155a2a6799f503653930f794bd6f4d56.tar.gz
gentoo-25c4cfe3155a2a6799f503653930f794bd6f4d56.tar.bz2
gentoo-25c4cfe3155a2a6799f503653930f794bd6f4d56.zip
dev-python/google-auth-httplib2: Version bump to 0.0.3
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/google-auth-httplib2')
-rw-r--r--dev-python/google-auth-httplib2/Manifest1
-rw-r--r--dev-python/google-auth-httplib2/google-auth-httplib2-0.0.3.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/google-auth-httplib2/Manifest b/dev-python/google-auth-httplib2/Manifest
index 931ab722ce20..9a02a344e47e 100644
--- a/dev-python/google-auth-httplib2/Manifest
+++ b/dev-python/google-auth-httplib2/Manifest
@@ -1 +1,2 @@
DIST google-auth-httplib2-0.0.2.tar.gz 10830 BLAKE2B 7f2092d83c318510b9140791681a58bd3e436f3b5966c8dc53aa5b041e50fdc4f93c276810a0e6ca20b14a919eb37588ae1d027b5eba74f79f44a6809909dd4f SHA512 ec111fdad930bfe3f8f97df70a8bef955920ab2cb0c383d7888ff444f19e5c176dd5aabe10f9a870c86035791a2b27e3e8e1276360626ff5e430db823da5efb0
+DIST google-auth-httplib2-0.0.3.tar.gz 10914 BLAKE2B 20473182a5bd4633d1ae16101d81520ddf182706d478c066e533a2eac3e28fccf2bbaf733eeb4f7ea14d658fe29b9b0c656307bb555aabd2d1a21585e3e3d3ba SHA512 dc39626961dfc67ee56d1c74b4e37e6c6a81ec3c8ddcc24007535acc6a973f2cba5e65a9ece323f53d4dcb4f7bca948d65bde4ab55b2c002432d020cba9d914e
diff --git a/dev-python/google-auth-httplib2/google-auth-httplib2-0.0.3.ebuild b/dev-python/google-auth-httplib2/google-auth-httplib2-0.0.3.ebuild
new file mode 100644
index 000000000000..1b43fb88d253
--- /dev/null
+++ b/dev-python/google-auth-httplib2/google-auth-httplib2-0.0.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy )
+
+inherit distutils-r1
+
+EGIT_COMMIT="e7cd722281d1d897fa9ae6e3b6b78ae142778e6e"
+MY_PN="google-auth-library-python-httplib2"
+DESCRIPTION="httplib2 Transport for Google Auth"
+HOMEPAGE="https://pypi.org/project/google-auth-httplib2/ https://github.com/GoogleCloudPlatform/google-auth-library-python-httplib2"
+# PyPi tarball is missing unit tests
+#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/GoogleCloudPlatform/google-auth-library-python-httplib2/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/google-auth[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/${MY_PN}-${EGIT_COMMIT}"
+
+python_test() {
+ pytest -vv || die "Tests failed under ${EPYTHON}"
+}