summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-23 04:22:18 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-23 04:37:11 +0100
commitaf3c41cec59c2202f827bcd7d202b425e15cf3a3 (patch)
treece7b0454db23b0ab4d09d1172281995b2ee19d17 /dev-python/oslo-config
parentdev-python/oslo-i18n: Bump to 6.3.0 (diff)
downloadgentoo-af3c41cec59c2202f827bcd7d202b425e15cf3a3.tar.gz
gentoo-af3c41cec59c2202f827bcd7d202b425e15cf3a3.tar.bz2
gentoo-af3c41cec59c2202f827bcd7d202b425e15cf3a3.zip
dev-python/oslo-config: Bump to 9.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/oslo-config')
-rw-r--r--dev-python/oslo-config/Manifest1
-rw-r--r--dev-python/oslo-config/oslo-config-9.4.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/oslo-config/Manifest b/dev-python/oslo-config/Manifest
index 079ada6f8d71..14b996113923 100644
--- a/dev-python/oslo-config/Manifest
+++ b/dev-python/oslo-config/Manifest
@@ -1 +1,2 @@
DIST oslo.config-9.3.0.tar.gz 161132 BLAKE2B 4971a9974f68db25080a70160636bf9c81effb8a817598d4c09aa2337fe69e9bdac4d2b19948d17f225bfcb20bbc65e1ddeb6a24e51792a8246033b5290e3fe1 SHA512 5472c44839724b11a1b4b31113c36716ce2c3dbb5e6500cb743cbfb7c73dc6ef878b4219b17d3178d7d8c2b7a46377a2d083cb21768dc82878078d3faed74514
+DIST oslo.config-9.4.0.tar.gz 161322 BLAKE2B 3edd3be09ebe777ebcb4cd79171bae764046f6ceb0f0c9ca8f88388f1a0bcd23d2bb4e4130ab81a7f3cf063ce0ee668ffbcd8c4bf9f633213e97dcd12e2575dd SHA512 d404876c34c82963af8b992091fd1186855b3ced9a6a574ca4fc152a5b50bfc1945aca04e163770d8bec948cb57904a83eae9e3d7c4c3b852c90987f73e66ba9
diff --git a/dev-python/oslo-config/oslo-config-9.4.0.ebuild b/dev-python/oslo-config/oslo-config-9.4.0.ebuild
new file mode 100644
index 000000000000..4d5e415463a5
--- /dev/null
+++ b/dev-python/oslo-config/oslo-config-9.4.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/.}
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Oslo Configuration API"
+HOMEPAGE="
+ https://opendev.org/openstack/oslo.config/
+ https://github.com/openstack/oslo.config/
+ https://pypi.org/project/oslo.config/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/pbr-1.3[${PYTHON_USEDEP}]
+ >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/netaddr-0.7.18[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/rfc3986-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.18.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pbr-1.3[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-mock-1.5.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # broken by some dep upgrade
+ sed -i -e '/DeprecationWarningTestsNoOsloLog/,$d' \
+ oslo_config/tests/test_cfg.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x COLUMNS=80
+ eunittest -b
+}