summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-15 17:23:28 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-15 19:33:02 +0200
commit4ee6977a1380729e115528ab959815482b469b74 (patch)
tree742989ac9c5715e238b2d6b35ddc757b8fb5670a /dev-python/podman
parentdev-python/portalocker: Enable py3.13 (diff)
downloadgentoo-4ee6977a1380729e115528ab959815482b469b74.tar.gz
gentoo-4ee6977a1380729e115528ab959815482b469b74.tar.bz2
gentoo-4ee6977a1380729e115528ab959815482b469b74.zip
dev-python/podman: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/podman')
-rw-r--r--dev-python/podman/Manifest1
-rw-r--r--dev-python/podman/podman-4.9.0.ebuild53
2 files changed, 0 insertions, 54 deletions
diff --git a/dev-python/podman/Manifest b/dev-python/podman/Manifest
index 9c6b0e48c1ff..c1ce992c1b9b 100644
--- a/dev-python/podman/Manifest
+++ b/dev-python/podman/Manifest
@@ -1,2 +1 @@
-DIST podman-py-4.9.0.gh.tar.gz 182639 BLAKE2B fce3efa75658bb29513fdb55fa8b51d41401a49d58c2ea3c17c037e435f1f822090c6cc12b1afd06aec7e96c2541abb898fc37a0d2a62fcc5cddeeaf7832a0c0 SHA512 73488ccd3e910284410a43ec607cefdab3b8f3478617b95d5a6efd6f817a3eaced1a5ac9993d13c0104bad1bcd868507d544ef0396202003bb2f8b024901396c
DIST podman-py-5.0.0.gh.tar.gz 183844 BLAKE2B c2c5511815d37321a843dfe028839592f6e9b4cc580263e743b6a2ee0917b3307b77bf4d08b327781c6d765c231d8bfcc4d1e0027351c4297509433405887552 SHA512 3abcc4c989843fb82a09e32359018cb9b3352f014253def4bec46a7336c95405b50fe774192d2f4625748351c57293b70d393eb85671719833c0a9f1311612ed
diff --git a/dev-python/podman/podman-4.9.0.ebuild b/dev-python/podman/podman-4.9.0.ebuild
deleted file mode 100644
index 9567fabe9519..000000000000
--- a/dev-python/podman/podman-4.9.0.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-MY_P=podman-py-${PV/_p/.post}
-DESCRIPTION="A library to interact with a Podman server"
-HOMEPAGE="
- https://github.com/containers/podman-py/
- https://pypi.org/project/podman/
-"
-SRC_URI="
- https://github.com/containers/podman-py/archive/v${PV/_p/.post}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- >=dev-python/pyxdg-0.26[${PYTHON_USEDEP}]
- >=dev-python/requests-2.24[${PYTHON_USEDEP}]
- >=dev-python/rich-12.5.1[${PYTHON_USEDEP}]
- dev-python/urllib3[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/tomli-1.2.3[${PYTHON_USEDEP}]
- ' 3.10)
-"
-BDEPEND="
- test? (
- >=dev-python/requests-mock-1.11.0[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # TODO
- podman/tests/unit/test_volumesmanager.py::VolumesManagerTestCase::test_get_404
- )
-
- # integration tests require a workable podman server,
- # and it doesn't seem to work in ebuild env
- epytest podman/tests/unit
-}