summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-28 18:14:02 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-28 18:14:02 +0100
commit5d4edbc607d3863f7838d0d1ebc3dfacba32200e (patch)
treec5939bbf9ec3462e71aca497e095b577f96e983d /dev-python/pycuda
parentdev-python/pycryptodome: Remove redundant versions (diff)
downloadgentoo-5d4edbc607d3863f7838d0d1ebc3dfacba32200e.tar.gz
gentoo-5d4edbc607d3863f7838d0d1ebc3dfacba32200e.tar.bz2
gentoo-5d4edbc607d3863f7838d0d1ebc3dfacba32200e.zip
dev-python/pycuda: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pycuda')
-rw-r--r--dev-python/pycuda/Manifest1
-rw-r--r--dev-python/pycuda/pycuda-2017.1.ebuild82
2 files changed, 0 insertions, 83 deletions
diff --git a/dev-python/pycuda/Manifest b/dev-python/pycuda/Manifest
index aaeea72adc58..ab240aa519cc 100644
--- a/dev-python/pycuda/Manifest
+++ b/dev-python/pycuda/Manifest
@@ -1,2 +1 @@
-DIST pycuda-2017.1.tar.gz 1608187 BLAKE2B 483bfd8e2da6d1c2dee9f1b5512e3f8120b29aa87d5fab49d7b1b738e9949aba14f87b102c5ff04cd2f2061c6c64c5036fdea71129e35505cce00ce76b6943aa SHA512 ce3de28de613352bec4efb86ffaa055f92ccd0c758b903aecc60af5b84f0f0643d04a869d6a23ce329c3d33670cfb266ad69c784ba917a190a11bdfea1fe6690
DIST pycuda-2018.1.1.tar.gz 1612853 BLAKE2B 7afbcc33891da96d726f07f1686bfb9a28b4a5ce3dfc754707166556153f91a0fbc3454d50ca678ac56b71e8dc15e8f7b797e8ff025e42aa9eed2eaaa797d952 SHA512 cb93855cf3cee6650ba0564bccce73c2f59ecbd579235eb3623ec32dde8d9247216e756b1342a876fc7d37c0159e741f5f626a86f2e7ab11c4b03c7a4e581a28
diff --git a/dev-python/pycuda/pycuda-2017.1.ebuild b/dev-python/pycuda/pycuda-2017.1.ebuild
deleted file mode 100644
index 74f9a3f6aef6..000000000000
--- a/dev-python/pycuda/pycuda-2017.1.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit cuda distutils-r1
-
-DESCRIPTION="Python wrapper for NVIDIA CUDA"
-HOMEPAGE="https://mathema.tician.de/software/pycuda/ https://pypi.org/project/pycuda/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="examples opengl test"
-
-RDEPEND="
- dev-libs/boost:=[python,${PYTHON_USEDEP}]
- dev-python/decorator[${PYTHON_USEDEP}]
- dev-python/mako[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- >=dev-python/pytools-2013[${PYTHON_USEDEP}]
- dev-util/nvidia-cuda-toolkit
- x11-drivers/nvidia-drivers
- opengl? ( virtual/opengl )"
-DEPEND="${RDEPEND}
- test? (
- dev-python/mako[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}] )"
-
-# We need write acccess /dev/nvidia0 and /dev/nvidiactl and the portage
-# user is (usually) not in the video group
-RESTRICT="userpriv !test? ( test )"
-
-python_prepare_all() {
- cuda_sanitize
- sed -e "s:'--preprocess':\'--preprocess\', \'--compiler-bindir=$(cuda_gccdir)\':g" \
- -e "s:\"--cubin\":\'--cubin\', \'--compiler-bindir=$(cuda_gccdir)\':g" \
- -e "s:/usr/include/pycuda:${S}/src/cuda:g" \
- -i pycuda/compiler.py || die
-
- touch siteconf.py || die
- distutils-r1_python_prepare_all
-}
-
-python_configure() {
- mkdir -p "${BUILD_DIR}" || die
- cd "${BUILD_DIR}" || die
- rm -f ./siteconf.py || die
- "${EPYTHON}" "${S}"/configure.py \
- --boost-inc-dir="${EPREFIX}/usr/include" \
- --boost-lib-dir="${EPREFIX}/usr/$(get_libdir)" \
- --boost-python-libname=boost_python-$(echo ${EPYTHON} | sed 's/python//')-mt \
- --boost-thread-libname=boost_thread-mt \
- --cuda-root="${EPREFIX}/opt/cuda" \
- --cudadrv-lib-dir="${EPREFIX}/usr/$(get_libdir)" \
- --cudart-lib-dir="${EPREFIX}/opt/cuda/$(get_libdir)" \
- --cuda-inc-dir="${EPREFIX}/opt/cuda/include" \
- --no-use-shipped-boost \
- $(usex opengl --cuda-enable-gl "") || die
-}
-
-src_test() {
- # we need write access to this to run the tests
- addwrite /dev/nvidia0
- addwrite /dev/nvidiactl
- python_test() {
- py.test --debug -v -v -v || die "Tests fail with ${EPYTHON}"
- }
- distutils-r1_src_test
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
-
- fi
-}